summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-09-03 07:00:33 +0000
committerJustin Lecher <jlec@gentoo.org>2012-09-03 07:00:33 +0000
commit50339875fa174e5f8301dd64b46fcb4fbe2e6e69 (patch)
treefbead4e34508d41aa1295c68dd6b45c9e2af5276 /net-analyzer/linkchecker
parentmask dev-php/pecl-memcached igbinary until the keywording catches up (diff)
downloadgentoo-2-50339875fa174e5f8301dd64b46fcb4fbe2e6e69.tar.gz
gentoo-2-50339875fa174e5f8301dd64b46fcb4fbe2e6e69.tar.bz2
gentoo-2-50339875fa174e5f8301dd64b46fcb4fbe2e6e69.zip
net-analyzer/linkchecker: Version Bump
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/linkchecker')
-rw-r--r--net-analyzer/linkchecker/ChangeLog8
-rw-r--r--net-analyzer/linkchecker/files/8.0-missing-files.patch13
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-8.0-desktop.patch28
-rw-r--r--net-analyzer/linkchecker/linkchecker-8.0.ebuild79
-rw-r--r--net-analyzer/linkchecker/metadata.xml1
5 files changed, 128 insertions, 1 deletions
diff --git a/net-analyzer/linkchecker/ChangeLog b/net-analyzer/linkchecker/ChangeLog
index 96027374065c..7a99b3a0ae51 100644
--- a/net-analyzer/linkchecker/ChangeLog
+++ b/net-analyzer/linkchecker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/linkchecker
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.77 2012/08/26 09:41:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.78 2012/09/03 07:00:33 jlec Exp $
+
+*linkchecker-8.0 (03 Sep 2012)
+
+ 03 Sep 2012; Justin Lecher <jlec@gentoo.org> +files/8.0-missing-files.patch,
+ +linkchecker-8.0.ebuild, +files/linkchecker-8.0-desktop.patch, metadata.xml:
+ Version Bump
26 Aug 2012; Justin Lecher <jlec@gentoo.org> -files/5.2-missing-files.patch,
-linkchecker-7.1.ebuild, -linkchecker-7.6.ebuild, -linkchecker-7.7.ebuild,
diff --git a/net-analyzer/linkchecker/files/8.0-missing-files.patch b/net-analyzer/linkchecker/files/8.0-missing-files.patch
new file mode 100644
index 000000000000..165783ccb671
--- /dev/null
+++ b/net-analyzer/linkchecker/files/8.0-missing-files.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 38b4c15..716203d 100755
+--- a/setup.py
++++ b/setup.py
+@@ -375,7 +375,7 @@ myemail = "calvin@users.sourceforge.net"
+ data_files = [
+ ('share/linkchecker',
+ ['config/linkcheckerrc', 'config/ca-certificates.crt',
+- 'doc/html/lccollection.qhc', 'doc/html/lcdoc.qch']),
++ 'doc/html/lccollection.qhcp', 'doc/html/lcdoc.qhp']),
+ ('share/linkchecker/examples',
+ ['cgi-bin/lconline/leer.html.en',
+ 'cgi-bin/lconline/leer.html.de',
diff --git a/net-analyzer/linkchecker/files/linkchecker-8.0-desktop.patch b/net-analyzer/linkchecker/files/linkchecker-8.0-desktop.patch
new file mode 100644
index 000000000000..dc07637e0fac
--- /dev/null
+++ b/net-analyzer/linkchecker/files/linkchecker-8.0-desktop.patch
@@ -0,0 +1,28 @@
+ doc/linkchecker-gui.desktop | 2 +-
+ doc/linkchecker.desktop | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/doc/linkchecker-gui.desktop b/doc/linkchecker-gui.desktop
+index 7e06b6e..1b3988f 100644
+--- a/doc/linkchecker-gui.desktop
++++ b/doc/linkchecker-gui.desktop
+@@ -6,5 +6,5 @@ Version=1.0
+ Type=Application
+ Exec=linkchecker-gui
+ Terminal=false
+-Categories=Network;WebDevelopment
++Categories=Network;WebDevelopment;
+ Icon=logo48x48
+diff --git a/doc/linkchecker.desktop b/doc/linkchecker.desktop
+index 0c0617c..7a88405 100644
+--- a/doc/linkchecker.desktop
++++ b/doc/linkchecker.desktop
+@@ -5,6 +5,6 @@ GenericName[de]=URL Validator
+ Version=1.0
+ Type=Application
+ Exec=linkchecker
+-Terminal=True
+-Categories=Network;WebDevelopment
++Terminal=true
++Categories=Network;WebDevelopment;
+ Icon=logo48x48
diff --git a/net-analyzer/linkchecker/linkchecker-8.0.ebuild b/net-analyzer/linkchecker/linkchecker-8.0.ebuild
new file mode 100644
index 000000000000..aef495aa4452
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-8.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/linkchecker-8.0.ebuild,v 1.1 2012/09/03 07:00:33 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 2.6 3.*"
+PYTHON_MODNAME="linkcheck"
+
+inherit bash-completion-r1 distutils eutils
+
+MY_P="${P/linkchecker/LinkChecker}"
+
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="http://linkchecker.sourceforge.net/ http://pypi.python.org/pypi/linkchecker/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x64-solaris"
+IUSE="bash-completion bookmarks clamav doc geoip gnome login nagios syntax-check X"
+
+RDEPEND="
+ dev-python/dnspython
+ bash-completion? ( dev-python/optcomplete )
+ bookmarks? ( dev-python/pysqlite:2 )
+ clamav? ( app-antivirus/clamav )
+ geoip? ( dev-python/geoip-python )
+ gnome? ( dev-python/pygtk:2 )
+ login? ( dev-python/twill )
+ syntax-check? (
+ dev-python/cssutils
+ dev-python/utidylib
+ )
+ X? (
+ dev-python/PyQt4[X,assistant]
+ dev-python/qscintilla-python
+ )"
+DEPEND="
+ doc? ( x11-libs/qt-assistant )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-missing-files.patch \
+ "${FILESDIR}"/7.0-unbundle.patch \
+ "${FILESDIR}"/${P}-desktop.patch
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C doc/html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ delete_gui() {
+ rm -rf \
+ "${ED}"/usr/bin/linkchecker-gui* \
+ "${ED}"/$(python_get_sitedir)/linkcheck/gui* || die
+ }
+ python_execute_function -q delete_gui
+ fi
+ if use doc; then
+ dohtml doc/html/*
+ fi
+ use bash-completion && dobashcomp config/linkchecker-completion
+ insinto /usr/$(get_libdir)/nagios/plugins
+ use nagios && doins linkchecker-nagios
+}
diff --git a/net-analyzer/linkchecker/metadata.xml b/net-analyzer/linkchecker/metadata.xml
index 43d46e8d3647..4c81bd541f92 100644
--- a/net-analyzer/linkchecker/metadata.xml
+++ b/net-analyzer/linkchecker/metadata.xml
@@ -7,6 +7,7 @@
<use>
<flag name="bookmarks">Mozilla Bookmark parsing</flag>
<flag name="login">login form submission</flag>
+ <flag name="nagios">Install nagios cli plugin</flag>
<flag name="syntax-check">HTML/CSS syntax checks</flag>
</use>
</pkgmetadata>