summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-07-20 09:15:42 +0000
committerFabian Groffen <grobian@gentoo.org>2007-07-20 09:15:42 +0000
commit662b085d3759a8580c32a2f68ef085b01ebaa5e9 (patch)
tree7ce6f3437d531a02edb91b17e3bbe039c98bcf51 /net-analyzer/mtr
parentVersion bump (diff)
downloadgentoo-2-662b085d3759a8580c32a2f68ef085b01ebaa5e9.tar.gz
gentoo-2-662b085d3759a8580c32a2f68ef085b01ebaa5e9.tar.bz2
gentoo-2-662b085d3759a8580c32a2f68ef085b01ebaa5e9.zip
make Jakub happy in bug #185960
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-analyzer/mtr')
-rw-r--r--net-analyzer/mtr/mtr-0.69-r1.ebuild6
-rw-r--r--net-analyzer/mtr/mtr-0.71.ebuild6
-rw-r--r--net-analyzer/mtr/mtr-0.72.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/net-analyzer/mtr/mtr-0.69-r1.ebuild b/net-analyzer/mtr/mtr-0.69-r1.ebuild
index 6fb6df79e61d..0388e72fc533 100644
--- a/net-analyzer/mtr/mtr-0.69-r1.ebuild
+++ b/net-analyzer/mtr/mtr-0.69-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.69-r1.ebuild,v 1.14 2007/07/19 17:55:30 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.69-r1.ebuild,v 1.15 2007/07/20 09:15:42 grobian Exp $
inherit eutils flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc s390 sparc x86"
-IUSE="gtk ipv6 ppc-macos"
+IUSE="gtk ipv6"
DEPEND="dev-util/pkgconfig
sys-libs/ncurses
@@ -31,7 +31,7 @@ src_compile() {
local myconf
use gtk || myconf="${myconf} --without-gtk"
- use ppc-macos && append-flags "-DBIND_8_COMPAT"
+ [[ ${CHOST} == *-darwin* ]] && append-flags "-DBIND_8_COMPAT"
append-ldflags $(bindnow-flags)
econf ${myconf} \
diff --git a/net-analyzer/mtr/mtr-0.71.ebuild b/net-analyzer/mtr/mtr-0.71.ebuild
index 83a37b10fec2..a60a9a6ba332 100644
--- a/net-analyzer/mtr/mtr-0.71.ebuild
+++ b/net-analyzer/mtr/mtr-0.71.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.71.ebuild,v 1.3 2007/07/19 17:55:30 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.71.ebuild,v 1.4 2007/07/20 09:15:42 grobian Exp $
inherit eutils flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sparc ~x86"
-IUSE="gtk ipv6 ppc-macos"
+IUSE="gtk ipv6"
DEPEND="dev-util/pkgconfig
sys-libs/ncurses
@@ -23,7 +23,7 @@ src_compile() {
local myconf
use gtk || myconf="${myconf} --without-gtk"
- use ppc-macos && append-flags "-DBIND_8_COMPAT"
+ [[ ${CHOST} == *-darwin* ]] && append-flags "-DBIND_8_COMPAT"
append-ldflags $(bindnow-flags)
econf ${myconf} \
diff --git a/net-analyzer/mtr/mtr-0.72.ebuild b/net-analyzer/mtr/mtr-0.72.ebuild
index 5f5ef1bd619f..8d65bc8f0d0b 100644
--- a/net-analyzer/mtr/mtr-0.72.ebuild
+++ b/net-analyzer/mtr/mtr-0.72.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.72.ebuild,v 1.10 2007/07/19 17:55:30 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.72.ebuild,v 1.11 2007/07/20 09:15:42 grobian Exp $
inherit flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc s390 sh sparc x86"
-IUSE="gtk ipv6 ppc-macos"
+IUSE="gtk ipv6"
DEPEND="dev-util/pkgconfig
sys-libs/ncurses
@@ -21,7 +21,7 @@ src_compile() {
local myconf
use gtk || myconf="${myconf} --without-gtk"
- use ppc-macos && append-flags "-DBIND_8_COMPAT"
+ [[ ${CHOST} == *-darwin* ]] && append-flags "-DBIND_8_COMPAT"
append-ldflags $(bindnow-flags)
econf ${myconf} \