summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-11-16 14:40:13 +0000
committerPeter Volkov <pva@gentoo.org>2008-11-16 14:40:13 +0000
commit94b44b204b0bcaed7cfd362e7cb839693c0a4614 (patch)
treec8e50220ba3b7c1338a23d853f4bc9f8a100bbb9 /net-analyzer/mtr
parentfix #238347; cleanup (diff)
downloadgentoo-2-94b44b204b0bcaed7cfd362e7cb839693c0a4614.tar.gz
gentoo-2-94b44b204b0bcaed7cfd362e7cb839693c0a4614.tar.bz2
gentoo-2-94b44b204b0bcaed7cfd362e7cb839693c0a4614.zip
Version bump, bug #226989, thank Krzysztof Olędzki for report. Finally removed all bind-now flags, #226989, thank Diego Pettenò for report. Remove old.
(Portage version: 2.2_rc14/cvs/Linux 2.6.26-openvz.git-35f41f1 i686)
Diffstat (limited to 'net-analyzer/mtr')
-rw-r--r--net-analyzer/mtr/ChangeLog10
-rw-r--r--net-analyzer/mtr/files/mtr-0.69-debian.patch93
-rw-r--r--net-analyzer/mtr/mtr-0.72.ebuild46
-rw-r--r--net-analyzer/mtr/mtr-0.73-r1.ebuild57
-rw-r--r--net-analyzer/mtr/mtr-0.73.ebuild53
-rw-r--r--net-analyzer/mtr/mtr-0.75.ebuild37
6 files changed, 46 insertions, 250 deletions
diff --git a/net-analyzer/mtr/ChangeLog b/net-analyzer/mtr/ChangeLog
index f17efd8908ef..8eb542b4e12c 100644
--- a/net-analyzer/mtr/ChangeLog
+++ b/net-analyzer/mtr/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/mtr
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/ChangeLog,v 1.81 2008/10/26 20:20:47 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/ChangeLog,v 1.82 2008/11/16 14:40:13 pva Exp $
+
+*mtr-0.75 (16 Nov 2008)
+
+ 16 Nov 2008; Peter Volkov <pva@gentoo.org> -files/mtr-0.69-debian.patch,
+ -mtr-0.72.ebuild, -mtr-0.73.ebuild, -mtr-0.73-r1.ebuild, +mtr-0.75.ebuild:
+ Version bump, bug #226989, thank Krzysztof Olędzki for report. Finally
+ removed all bind-now flags, #226989, thank Diego Pettenò for report.
+ Remove old.
26 Oct 2008; Joshua Kinard <kumba@gentoo.org> mtr-0.73-r2.ebuild:
Mark mtr-0.73-r2 unstable on mips.
diff --git a/net-analyzer/mtr/files/mtr-0.69-debian.patch b/net-analyzer/mtr/files/mtr-0.69-debian.patch
deleted file mode 100644
index 5842777d4de6..000000000000
--- a/net-analyzer/mtr/files/mtr-0.69-debian.patch
+++ /dev/null
@@ -1,93 +0,0 @@
---- mtr-0.69.orig/mtr.c
-+++ mtr-0.69/mtr.c
-@@ -388,10 +388,6 @@
- }
-
-
-- if (net_set_interfaceaddress (InterfaceAddress) != 0) {
-- fprintf (stderr, "mtr: Couldn't set interface addres.\n");
-- exit (1);
-- }
-
- #ifdef ENABLE_IPV6
- /* gethostbyname2() is deprecated so we'll use getaddrinfo() instead. */
-@@ -442,6 +438,11 @@
- exit(1);
- }
-
-+ if (net_set_interfaceaddress (InterfaceAddress) != 0) {
-+ fprintf (stderr, "mtr: Couldn't set interface address.\n");
-+ exit (1);
-+ }
-+
- display_open();
- dns_open();
-
---- mtr-0.69.orig/net.c
-+++ mtr-0.69/net.c
-@@ -322,7 +322,15 @@
- int oldavg; /* usedByMin */
- int oldjavg; /* usedByMin */
- int i; /* usedByMin */
-+#ifdef ENABLE_IPV6
-+ char addrcopy[sizeof(struct in6_addr)];
-+#else
-+ char addrcopy[sizeof(struct in_addr)];
-+#endif
-
-+ /* Copy the from address ASAP because it can be overwritten */
-+ addrcpy( (void *) &addrcopy, addr, af );
-+
- if (seq < 0 || seq >= MaxSequence)
- return;
-
-@@ -339,22 +347,22 @@
- if ( addrcmp( (void *) &(host[index].addr),
- (void *) &unspec_addr, af ) == 0 ) {
- // should be out of if as addr can change
-- addrcpy( (void *) &(host[index].addr), addr, af );
-+ addrcpy( (void *) &(host[index].addr), addrcopy, af );
- display_rawhost(index, (void *) &(host[index].addr));
-
- /* multi paths by Min */
-- addrcpy( (void *) &(host[index].addrs[0]), addr, af );
-+ addrcpy( (void *) &(host[index].addrs[0]), addrcopy, af );
- } else {
- for( i=0; i<MAXPATH; ) {
-- if( addrcmp( (void *) &(host[index].addrs[i]), (void *) &addr,
-+ if( addrcmp( (void *) &(host[index].addrs[i]), (void *) &addrcopy,
- af ) == 0 ||
- addrcmp( (void *) &(host[index].addrs[i]),
- (void *) &unspec_addr, af ) == 0 ) break;
- i++;
- }
-- if( addrcmp( (void *) &(host[index].addrs[i]), addr, af ) != 0 &&
-+ if( addrcmp( (void *) &(host[index].addrs[i]), addrcopy, af ) != 0 &&
- i<MAXPATH ) {
-- addrcpy( (void *) &(host[index].addrs[i]), addr, af );
-+ addrcpy( (void *) &(host[index].addrs[i]), addrcopy, af );
- }
- /* end multi paths */
- }
-@@ -911,8 +919,10 @@
-
- void net_close(void)
- {
-- close(sendsock);
-- close(recvsock);
-+ if (sendsock4 >= 0) close(sendsock4);
-+ if (recvsock4 >= 0) close(recvsock4);
-+ if (sendsock6 >= 0) close(sendsock6);
-+ if (recvsock6 >= 0) close(recvsock6);
- }
-
-
---- mtr-0.69.orig/net.h
-+++ mtr-0.69/net.h
-@@ -117,3 +117,6 @@
- extern char available_options[];
-
- ip_t unspec_addr;
-+
-+FILE *ADDRCMP;
-+int i;
diff --git a/net-analyzer/mtr/mtr-0.72.ebuild b/net-analyzer/mtr/mtr-0.72.ebuild
deleted file mode 100644
index 00994bc31e40..000000000000
--- a/net-analyzer/mtr/mtr-0.72.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.72.ebuild,v 1.12 2008/05/06 13:47:24 drac Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="My TraceRoute. Excellent network diagnostic tool."
-HOMEPAGE="http://www.bitwizard.nl/mtr/"
-SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc s390 sh sparc x86"
-IUSE="gtk ipv6"
-
-RDEPEND="sys-libs/ncurses
- gtk? ( >=x11-libs/gtk+-2 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_compile() {
- local myconf
- use gtk || myconf="${myconf} --without-gtk"
-
- [[ ${CHOST} == *-darwin* ]] && append-flags "-DBIND_8_COMPAT"
- append-ldflags $(bindnow-flags)
-
- econf ${myconf} \
- $(use_enable gtk gtk2) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- # this binary is universal. ie: it does both console and gtk.
- make DESTDIR="${D}" sbindir=/usr/bin install || die "make install failed"
-
- insinto /usr/share/${PN} ; doins img/mtr_icon.xpm
-
- fowners root:wheel /usr/bin/mtr
- fperms 4710 /usr/bin/mtr
-
- dodoc AUTHORS ChangeLog FORMATS NEWS README SECURITY TODO
-}
diff --git a/net-analyzer/mtr/mtr-0.73-r1.ebuild b/net-analyzer/mtr/mtr-0.73-r1.ebuild
deleted file mode 100644
index 695da04ff4da..000000000000
--- a/net-analyzer/mtr/mtr-0.73-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.73-r1.ebuild,v 1.3 2008/11/09 12:15:15 vapier Exp $
-
-inherit flag-o-matic autotools eutils
-
-DESCRIPTION="My TraceRoute. Excellent network diagnostic tool."
-HOMEPAGE="http://www.bitwizard.nl/mtr/"
-SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz
- mirror://gentoo/gtk-2.0-for-mtr.m4.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha ~amd64 arm ~hppa ia64 ~ppc s390 sh sparc x86"
-IUSE="gtk ipv6"
-
-RDEPEND="sys-libs/ncurses
- gtk? ( >=x11-libs/gtk+-2 )"
-DEPEND="${RDEPEND}
- gtk? ( dev-util/pkgconfig )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- mv "${WORKDIR}"/gtk-2.0-for-mtr.m4 gtk-2.0.m4
- epatch "${FILESDIR}"/${P}-am_path_gtk.patch
- epatch "${FILESDIR}"/${P}-CVE-2008-2357.patch
- AT_M4DIR="." eautoreconf
-}
-
-src_compile() {
- local myconf
- use gtk || myconf="${myconf} --without-gtk"
-
- [[ ${CHOST} == *-darwin* ]] && append-flags "-DBIND_8_COMPAT"
-
- econf ${myconf} \
- $(use_enable gtk gtk2) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- # this binary is universal. ie: it does both console and gtk.
- emake DESTDIR="${D}" install || die "make install failed"
-
- insinto /usr/share/${PN}
- doins img/mtr_icon.xpm
-
- fowners root:wheel /usr/bin/mtr
- fperms 4710 /usr/bin/mtr
-
- dodoc AUTHORS ChangeLog FORMATS NEWS README SECURITY TODO
-}
diff --git a/net-analyzer/mtr/mtr-0.73.ebuild b/net-analyzer/mtr/mtr-0.73.ebuild
deleted file mode 100644
index c34c402e2114..000000000000
--- a/net-analyzer/mtr/mtr-0.73.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.73.ebuild,v 1.1 2008/05/18 12:21:59 cedk Exp $
-
-inherit flag-o-matic autotools eutils
-
-DESCRIPTION="My TraceRoute. Excellent network diagnostic tool."
-HOMEPAGE="http://www.bitwizard.nl/mtr/"
-SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~x86"
-IUSE="gtk ipv6"
-
-RDEPEND="sys-libs/ncurses
- gtk? ( >=x11-libs/gtk+-2 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-am_path_gtk.patch"
- eautoreconf
-}
-
-src_compile() {
- local myconf
- use gtk || myconf="${myconf} --without-gtk"
-
- [[ ${CHOST} == *-darwin* ]] && append-flags "-DBIND_8_COMPAT"
-
- econf ${myconf} \
- $(use_enable gtk gtk2) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- # this binary is universal. ie: it does both console and gtk.
- emake DESTDIR="${D}" sbindir=/usr/bin install || die "make install failed"
-
- insinto /usr/share/${PN}
- doins img/mtr_icon.xpm
-
- fowners root:wheel /usr/bin/mtr
- fperms 4710 /usr/bin/mtr
-
- dodoc AUTHORS ChangeLog FORMATS NEWS README SECURITY TODO
-}
diff --git a/net-analyzer/mtr/mtr-0.75.ebuild b/net-analyzer/mtr/mtr-0.75.ebuild
new file mode 100644
index 000000000000..4a8fd31d5524
--- /dev/null
+++ b/net-analyzer/mtr/mtr-0.75.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.75.ebuild,v 1.1 2008/11/16 14:40:13 pva Exp $
+
+DESCRIPTION="My TraceRoute. Excellent network diagnostic tool."
+HOMEPAGE="http://www.bitwizard.nl/mtr/"
+SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz
+ mirror://gentoo/gtk-2.0-for-mtr.m4.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="gtk ipv6"
+
+RDEPEND="sys-libs/ncurses
+ gtk? ( >=x11-libs/gtk+-2.4.0 )"
+DEPEND="${RDEPEND}
+ gtk? ( dev-util/pkgconfig )"
+
+# I've kept gtk-2.0.m4 in SRC_URI but you'll have to mv it before autoreconf
+# mv "${WORKDIR}"/gtk-2.0-for-mtr.m4 gtk-2.0.m4 #222909
+src_compile() {
+ econf \
+ $(use_with gtk) \
+ $(use_enable ipv6)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ fowners root:0 /usr/sbin/mtr
+ fperms 4710 /usr/sbin/mtr
+
+ dodoc AUTHORS ChangeLog FORMATS NEWS README SECURITY TODO || die
+}