summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-10-22 09:24:58 +0000
committerPeter Volkov <pva@gentoo.org>2009-10-22 09:24:58 +0000
commitf41d5ad59c77f10615f8a77fcf7e23c0700c5711 (patch)
tree86e304a66edcde03c25a525fd79499139b9372b0 /net-analyzer/mtr
parentfixed poppler dependency (diff)
downloadgentoo-2-f41d5ad59c77f10615f8a77fcf7e23c0700c5711.tar.gz
gentoo-2-f41d5ad59c77f10615f8a77fcf7e23c0700c5711.tar.bz2
gentoo-2-f41d5ad59c77f10615f8a77fcf7e23c0700c5711.zip
Fixed build issue with gcc-3.4.6, bug #248800, thank barthek for report.
(Portage version: 2.1.7.1/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/mtr')
-rw-r--r--net-analyzer/mtr/ChangeLog8
-rw-r--r--net-analyzer/mtr/files/mtr-0.75--Wno-pointer-sign.patch20
-rw-r--r--net-analyzer/mtr/mtr-0.75.ebuild20
3 files changed, 39 insertions, 9 deletions
diff --git a/net-analyzer/mtr/ChangeLog b/net-analyzer/mtr/ChangeLog
index 8eb542b4e12c..abb033b5186e 100644
--- a/net-analyzer/mtr/ChangeLog
+++ b/net-analyzer/mtr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/mtr
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/ChangeLog,v 1.82 2008/11/16 14:40:13 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/ChangeLog,v 1.83 2009/10/22 09:24:57 pva Exp $
+
+ 22 Oct 2009; Peter Volkov <pva@gentoo.org> mtr-0.75.ebuild,
+ +files/mtr-0.75--Wno-pointer-sign.patch:
+ Fixed build issue with gcc-3.4.6, bug #248800, thank barthek for report.
*mtr-0.75 (16 Nov 2008)
diff --git a/net-analyzer/mtr/files/mtr-0.75--Wno-pointer-sign.patch b/net-analyzer/mtr/files/mtr-0.75--Wno-pointer-sign.patch
new file mode 100644
index 000000000000..5c63bbe1fd6e
--- /dev/null
+++ b/net-analyzer/mtr/files/mtr-0.75--Wno-pointer-sign.patch
@@ -0,0 +1,20 @@
+=== modified file 'configure.in'
+--- configure.in 2009-05-24 15:45:58 +0000
++++ configure.in 2009-05-24 16:02:19 +0000
+@@ -107,8 +107,13 @@
+ AC_MSG_CHECKING(for C flags to get more warnings)
+ ac_save_CFLAGS="$CFLAGS"
+ if test "x$ac_cv_c_compiler_gnu" = "xyes" ; then
+- dnl gcc is the easiest C compiler
+- warning_CFLAGS="-Wall -Wno-pointer-sign"
++ warning_CFLAGS="-Wall"
++ # Check if compiler supports -Wno-pointer-sign and add it if supports
++ CFLAGS_saved="$CFLAGS"
++ CFLAGS="$CFLAGS -Wno-pointer-sign"
++ AC_COMPILE_IFELSE([ AC_LANG_SOURCE([[ int foo; ]])],
++ [ warning_CFLAGS="${warning_CFLAGS} -Wno-pointer-sign" ],)
++ CFLAGS="$CFLAGS_saved"
+ else
+ dnl Vendor supplied C compilers are a bit tricky
+ case "$host_os" in
+
diff --git a/net-analyzer/mtr/mtr-0.75.ebuild b/net-analyzer/mtr/mtr-0.75.ebuild
index 4a8fd31d5524..20cf069b460d 100644
--- a/net-analyzer/mtr/mtr-0.75.ebuild
+++ b/net-analyzer/mtr/mtr-0.75.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.75.ebuild,v 1.1 2008/11/16 14:40:13 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.75.ebuild,v 1.2 2009/10/22 09:24:57 pva Exp $
+
+EAPI="2"
+inherit eutils autotools
DESCRIPTION="My TraceRoute. Excellent network diagnostic tool."
HOMEPAGE="http://www.bitwizard.nl/mtr/"
@@ -17,14 +20,17 @@ RDEPEND="sys-libs/ncurses
DEPEND="${RDEPEND}
gtk? ( dev-util/pkgconfig )"
-# I've kept gtk-2.0.m4 in SRC_URI but you'll have to mv it before autoreconf
-# mv "${WORKDIR}"/gtk-2.0-for-mtr.m4 gtk-2.0.m4 #222909
-src_compile() {
+src_prepare() {
+ epatch "${FILESDIR}/${P}--Wno-pointer-sign.patch"
+ # Keep this comment and following move, even incase ebuild does not needs
+ # it: kept gtk-2.0.m4 in SRC_URI but you'll have to mv it before autoreconf
+ mv "${WORKDIR}"/gtk-2.0-for-mtr.m4 gtk-2.0.m4 #222909
+ eautoreconf
+}
+src_configure() {
econf \
$(use_with gtk) \
$(use_enable ipv6)
-
- emake || die "emake failed"
}
src_install() {