summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-01-25 17:14:54 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-01-25 17:14:54 +0000
commit25ec1cb381748c15980ef3f807998d110a3d0b4d (patch)
tree9e4ad4f9dba58d37b83a14ca2862b77c3e443f8d /net-analyzer/nagios
parentcompnerd retired (diff)
downloadgentoo-2-25ec1cb381748c15980ef3f807998d110a3d0b4d.tar.gz
gentoo-2-25ec1cb381748c15980ef3f807998d110a3d0b4d.tar.bz2
gentoo-2-25ec1cb381748c15980ef3f807998d110a3d0b4d.zip
Version bump (and set on nagios-plugins to 1.4.13-r1 for 3.0.6, too)
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nagios')
-rw-r--r--net-analyzer/nagios/ChangeLog8
-rw-r--r--net-analyzer/nagios/nagios-3.0.6.ebuild4
-rw-r--r--net-analyzer/nagios/nagios-3.1.0.ebuild52
3 files changed, 61 insertions, 3 deletions
diff --git a/net-analyzer/nagios/ChangeLog b/net-analyzer/nagios/ChangeLog
index 15c1e89f53a0..2de1be415937 100644
--- a/net-analyzer/nagios/ChangeLog
+++ b/net-analyzer/nagios/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nagios
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/ChangeLog,v 1.76 2009/01/04 18:30:06 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/ChangeLog,v 1.77 2009/01/25 17:14:54 dertobi123 Exp $
+
+*nagios-3.1.0 (25 Jan 2009)
+
+ 25 Jan 2009; Tobias Scherbaum <dertobi123@gentoo.org> nagios-3.0.6.ebuild,
+ +nagios-3.1.0.ebuild:
+ Version bump (and set on nagios-plugins to 1.4.13-r1 for 3.0.6, too)
04 Jan 2009; Tobias Scherbaum <dertobi123@gentoo.org> nagios-3.0.6.ebuild:
Fix detection for incompatible upgrades
diff --git a/net-analyzer/nagios/nagios-3.0.6.ebuild b/net-analyzer/nagios/nagios-3.0.6.ebuild
index f91adfd392bd..55077153f24f 100644
--- a/net-analyzer/nagios/nagios-3.0.6.ebuild
+++ b/net-analyzer/nagios/nagios-3.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/nagios-3.0.6.ebuild,v 1.2 2009/01/04 18:30:06 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/nagios-3.0.6.ebuild,v 1.3 2009/01/25 17:14:54 dertobi123 Exp $
DESCRIPTION="The Nagios metapackage - merge this to pull install all of the
nagios packages"
@@ -12,7 +12,7 @@ KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
RDEPEND="~net-analyzer/nagios-core-${PV}
- >=net-analyzer/nagios-plugins-1.4.12-r100
+ >=net-analyzer/nagios-plugins-1.4.13-r1
>=net-analyzer/nagios-imagepack-1.0-r100"
pkg_setup() {
diff --git a/net-analyzer/nagios/nagios-3.1.0.ebuild b/net-analyzer/nagios/nagios-3.1.0.ebuild
new file mode 100644
index 000000000000..a6f51a8705b9
--- /dev/null
+++ b/net-analyzer/nagios/nagios-3.1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/nagios-3.1.0.ebuild,v 1.1 2009/01/25 17:14:54 dertobi123 Exp $
+
+DESCRIPTION="The Nagios metapackage - merge this to pull install all of the
+nagios packages"
+HOMEPAGE="http://www.nagios.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="~net-analyzer/nagios-core-${PV}
+ >=net-analyzer/nagios-plugins-1.4.13-r1
+ >=net-analyzer/nagios-imagepack-1.0-r100"
+
+pkg_setup() {
+ # Avoid upgrading from Nagios <3 as the directory structure has changed
+ if has_version '<net-analyzer/nagios-3.0' ; then
+ if [[ "${FORCE_UPGRADE}" ]] ; then
+ echo
+ ewarn "you are upgrading from an incompatible version and have"
+ ewarn "FORCE_UPGRADE set, will build this package while Nagios is running."
+ echo
+ else
+ echo
+ eerror "You are upgrading from an incompatible version."
+ eerror "Please be advised that installation paths have changed to a more FHS"
+ eerror "compliant structure and you won't be able to easily upgrade to"
+ eerror "Nagios 3 therefore. You will have to change your configuration"
+ eerror "to reflect this change, for example Nagios plugins are now installed"
+ eerror "into /usr/$(get_libdir)/nagios/plugins/ instead of /usr/nagios/libexec."
+ echo
+ eerror "If you want to upgrade now, emerge nagios with:"
+ eerror " FORCE_UPGRADE=1 emerge nagios"
+ die "Upgrading from an incompatible version!"
+ echo
+ fi
+ fi
+}
+
+pkg_postrm() {
+ elog "Note: this is a META ebuild for ${P}."
+ elog "to remove it completely or before re-emerging"
+ elog "either use 'depclean', or remove/re-emerge these packages:"
+ elog
+ for dep in ${RDEPEND}; do
+ elog " ${dep}"
+ done
+ echo
+}