summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-03-05 07:59:38 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-03-05 07:59:38 +0000
commite1fee365c6fbf7dcafdbf6b14cb40778b5f1d0db (patch)
tree74f1f512bc73bd92c26b7dad1c8f1384f492ca26 /net-analyzer/nbtscan
parentCleaning up old versions (diff)
downloadgentoo-2-e1fee365c6fbf7dcafdbf6b14cb40778b5f1d0db.tar.gz
gentoo-2-e1fee365c6fbf7dcafdbf6b14cb40778b5f1d0db.tar.bz2
gentoo-2-e1fee365c6fbf7dcafdbf6b14cb40778b5f1d0db.zip
Revision bump; add patch that fixes -s output (bug 84139). Thanks to Josh Nichols <nichoj@rpi.edu> for the patch.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-analyzer/nbtscan')
-rw-r--r--net-analyzer/nbtscan/ChangeLog9
-rw-r--r--net-analyzer/nbtscan/Manifest7
-rw-r--r--net-analyzer/nbtscan/files/digest-nbtscan-1.5.1-r11
-rw-r--r--net-analyzer/nbtscan/files/nbtscan-1.5.1-script-whitespace.patch122
-rw-r--r--net-analyzer/nbtscan/nbtscan-1.5.1-r1.ebuild33
5 files changed, 169 insertions, 3 deletions
diff --git a/net-analyzer/nbtscan/ChangeLog b/net-analyzer/nbtscan/ChangeLog
index 8b50c9c99781..845ed656ef2e 100644
--- a/net-analyzer/nbtscan/ChangeLog
+++ b/net-analyzer/nbtscan/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/nbtscan
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbtscan/ChangeLog,v 1.15 2005/01/18 17:02:04 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbtscan/ChangeLog,v 1.16 2005/03/05 07:59:38 ka0ttic Exp $
+
+*nbtscan-1.5.1-r1 (05 Mar 2005)
+
+ 05 Mar 2005; Aaron Walker <ka0ttic@gentoo.org>
+ +files/nbtscan-1.5.1-script-whitespace.patch, +nbtscan-1.5.1-r1.ebuild:
+ Revision bump; add patch that fixes -s output (bug 84139). Thanks to Josh
+ Nichols <nichoj@rpi.edu> for the patch.
18 Jan 2005; Lina Pezzella <j4rg0n@gentoo.org> nbtscan-1.5.1.ebuild:
Stable ppc-macos.
diff --git a/net-analyzer/nbtscan/Manifest b/net-analyzer/nbtscan/Manifest
index af087c5b4fc7..d61c023c2371 100644
--- a/net-analyzer/nbtscan/Manifest
+++ b/net-analyzer/nbtscan/Manifest
@@ -1,6 +1,9 @@
-MD5 e5a967ca4d04fc14bd7e5a02f3a8df9f ChangeLog 1865
-MD5 f34e3c8858756da0001b12d2d3fa1af2 metadata.xml 159
MD5 7438d043252eb213c0ffc92d035d6438 nbtscan-1.0.3.ebuild 676
MD5 9553ea981aa9b1495ce341ac8112dd72 nbtscan-1.5.1.ebuild 708
+MD5 f50060909c39e24ccbafcf7ff99949e9 ChangeLog 2140
+MD5 f34e3c8858756da0001b12d2d3fa1af2 metadata.xml 159
+MD5 04b2ac7771a9ed6db95eff3bc4469098 nbtscan-1.5.1-r1.ebuild 816
MD5 cf7eaedc7093ec3f2c0aca3848d73798 files/digest-nbtscan-1.0.3 64
MD5 8e3778c37bb9f7f1e27633860cd1b2f2 files/digest-nbtscan-1.5.1 64
+MD5 8e3778c37bb9f7f1e27633860cd1b2f2 files/digest-nbtscan-1.5.1-r1 64
+MD5 8554973b956e4dc879eee3520b4be142 files/nbtscan-1.5.1-script-whitespace.patch 4023
diff --git a/net-analyzer/nbtscan/files/digest-nbtscan-1.5.1-r1 b/net-analyzer/nbtscan/files/digest-nbtscan-1.5.1-r1
new file mode 100644
index 000000000000..651f8a7c4c2c
--- /dev/null
+++ b/net-analyzer/nbtscan/files/digest-nbtscan-1.5.1-r1
@@ -0,0 +1 @@
+MD5 85bb085077c380b82a6ff73e0de0c154 nbtscan-1.5.1.tar.gz 82107
diff --git a/net-analyzer/nbtscan/files/nbtscan-1.5.1-script-whitespace.patch b/net-analyzer/nbtscan/files/nbtscan-1.5.1-script-whitespace.patch
new file mode 100644
index 000000000000..51c823882576
--- /dev/null
+++ b/net-analyzer/nbtscan/files/nbtscan-1.5.1-script-whitespace.patch
@@ -0,0 +1,122 @@
+Only in nbtscan-1.5.1a: config.log
+Only in nbtscan-1.5.1a: config.status
+diff -u nbtscan-1.5.1a/nbtscan.c nbtscan-1.5.1a-work/nbtscan.c
+--- nbtscan-1.5.1a/nbtscan.c 2003-06-06 08:14:00.000000000 -0400
++++ nbtscan-1.5.1a-work/nbtscan.c 2003-06-30 13:20:22.000000000 -0400
+@@ -86,7 +86,7 @@
+ int d_print_hostinfo(struct in_addr addr, const struct nb_host_info* hostinfo) {
+ int i;
+ unsigned char service; /* 16th byte of NetBIOS name */
+- char name[16];
++ char comp_name[16];
+
+ printf("\nPacket dump for Host %s:\n\n", inet_ntoa(addr));
+ if(hostinfo->is_broken) printf("Incomplete packet, %d bytes long.\n", hostinfo->is_broken);
+@@ -110,9 +110,9 @@
+ printf("Names received:\n");
+ for(i=0; i< hostinfo->header->number_of_names; i++) {
+ service = hostinfo->names[i].ascii_name[15];
+- strncpy(name, hostinfo->names[i].ascii_name, 15);
+- name[16]=0;
+- printf("%-17s Service: 0x%02x Flags: 0x%04x\n", name, service, hostinfo->names[i].rr_flags);
++ strncpy(comp_name, hostinfo->names[i].ascii_name, 15);
++ comp_name[16]=0;
++ printf("%-17s Service: 0x%02x Flags: 0x%04x\n", comp_name, service, hostinfo->names[i].rr_flags);
+ }
+ };
+
+@@ -147,9 +147,9 @@
+
+
+ int v_print_hostinfo(struct in_addr addr, const struct nb_host_info* hostinfo, char* sf, int hr) {
+- int i, unique;
++ int i, j, unique;
+ my_uint8_t service; /* 16th byte of NetBIOS name */
+- char name[16];
++ char comp_name[16];
+ char* sname;
+
+ if(!sf) {
+@@ -163,20 +163,27 @@
+ if(hostinfo->header && hostinfo->names) {
+ for(i=0; i< hostinfo->header->number_of_names; i++) {
+ service = hostinfo->names[i].ascii_name[15];
+- strncpy(name, hostinfo->names[i].ascii_name, 15);
+- name[16]=0;
++ strncpy(comp_name, hostinfo->names[i].ascii_name, 15);
++
++ // Eliminate trailing spaces
++ for(j=0; j < 15; j++) {
++ if (comp_name[j] == ' ')
++ break;
++ }
++ comp_name[j] = 0;
++
+ unique = !(hostinfo->names[i].rr_flags & 0x0080);
+ if(sf) {
+- printf("%s%s%s%s", inet_ntoa(addr), sf, name, sf);
+- if(hr) printf("%s\n", (char*)getnbservicename(service, unique, name));
++ printf("%s%s%s%s", inet_ntoa(addr), sf, comp_name, sf);
++ if(hr) printf("%s\n", (char*)getnbservicename(service, unique, comp_name));
+ else {
+ printf("%02x", service);
+ if(unique) printf("U\n");
+ else printf("G\n");
+ }
+ } else {
+- printf("%-17s", name);
+- if(hr) printf("%s\n", (char*)getnbservicename(service, unique, name));
++ printf("%-17s", comp_name);
++ if(hr) printf("%s\n", (char*)getnbservicename(service, unique, comp_name));
+ else {
+ printf("<%02x>", service);
+ if(unique) printf(" UNIQUE\n");
+@@ -199,7 +206,7 @@
+ };
+
+ int print_hostinfo(struct in_addr addr, struct nb_host_info* hostinfo, char* sf) {
+- int i;
++ int i,j;
+ unsigned char service; /* 16th byte of NetBIOS name */
+ char comp_name[16], user_name[16];
+ int is_server=0;
+@@ -215,7 +222,13 @@
+ if(service == 0 && unique && first_name) {
+ /* Unique name, workstation service - this is computer name */
+ strncpy(comp_name, hostinfo->names[i].ascii_name, 15);
+- comp_name[15] = 0;
++
++ // Eliminate trailing spaces
++ for(j=0; j < 15; j++) {
++ if (comp_name[j] == ' ')
++ break;
++ }
++ comp_name[j] = 0;
+ first_name = 0;
+ };
+ if(service == 0x20 && unique) {
+@@ -252,7 +265,7 @@
+ /* If l is true adds #PRE to each line of output (for lmhosts) */
+
+ int l_print_hostinfo(struct in_addr addr, struct nb_host_info* hostinfo, int l) {
+- int i;
++ int i,j;
+ unsigned char service; /* 16th byte of NetBIOS name */
+ char comp_name[16];
+ int is_server=0;
+@@ -268,7 +281,13 @@
+ if(service == 0 && unique && first_name) {
+ /* Unique name, workstation service - this is computer name */
+ strncpy(comp_name, hostinfo->names[i].ascii_name, 15);
+- comp_name[15]=0;
++
++ // Eliminate trailing spaces
++ for(j=0; j < 15; j++) {
++ if (comp_name[j] == ' ')
++ break;
++ }
++ comp_name[j] = 0;
+ first_name = 0;
+ };
+ };
+
diff --git a/net-analyzer/nbtscan/nbtscan-1.5.1-r1.ebuild b/net-analyzer/nbtscan/nbtscan-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..d47b8b739629
--- /dev/null
+++ b/net-analyzer/nbtscan/nbtscan-1.5.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbtscan/nbtscan-1.5.1-r1.ebuild,v 1.1 2005/03/05 07:59:38 ka0ttic Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}a
+DESCRIPTION="NBTscan is a program for scanning IP networks for NetBIOS name information"
+SRC_URI="http://www.inetcat.org/software/${P}.tar.gz"
+HOMEPAGE="http://www.inetcat.org/software/nbtscan.html"
+
+DEPEND="virtual/libc"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc-macos"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-script-whitespace.patch
+}
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr || die
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ dobin nbtscan
+ dodoc COPYING ChangeLog README
+}