summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-09 18:13:36 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-09 18:13:36 +0000
commit59d04643ab2ae4eff69c42c5a1927baef31f3914 (patch)
tree2e336569dea7d584f0f10783fdcea1fc2892ec57 /net-analyzer/nessus-core
parentFix use invocation (Manifest recommit) (diff)
downloadgentoo-2-59d04643ab2ae4eff69c42c5a1927baef31f3914.tar.gz
gentoo-2-59d04643ab2ae4eff69c42c5a1927baef31f3914.tar.bz2
gentoo-2-59d04643ab2ae4eff69c42c5a1927baef31f3914.zip
Fix use invocation and don't run epatch in a subshell because then it can't die
Diffstat (limited to 'net-analyzer/nessus-core')
-rw-r--r--net-analyzer/nessus-core/ChangeLog7
-rw-r--r--net-analyzer/nessus-core/nessus-core-2.0.10a.ebuild12
-rw-r--r--net-analyzer/nessus-core/nessus-core-2.0.7-r1.ebuild16
-rw-r--r--net-analyzer/nessus-core/nessus-core-2.0.7.ebuild8
-rw-r--r--net-analyzer/nessus-core/nessus-core-2.0.8a.ebuild18
-rw-r--r--net-analyzer/nessus-core/nessus-core-2.0.9.ebuild12
6 files changed, 39 insertions, 34 deletions
diff --git a/net-analyzer/nessus-core/ChangeLog b/net-analyzer/nessus-core/ChangeLog
index ecb98cdaa929..2e680b5121e9 100644
--- a/net-analyzer/nessus-core/ChangeLog
+++ b/net-analyzer/nessus-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nessus-core
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/ChangeLog,v 1.31 2004/06/05 14:29:23 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/ChangeLog,v 1.32 2004/06/09 18:13:36 agriffis Exp $
+
+ 09 Jun 2004; Aron Griffis <agriffis@gentoo.org> nessus-core-2.0.10a.ebuild,
+ nessus-core-2.0.7-r1.ebuild, nessus-core-2.0.7.ebuild,
+ nessus-core-2.0.8a.ebuild, nessus-core-2.0.9.ebuild:
+ Fix use invocation and don't run epatch in a subshell because then it can't die
05 Jun 2004; Bryan Østergaard <kloeri@gentoo.org>
nessus-core-2.0.10a.ebuild:
diff --git a/net-analyzer/nessus-core/nessus-core-2.0.10a.ebuild b/net-analyzer/nessus-core/nessus-core-2.0.10a.ebuild
index 15db4d5250f6..e84d06f15e64 100644
--- a/net-analyzer/nessus-core/nessus-core-2.0.10a.ebuild
+++ b/net-analyzer/nessus-core/nessus-core-2.0.10a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.0.10a.ebuild,v 1.4 2004/06/05 14:29:23 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.0.10a.ebuild,v 1.5 2004/06/09 18:13:36 agriffis Exp $
inherit eutils
@@ -26,24 +26,24 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- use prelude && (
+ if use prelude; then
epatch ${DISTDIR}/patch_0.nessus-core.2.0.7
epatch ${FILESDIR}/patch_1.nessus-core.2.0.7
- )
+ fi
}
src_compile() {
local myconf
# no use_enable because of bug 31670
- if [ `use tcpd` ]; then
+ if use tcpd; then
myconf="${myconf} --enable-tcpwrappers"
fi
- if [ `use debug` ]; then
+ if use debug; then
myconf="${myconf} --enable-debug"
else
myconf="${myconf} --disable-debug"
fi
- if [ `use prelude` ]; then
+ if use prelude; then
export LIBPRELUDE_CONFIG=/usr/bin/libprelude-config
fi
use X || myconf="${myconf} --disable-gtk"
diff --git a/net-analyzer/nessus-core/nessus-core-2.0.7-r1.ebuild b/net-analyzer/nessus-core/nessus-core-2.0.7-r1.ebuild
index 56d56a77c66d..34e3c56e8cdc 100644
--- a/net-analyzer/nessus-core/nessus-core-2.0.7-r1.ebuild
+++ b/net-analyzer/nessus-core/nessus-core-2.0.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.0.7-r1.ebuild,v 1.5 2004/04/27 21:10:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.0.7-r1.ebuild,v 1.6 2004/06/09 18:13:36 agriffis Exp $
inherit eutils
@@ -26,32 +26,32 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PN}-${PV}.patch
- use prelude && (
+ if use prelude; then
epatch ${DISTDIR}/patch_0.nessus-core.2.0.7
epatch ${FILESDIR}/patch_1.nessus-core.2.0.7
- )
+ fi
}
src_compile() {
local myconf
use X && myconf="--with-x" || myconf="--without-x"
- if [ `use gtk` ]; then
+ if use gtk; then
myconf="${myconf} --enable-gtk"
- elif [ `use gtk2` ]; then
+ elif use gtk2; then
myconf="${myconf} --enable-gtk"
else
myconf="${myconf} --disable-gtk"
fi
myconf="${myconf} `use_enable tcpd tcpwrappers`"
- if [ `use debug` ]; then
+ if use debug; then
myconf="${myconf} --enable-debug"
else
myconf="${myconf} --disable-debug"
fi
- if [ `use prelude` ]; then
+ if use prelude; then
export LIBPRELUDE_CONFIG=/usr/bin/libprelude-config
fi
- if [ `use prelude` ]; then
+ if use prelude; then
export LIBPRELUDE_CONFIG=/usr/bin/libprelude-config
fi
econf ${myconf} || die "configure failed"
diff --git a/net-analyzer/nessus-core/nessus-core-2.0.7.ebuild b/net-analyzer/nessus-core/nessus-core-2.0.7.ebuild
index e3d561b893bd..08e2c4af3225 100644
--- a/net-analyzer/nessus-core/nessus-core-2.0.7.ebuild
+++ b/net-analyzer/nessus-core/nessus-core-2.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.0.7.ebuild,v 1.5 2004/04/27 21:10:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.0.7.ebuild,v 1.6 2004/06/09 18:13:36 agriffis Exp $
inherit eutils
@@ -29,15 +29,15 @@ src_unpack() {
src_compile() {
local myconf
use X && myconf="--with-x" || myconf="--without-x"
- if [ `use gtk` ]; then
+ if use gtk; then
myconf="${myconf} --enable-gtk"
- elif [ `use gtk2` ]; then
+ elif use gtk2; then
myconf="${myconf} --enable-gtk"
else
myconf="${myconf} --disable-gtk"
fi
myconf="${myconf} `use_enable tcpd tcpwrappers`"
- if [ `use debug` ]; then
+ if use debug; then
myconf="${myconf} --enable-debug"
else
myconf="${myconf} --disable-debug"
diff --git a/net-analyzer/nessus-core/nessus-core-2.0.8a.ebuild b/net-analyzer/nessus-core/nessus-core-2.0.8a.ebuild
index d04af991fc0f..726ffe3b3869 100644
--- a/net-analyzer/nessus-core/nessus-core-2.0.8a.ebuild
+++ b/net-analyzer/nessus-core/nessus-core-2.0.8a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.0.8a.ebuild,v 1.5 2004/04/27 21:10:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.0.8a.ebuild,v 1.6 2004/06/09 18:13:36 agriffis Exp $
inherit eutils
@@ -26,35 +26,35 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- use prelude && (
+ if use prelude; then
epatch ${DISTDIR}/patch_0.nessus-core.2.0.7
epatch ${FILESDIR}/patch_1.nessus-core.2.0.7
- )
+ fi
}
src_compile() {
local myconf
use X && myconf="--with-x" || myconf="--without-x"
- if [ `use gtk` ]; then
+ if use gtk; then
myconf="${myconf} --enable-gtk"
- elif [ `use gtk2` ]; then
+ elif use gtk2; then
myconf="${myconf} --enable-gtk"
else
myconf="${myconf} --disable-gtk"
fi
# no use_enable because of bug 31670
- if [ `use tcpd` ]; then
+ if use tcpd; then
myconf="${myconf} --enable-tcpwrappers"
fi
- if [ `use debug` ]; then
+ if use debug; then
myconf="${myconf} --enable-debug"
else
myconf="${myconf} --disable-debug"
fi
- if [ `use prelude` ]; then
+ if use prelude; then
export LIBPRELUDE_CONFIG=/usr/bin/libprelude-config
fi
- if [ `use prelude` ]; then
+ if use prelude; then
export LIBPRELUDE_CONFIG=/usr/bin/libprelude-config
fi
econf ${myconf} || die "configure failed"
diff --git a/net-analyzer/nessus-core/nessus-core-2.0.9.ebuild b/net-analyzer/nessus-core/nessus-core-2.0.9.ebuild
index 3147a156e9e3..fcdec63c76e1 100644
--- a/net-analyzer/nessus-core/nessus-core-2.0.9.ebuild
+++ b/net-analyzer/nessus-core/nessus-core-2.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.0.9.ebuild,v 1.6 2004/04/27 21:10:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.0.9.ebuild,v 1.7 2004/06/09 18:13:36 agriffis Exp $
inherit eutils
@@ -26,24 +26,24 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- use prelude && (
+ if use prelude; then
epatch ${DISTDIR}/patch_0.nessus-core.2.0.7
epatch ${FILESDIR}/patch_1.nessus-core.2.0.7
- )
+ fi
}
src_compile() {
local myconf
# no use_enable because of bug 31670
- if [ `use tcpd` ]; then
+ if use tcpd; then
myconf="${myconf} --enable-tcpwrappers"
fi
- if [ `use debug` ]; then
+ if use debug; then
myconf="${myconf} --enable-debug"
else
myconf="${myconf} --disable-debug"
fi
- if [ `use prelude` ]; then
+ if use prelude; then
export LIBPRELUDE_CONFIG=/usr/bin/libprelude-config
fi
use X || myconf="${myconf} --disable-gtk"