summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-08-13 10:08:12 +0000
committerEldad Zack <eldad@gentoo.org>2004-08-13 10:08:12 +0000
commit9cddb75eb06dcb1b6343f50f2982e1ad75bbfb9f (patch)
treedaaee003dca4060c2fae1e6ca7756f9878f55bac /net-analyzer/nessus-libraries/nessus-libraries-2.1.1.ebuild
parentStable on alpha, bug 59419. (Manifest recommit) (diff)
downloadgentoo-2-9cddb75eb06dcb1b6343f50f2982e1ad75bbfb9f.tar.gz
gentoo-2-9cddb75eb06dcb1b6343f50f2982e1ad75bbfb9f.tar.bz2
gentoo-2-9cddb75eb06dcb1b6343f50f2982e1ad75bbfb9f.zip
Changed optional ssl support to mandatory
Diffstat (limited to 'net-analyzer/nessus-libraries/nessus-libraries-2.1.1.ebuild')
-rw-r--r--net-analyzer/nessus-libraries/nessus-libraries-2.1.1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/net-analyzer/nessus-libraries/nessus-libraries-2.1.1.ebuild b/net-analyzer/nessus-libraries/nessus-libraries-2.1.1.ebuild
index aacd098dabe6..e2f67bd0d928 100644
--- a/net-analyzer/nessus-libraries/nessus-libraries-2.1.1.ebuild
+++ b/net-analyzer/nessus-libraries/nessus-libraries-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-libraries/nessus-libraries-2.1.1.ebuild,v 1.1 2004/07/24 14:58:45 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-libraries/nessus-libraries-2.1.1.ebuild,v 1.2 2004/08/13 10:08:12 eldad Exp $
DESCRIPTION="A remote security scanner for Linux (nessus-libraries)"
HOMEPAGE="http://www.nessus.org/"
@@ -8,14 +8,16 @@ SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
-IUSE="ssl"
-DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+IUSE=""
+
+# Hard dep on SSL since libnasl won't compile when this package is emerged -ssl.
+DEPEND=">=dev-libs/openssl-0.9.6d"
S=${WORKDIR}/${PN}
src_compile() {
local myconf=""
- use ssl && myconf="--with-ssl=/usr/lib" \
- || myconf="--without-ssl"
+ myconf="--with-ssl=/usr/lib"
+
econf ${myconf} || die "econf failed"
emake || die "emake failed"
}