summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-05 21:49:19 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-05 21:49:19 +0000
commite856530c9047ec9b55198ea37a55e6e7c77a0927 (patch)
treeacef14a1ca870dfc670706a6275f8199581f20a6 /net-analyzer/netcat/netcat-110-r6.ebuild
parentinitial import (diff)
downloadgentoo-2-e856530c9047ec9b55198ea37a55e6e7c77a0927.tar.gz
gentoo-2-e856530c9047ec9b55198ea37a55e6e7c77a0927.tar.bz2
gentoo-2-e856530c9047ec9b55198ea37a55e6e7c77a0927.zip
aes crypt support ... just for you solar baby
Diffstat (limited to 'net-analyzer/netcat/netcat-110-r6.ebuild')
-rw-r--r--net-analyzer/netcat/netcat-110-r6.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/netcat/netcat-110-r6.ebuild b/net-analyzer/netcat/netcat-110-r6.ebuild
new file mode 100644
index 000000000000..ca17007828ec
--- /dev/null
+++ b/net-analyzer/netcat/netcat-110-r6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/netcat-110-r6.ebuild,v 1.1 2004/05/05 21:49:19 vapier Exp $
+
+inherit eutils gcc flag-o-matic
+
+MY_P=nc${PV}
+DESCRIPTION="A network piping program"
+HOMEPAGE="http://www.atstake.com/research/tools/network_utilities/"
+SRC_URI="http://www.atstake.com/research/tools/network_utilities/${MY_P}.tgz
+ ftp://sith.mimuw.edu.pl/pub/users/baggins/IPv6/nc-v6-20000918.patch.gz
+ mirror://gentoo/${PF}-gentoo-deb-patches.tbz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~amd64"
+IUSE="ipv6 static crypt GAPING_SECURITY_HOLE"
+
+DEPEND="virtual/glibc
+ crypt? ( dev-libs/libmix )"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${MY_P}.tgz
+ unpack ${PF}-gentoo-deb-patches.tbz2
+ epatch ${DISTDIR}/nc-v6-20000918.patch.gz
+ EPATCH_SUFFIX="patch" epatch ${S}/deb-patches/
+ sed -i 's:#define HAVE_BIND:#undef HAVE_BIND:' netcat.c
+ sed -i 's:#define FD_SETSIZE 16:#define FD_SETSIZE 1024:' netcat.c #34250
+}
+
+src_compile() {
+ export XLIBS=""
+ export XFLAGS="-DLINUX -DTELNET"
+ use ipv6 && XFLAGS="${XFLAGS} -DINET6"
+ use static && export STATIC="-static"
+ use crypt && XFLAGS="${XFLAGS} -DAESCRYPT" && XLIBS="${XLIBS} -lmix"
+ use GAPING_SECURITY_HOLE && XFLAGS="${XFLAGS} -DGAPING_SECURITY_HOLE"
+ CC="$(gcc-getCC) ${CFLAGS}" make -e nc || die
+}
+
+src_install() {
+ dobin nc || die "dobin failed"
+ dodoc README README.Debian netcat.blurb README.aes-netcat
+ doman nc.1
+ docinto scripts
+ dodoc scripts/*
+}