summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-18 23:22:52 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-18 23:22:52 +0000
commitf62937cab196d3ac4f1c7cfe48733508bddb8de2 (patch)
tree9c80a9ffcaeccd18f09aa3ded1da093c3a2bab7e /net-analyzer/netcat
parentrepoman'd (diff)
downloadgentoo-2-f62937cab196d3ac4f1c7cfe48733508bddb8de2.tar.gz
gentoo-2-f62937cab196d3ac4f1c7cfe48733508bddb8de2.tar.bz2
gentoo-2-f62937cab196d3ac4f1c7cfe48733508bddb8de2.zip
repoman'd
Diffstat (limited to 'net-analyzer/netcat')
-rw-r--r--net-analyzer/netcat/netcat-110.ebuild33
1 files changed, 18 insertions, 15 deletions
diff --git a/net-analyzer/netcat/netcat-110.ebuild b/net-analyzer/netcat/netcat-110.ebuild
index b144a778ccb1..592fedf98a91 100644
--- a/net-analyzer/netcat/netcat-110.ebuild
+++ b/net-analyzer/netcat/netcat-110.ebuild
@@ -1,39 +1,42 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/netcat-110.ebuild,v 1.2 2002/07/11 06:30:43 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/netcat-110.ebuild,v 1.3 2002/07/18 23:22:50 seemant Exp $
-A="nc110.tgz"
+MY_P=nc${PV}
S=${WORKDIR}/nc-${PV}
DESCRIPTION="A network piping program"
-SRC_URI="http://www.l0pht.com/~weld/netcat/${A}"
+SRC_URI="http://www.l0pht.com/~weld/netcat/${MY_P}.tgz"
HOMEPAGE="http://www.l0pht.com/~weld/netcat"
+
SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86"
DEPEND="virtual/glibc"
src_unpack() {
- mkdir ${S}
- cd ${S}
- tar zxf ${DISTDIR}/${A}
+ mkdir ${S}
+ cd ${S}
+ tar zxf ${DISTDIR}/${A}
}
src_compile() {
- cp Makefile Makefile.orig
- cat Makefile.orig | sed -e "s:^CFLAGS =.*$:CFLAGS = ${CFLAGS}:" \
+ cp Makefile Makefile.orig
+ cat Makefile.orig | sed -e "s:^CFLAGS =.*$:CFLAGS = ${CFLAGS}:" \
| sed -e "s:^CC =.*$:CC = gcc \$(CFLAGS):" > Makefile
- cp netcat.c netcat.orig
- cat netcat.orig | sed -e "s:#define HAVE_BIND:#undef HAVE_BIND:" > netcat.c
- try make linux
+ cp netcat.c netcat.orig
+ cat netcat.orig | sed -e "s:#define HAVE_BIND:#undef HAVE_BIND:" > netcat.c
+ try make linux
}
src_install () {
- dobin nc
- dodoc README
- docinto scripts
- dodoc scripts/*
+ dobin nc
+ dodoc README BUGS CONTRIB LICENSE
+ docinto scripts
+ dodoc scripts/*
}