summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-08-09 22:21:41 +0000
committerMichael Januszewski <spock@gentoo.org>2005-08-09 22:21:41 +0000
commit5336682ecda32085f2d041f63ef631945c76370f (patch)
treee33feb595ce56e9034cd409ad576f419ce76ff65 /net-analyzer/nmap
parentAdded a dependency on git-0.99.3. (diff)
downloadgentoo-2-5336682ecda32085f2d041f63ef631945c76370f.tar.gz
gentoo-2-5336682ecda32085f2d041f63ef631945c76370f.tar.bz2
gentoo-2-5336682ecda32085f2d041f63ef631945c76370f.zip
Version bump.
(Portage version: 1.589-cvs)
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog7
-rw-r--r--net-analyzer/nmap/files/digest-nmap-3.831
-rw-r--r--net-analyzer/nmap/nmap-3.83.ebuild35
3 files changed, 42 insertions, 1 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 87d6a3307d5d..aa1b27c8d3e1 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.93 2005/06/26 18:15:29 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.94 2005/08/09 22:21:41 spock Exp $
+
+*nmap-3.83 (09 Aug 2005)
+
+ 09 Aug 2005; Michał Januszewski <spock@gentoo.org> +nmap-3.83.ebuild:
+ Version bump (closes bug #100859).
26 Jun 2005; Lina Pezzella <j4rg0n@gentoo.org> nmap-3.75.ebuild,
nmap-3.80.ebuild, nmap-3.81.ebuild:
diff --git a/net-analyzer/nmap/files/digest-nmap-3.83 b/net-analyzer/nmap/files/digest-nmap-3.83
new file mode 100644
index 000000000000..3d2133643aa8
--- /dev/null
+++ b/net-analyzer/nmap/files/digest-nmap-3.83
@@ -0,0 +1 @@
+MD5 554d1891132b192b0ef58a6b7c561d5c nmap-3.83.DC13.tar.bz2 1943957
diff --git a/net-analyzer/nmap/nmap-3.83.ebuild b/net-analyzer/nmap/nmap-3.83.ebuild
new file mode 100644
index 000000000000..ae47aa5ac734
--- /dev/null
+++ b/net-analyzer/nmap/nmap-3.83.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.83.ebuild,v 1.1 2005/08/09 22:21:41 spock Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://www.insecure.org/presentations/Defcon13/NmapRelease"
+SRC_URI="http://www.insecure.org/presentations/Defcon13/NmapRelease/${P}.DC13.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86"
+IUSE="gtk ssl"
+
+DEPEND="virtual/libc
+ dev-libs/libpcre
+ gtk? ( =x11-libs/gtk+-1.2* )
+ ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${P}.DC13"
+
+src_compile() {
+ use ppc-macos && filter-flags -fstrict-aliasing -O2
+ econf \
+ $(use_with gtk nmapfe) \
+ $(use_with ssl openssl) || die
+ emake -j1 || die
+}
+
+src_install() {
+ einstall -j1 nmapdatadir=${D}/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING INSTALL docs/README docs/*.txt
+ dohtml docs/*.html
+}