summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-08-30 21:23:41 +0000
committerMichael Januszewski <spock@gentoo.org>2008-08-30 21:23:41 +0000
commit6ac1d1b6f8ea04373fd4e8a0dae0be99dad27daa (patch)
tree36b550fe168124c60b1d67dd99a55fe71d43c54d /net-analyzer/nmap
parentVersion bump, mostly performance improvements and bugfixes (diff)
downloadgentoo-2-6ac1d1b6f8ea04373fd4e8a0dae0be99dad27daa.tar.gz
gentoo-2-6ac1d1b6f8ea04373fd4e8a0dae0be99dad27daa.tar.bz2
gentoo-2-6ac1d1b6f8ea04373fd4e8a0dae0be99dad27daa.zip
Fix a race condition in the make file (bug #235995).
(Portage version: 2.2_rc8/cvs/Linux 2.6.26 x86_64)
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog6
-rw-r--r--net-analyzer/nmap/files/nmap-4.68-concurrent-make-fix.patch12
-rw-r--r--net-analyzer/nmap/nmap-4.68.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index d48641ac3c57..886e832e33f0 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.181 2008/08/28 21:38:01 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.182 2008/08/30 21:23:40 spock Exp $
+
+ 30 Aug 2008; Michał Januszewski <spock@gentoo.org>
+ +files/nmap-4.68-concurrent-make-fix.patch, nmap-4.68.ebuild:
+ Fix a race condition in the make file (bug #235995).
28 Aug 2008; Michał Januszewski <spock@gentoo.org> nmap-4.68.ebuild:
Remove forced -j1 as it doesn't seem to be necessary anymore (bug
diff --git a/net-analyzer/nmap/files/nmap-4.68-concurrent-make-fix.patch b/net-analyzer/nmap/files/nmap-4.68-concurrent-make-fix.patch
new file mode 100644
index 000000000000..4cc8acb21114
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-4.68-concurrent-make-fix.patch
@@ -0,0 +1,12 @@
+diff -Naurp nmap-4.68-orig/Makefile.in nmap-4.68/Makefile.in
+--- nmap-4.68-orig/Makefile.in 2008-08-30 01:04:10.000000000 +0200
++++ nmap-4.68/Makefile.in 2008-08-30 01:04:45.000000000 +0200
+@@ -101,7 +101,7 @@ nbase_build: $(NBASEDIR)/Makefile
+ @echo Compiling libnbase;
+ cd $(NBASEDIR) && $(MAKE)
+
+-nsock_build: $(NSOCKDIR)/src/Makefile
++nsock_build: $(NSOCKDIR)/src/Makefile nbase_build
+ @echo Compiling libnsock;
+ cd $(NSOCKDIR)/src && $(MAKE)
+
diff --git a/net-analyzer/nmap/nmap-4.68.ebuild b/net-analyzer/nmap/nmap-4.68.ebuild
index a7d49e2273ce..ed19ca0034bd 100644
--- a/net-analyzer/nmap/nmap-4.68.ebuild
+++ b/net-analyzer/nmap/nmap-4.68.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.68.ebuild,v 1.6 2008/08/28 21:38:01 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.68.ebuild,v 1.7 2008/08/30 21:23:40 spock Exp $
inherit eutils flag-o-matic autotools
@@ -26,6 +26,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-nolua.patch"
+ epatch "${FILESDIR}/${P}-concurrent-make-fix.patch"
AT_NO_RECURSIVE=1 eautoreconf
}