summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-06-27 09:03:51 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-06-27 09:03:51 +0000
commit8d1ca8e6b943790e9fb3a20d76f898e80f26ab42 (patch)
treee61c6e611385cb9b2a0383ab957d7ba25298a4b7 /net-analyzer/nmap
parentWorks on ~x86 so keyword. (diff)
downloadgentoo-2-8d1ca8e6b943790e9fb3a20d76f898e80f26ab42.tar.gz
gentoo-2-8d1ca8e6b943790e9fb3a20d76f898e80f26ab42.tar.bz2
gentoo-2-8d1ca8e6b943790e9fb3a20d76f898e80f26ab42.zip
Bump to 4.90_rc1, fixes #275563
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog7
-rw-r--r--net-analyzer/nmap/nmap-4.90_rc1.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 96df85c6ae94..80080a836b9e 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nmap
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.200 2009/06/02 16:07:13 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.201 2009/06/27 09:03:51 patrick Exp $
+
+*nmap-4.90_rc1 (27 Jun 2009)
+
+ 27 Jun 2009; Patrick Lauer <patrick@gentoo.org> +nmap-4.90_rc1.ebuild:
+ Bump to 4.90_rc1, fixes #275563
02 Jun 2009; Michał Januszewski <spock@gentoo.org>
nmap-4.85_beta9.ebuild:
diff --git a/net-analyzer/nmap/nmap-4.90_rc1.ebuild b/net-analyzer/nmap/nmap-4.90_rc1.ebuild
new file mode 100644
index 000000000000..e6e63b15256d
--- /dev/null
+++ b/net-analyzer/nmap/nmap-4.90_rc1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.90_rc1.ebuild,v 1.1 2009/06/27 09:03:51 patrick Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+MY_P=${P//_rc1/RC1}
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="http://download.insecure.org/nmap/dist/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk lua ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ || ( >=dev-lang/python-2.5[sqlite]
+ >=dev-python/pysqlite-2 )
+ )
+ ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.75-include.patch"
+ epatch "${FILESDIR}/${PN}-4.75-nolua.patch"
+ sed -i -e 's/-m 755 -s ncat/-m 755 ncat/' ncat/Makefile.in
+}
+
+src_configure() {
+ local myconf=""
+
+ if use lua ; then
+ if has_version ">=dev-lang/lua-5.1.3-r1" &&
+ built_with_use dev-lang/lua deprecated ; then
+ myconf="--with-liblua"
+ else
+ myconf="--with-liblua=included"
+ fi
+ else
+ myconf="--without-liblua"
+ fi
+
+ econf \
+ --with-libdnet=included \
+ "${myconf}" \
+ $(use_with gtk zenmap) \
+ $(use_with ssl openssl) || die
+}
+
+src_install() {
+ LC_ALL=C emake DESTDIR="${D}" -j1 STRIP=: nmapdatadir=/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}