summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-12-09 09:03:57 +0000
committerMichael Januszewski <spock@gentoo.org>2006-12-09 09:03:57 +0000
commitf24de39110ab3cd520f0ed9deb09023f1c8c6e60 (patch)
tree9b5bb58e4a70572d97639c8d19637f75e57c04cd /net-analyzer/nmap
parentVersion bump (diff)
downloadgentoo-2-f24de39110ab3cd520f0ed9deb09023f1c8c6e60.tar.gz
gentoo-2-f24de39110ab3cd520f0ed9deb09023f1c8c6e60.tar.bz2
gentoo-2-f24de39110ab3cd520f0ed9deb09023f1c8c6e60.zip
Version bump.
(Portage version: 2.1.2_rc3)
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog7
-rw-r--r--net-analyzer/nmap/files/digest-nmap-4.203
-rw-r--r--net-analyzer/nmap/nmap-4.20.ebuild48
3 files changed, 57 insertions, 1 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 24f81852e2ba..76ca867edc7a 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.131 2006/10/20 21:56:20 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.132 2006/12/09 09:03:57 spock Exp $
+
+*nmap-4.20 (09 Dec 2006)
+
+ 09 Dec 2006; Michał Januszewski <spock@gentoo.org> +nmap-4.20.ebuild:
+ Version bump.
20 Oct 2006; Bryan Østergaard <kloeri@gentoo.org> nmap-4.11.ebuild:
Stable on Alpha.
diff --git a/net-analyzer/nmap/files/digest-nmap-4.20 b/net-analyzer/nmap/files/digest-nmap-4.20
new file mode 100644
index 000000000000..e454ac032489
--- /dev/null
+++ b/net-analyzer/nmap/files/digest-nmap-4.20
@@ -0,0 +1,3 @@
+MD5 ea50419f99472200c4184a304e3831ea nmap-4.20.tar.bz2 2156077
+RMD160 d4794618c72f46e3c9446ce9e0c705ccf32c7115 nmap-4.20.tar.bz2 2156077
+SHA256 c923a6cfa6d3683dc7ee27a721c19d15fd66f264f8ca6dbc9cfac710591f32a8 nmap-4.20.tar.bz2 2156077
diff --git a/net-analyzer/nmap/nmap-4.20.ebuild b/net-analyzer/nmap/nmap-4.20.ebuild
new file mode 100644
index 000000000000..c26ef4390f75
--- /dev/null
+++ b/net-analyzer/nmap/nmap-4.20.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.20.ebuild,v 1.1 2006/12/09 09:03:57 spock Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://www.insecure.org/nmap/"
+SRC_URI="http://download.insecure.org/nmap/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk ssl"
+
+DEPEND="virtual/libc
+ dev-libs/libpcre
+ gtk? ( =x11-libs/gtk+-2* )
+ ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed 's:Icon=icon-network:Icon=nmap-logo-64.png:' -i nmapfe.desktop
+ echo ";" >> nmapfe.desktop
+ epatch ${FILESDIR}/nmap-shtool-nls.patch
+ epatch ${FILESDIR}/nmap-4.01-nostrip.patch
+}
+
+src_compile() {
+ use ppc-macos && filter-flags -fstrict-aliasing -O2
+ econf \
+ $(use_with gtk nmapfe) \
+ $(use_with ssl openssl) || die
+ emake -j1 || die
+}
+
+src_install() {
+ einstall -j1 nmapdatadir=${D}/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt
+ dohtml docs/*.html
+
+ if use gtk; then
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/nmap-logo-64.png
+ fi
+}