summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2012-11-01 07:35:04 +0000
committerBenda XU <heroxbd@gentoo.org>2012-11-01 07:35:04 +0000
commit217358e24d29ac4a2a00ab1290dd2caaf918a910 (patch)
tree07e6ba19994763f8fa593847fe1d2263cd0ef7b3 /net-analyzer/openbsd-netcat
parentUnmask boost 1.50/1.51 to comply with glibc-2.16, as well as GnuTLS 3; keep l... (diff)
downloadgentoo-2-217358e24d29ac4a2a00ab1290dd2caaf918a910.tar.gz
gentoo-2-217358e24d29ac4a2a00ab1290dd2caaf918a910.tar.bz2
gentoo-2-217358e24d29ac4a2a00ab1290dd2caaf918a910.zip
include in tree. closing bug 333253 and replies to bug 237277. credits to Luca Pasquali for initial writing of the ebuild and all who contributed patches.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/openbsd-netcat')
-rw-r--r--net-analyzer/openbsd-netcat/ChangeLog9
-rw-r--r--net-analyzer/openbsd-netcat/metadata.xml11
-rw-r--r--net-analyzer/openbsd-netcat/openbsd-netcat-1.84.ebuild60
3 files changed, 80 insertions, 0 deletions
diff --git a/net-analyzer/openbsd-netcat/ChangeLog b/net-analyzer/openbsd-netcat/ChangeLog
new file mode 100644
index 000000000000..1e36de943d47
--- /dev/null
+++ b/net-analyzer/openbsd-netcat/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-analyzer/netcat-openbsd
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openbsd-netcat/ChangeLog,v 1.1 2012/11/01 07:35:04 heroxbd Exp $
+
+*netcat-openbsd (12 Sep 2008)
+
+ 12 Sep 2008; Luca Pasquali <lpasquali@staff.dada.net> netcat-openbsd-1.84-r0.ebuild:
+ just started the ebuild.
+ package is initially put tidled in my two test environments: amd64 and x86.
diff --git a/net-analyzer/openbsd-netcat/metadata.xml b/net-analyzer/openbsd-netcat/metadata.xml
new file mode 100644
index 000000000000..2eb55f5f9145
--- /dev/null
+++ b/net-analyzer/openbsd-netcat/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>heroxbd@gentoo.org</email>
+ <name>Benda Xu</name>
+</maintainer>
+<longdescription lang="en">
+ This package provides the openbsd linux port of netcat.
+</longdescription>
+</pkgmetadata>
diff --git a/net-analyzer/openbsd-netcat/openbsd-netcat-1.84.ebuild b/net-analyzer/openbsd-netcat/openbsd-netcat-1.84.ebuild
new file mode 100644
index 000000000000..b2fd767cf491
--- /dev/null
+++ b/net-analyzer/openbsd-netcat/openbsd-netcat-1.84.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openbsd-netcat/openbsd-netcat-1.84.ebuild,v 1.1 2012/11/01 07:35:04 heroxbd Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs rpm
+
+DESCRIPTION="the OpenBSD network swiss army knife"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/nc/"
+SRC_URI="ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Server/en/os/SRPMS/nc-1.84-22.el6.src.rpm"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE="static"
+
+DEPEND="dev-libs/glib:2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/nc
+
+src_unpack() {
+ rpm_src_unpack
+}
+
+src_prepare() {
+ epatch "../nc-1.84-glib.patch"
+ epatch "../nc-1.78-pollhup.patch"
+ epatch "../nc-1.82-reuseaddr.patch"
+ epatch "../nc-gcc_signess.patch"
+ epatch "../nc-1.84-connect_with_timeout.patch"
+ epatch "../nc-1.84-udp_stop.patch"
+ epatch "../nc-1.84-udp_port_scan.patch"
+ epatch "../nc-1.84-crlf.patch"
+ epatch "../nc-1.84-verb.patch"
+ epatch "../nc-1.84-man.patch"
+ epatch "../nc-1.84-gcc4.3.patch"
+ epatch "../nc-1.84-efficient_reads.patch"
+ epatch "../nc-1.84-verbose-segfault.patch"
+
+ # avoid name conflict against net-analyzer/netcat
+ mv nc.1 nc.openbsd.1
+}
+
+src_compile() {
+ use static && export STATIC="-static"
+ COMPILER=$(tc-getCC)
+ ${COMPILER} ${CFLAGS} $(pkg-config --cflags --libs glib-2.0) netcat.c \
+ atomicio.c socks.c -o nc.openbsd || die
+}
+
+src_install() {
+ dobin nc.openbsd
+ dodoc README*
+ doman nc.openbsd.1
+ docinto scripts
+ dodoc scripts/*
+}