summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2012-01-14 18:20:26 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2012-01-14 18:20:26 +0000
commitb66eb77405e6e4e30603fad048de4e2e5f77367c (patch)
treee62cc3928232983ec6c626723b2a9605cfc2bd44 /net-analyzer/rrdtool
parentReplace the docdir-directory error with a warning. (diff)
downloadgentoo-2-b66eb77405e6e4e30603fad048de4e2e5f77367c.tar.gz
gentoo-2-b66eb77405e6e4e30603fad048de4e2e5f77367c.tar.bz2
gentoo-2-b66eb77405e6e4e30603fad048de4e2e5f77367c.zip
[net-analyzer/rrdtool-1.4.5-r2] Fix the build with automake-1.11.2 - bug #396727.
Thanks to <AlphatPC@gmail.com> for the patch. (Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/ChangeLog12
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.4.5-automake-1.11.2.patch27
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.4.5-r2.ebuild129
3 files changed, 166 insertions, 2 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index 647b86ccc45f..53d42c44e422 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/rrdtool
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.218 2011/10/23 17:35:28 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.219 2012/01/14 18:20:26 jmbsvicetto Exp $
+
+*rrdtool-1.4.5-r2 (14 Jan 2012)
+
+ 14 Jan 2012; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +rrdtool-1.4.5-r2.ebuild, +files/rrdtool-1.4.5-automake-1.11.2.patch:
+ [net-analyzer/rrdtool-1.4.5-r2] Fix the build with automake-1.11.2 - bug
+ #396727.
+ Thanks to <AlphatPC@gmail.com> for the patch.
23 Oct 2011; Raúl Porcel <armin76@gentoo.org> rrdtool-1.4.5-r1.ebuild:
alpha/arm/ia64/s390/sh/sparc stable wrt #387171
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.4.5-automake-1.11.2.patch b/net-analyzer/rrdtool/files/rrdtool-1.4.5-automake-1.11.2.patch
new file mode 100644
index 000000000000..64206f441b54
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.4.5-automake-1.11.2.patch
@@ -0,0 +1,27 @@
+Install dir:
+ /usr/$(get_libdir)/rrdtool/ifOctets.tcl
+ /usr/$(get_libdir)/rrdtool/pkgIndex.tcl
+
+Due to the following change, pkglib_{DATA,SCRIPTS} is invalid:
+ http://git.savannah.gnu.org/cgit/automake.git/commit/?id=9ca632642b006ac6b0fc4ce0ae5b34023faa8cbf
+
+---
+ bindings/tcl/Makefile.am | 5 +++--
+ 1 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/bindings/tcl/Makefile.am b/bindings/tcl/Makefile.am
+index c0e8b0f..b7205e7 100644
+--- a/bindings/tcl/Makefile.am
++++ b/bindings/tcl/Makefile.am
+@@ -27,8 +27,9 @@ tclpkgdir = @TCL_PACKAGE_DIR@
+ tclpkg_DATA = pkgIndex.tcl
+ tclpkg_SCRIPTS = ifOctets.tcl
+ else
+-pkglib_DATA = pkgIndex.tcl
+-pkglib_SCRIPTS = ifOctets.tcl
++tclpkgdir = $(libdir)/@PACKAGE@
++tclpkg_DATA = pkgIndex.tcl
++tclpkg_SCRIPTS = ifOctets.tcl
+ endif
+
+ # Automake doen't like `tclrrd$(VERSION)$(TCL_SHLIB_SUFFIX)' as
diff --git a/net-analyzer/rrdtool/rrdtool-1.4.5-r2.ebuild b/net-analyzer/rrdtool/rrdtool-1.4.5-r2.ebuild
new file mode 100644
index 000000000000..e3b4de6a2ca2
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.4.5-r2.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.4.5-r2.ebuild,v 1.1 2012/01/14 18:20:26 jmbsvicetto Exp $
+
+EAPI="3"
+
+GENTOO_DEPEND_ON_PERL="no"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit eutils distutils flag-o-matic multilib perl-module autotools
+
+DESCRIPTION="A system to store and display time-series data"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="doc lua perl python ruby rrdcgi tcl"
+
+# This versions are minimal versions upstream tested with.
+RDEPEND="
+ >=media-libs/libpng-1.2.10
+ >=dev-libs/libxml2-2.6.31
+ >=x11-libs/cairo-1.4.6[svg]
+ >=dev-libs/glib-2.12.12
+ >=x11-libs/pango-1.17
+ lua? ( dev-lang/lua )
+ perl? ( dev-lang/perl )
+ ruby? ( >=dev-lang/ruby-1.8.6_p287-r13 )
+ tcl? ( dev-lang/tcl )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-apps/gawk"
+
+DISTUTILS_SETUP_FILES=("bindings/python|setup.py")
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.3.8-configure.ac.patch"
+# epatch "${FILESDIR}/${PN}-1.4.3-ruby-ldflags.patch"
+ epatch "${FILESDIR}/${PN}-1.4.4-dont-link-system-lib.patch"
+ epatch "${FILESDIR}/${P}-automake-1.11.2.patch"
+ sed -i '/PERLLD/s:same as PERLCC:same-as-PERLCC:' configure.ac #281694
+
+ # Python bindings are built/installed manually
+ sed -e "/^all-local:/s/ @COMP_PYTHON@//" -i bindings/Makefile.am
+
+ eautoreconf
+}
+
+src_configure() {
+ filter-flags -ffast-math
+
+ export RRDDOCDIR=${EPREFIX}/usr/share/doc/${PF}
+
+ # to solve bug #260380
+ [[ ${CHOST} == *-solaris* ]] && append-flags -D__EXTENSIONS__
+
+ econf \
+ --disable-static \
+ $(use_enable rrdcgi) \
+ $(use_enable lua) \
+ $(use_enable lua lua-site-install) \
+ $(use_enable ruby) \
+ $(use_enable ruby ruby-site-install) \
+ $(use_enable perl) \
+ $(use_enable perl perl-site-install) \
+ --with-perl-options=INSTALLDIRS=vendor \
+ $(use_enable tcl) \
+ $(use_with tcl tcllib "${EPREFIX}"/usr/$(get_libdir)) \
+ $(use_enable python)
+}
+
+src_compile() {
+ default
+ use python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if ! use doc ; then
+ rm -rf "${ED}"usr/share/doc/${PF}/{html,txt}
+ fi
+
+ if use !rrdcgi ; then
+ # uses rrdcgi, causes invalid shebang error in Prefix, useless
+ # without rrdcgi installed
+ rm -f "${ED}"usr/share/${PN}/examples/cgi-demo.cgi
+ fi
+
+ if use perl ; then
+ perl_delete_localpod
+ perl_delete_packlist
+ fi
+
+ use python && distutils_src_install
+
+ dodoc CHANGES CONTRIBUTORS NEWS README THREADS TODO
+
+ find "${ED}"usr -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+
+ ewarn "rrdtool dump 1.3 does emit completely legal xml. Basically this means that"
+ ewarn "it contains an xml header and a DOCTYPE definition. Unfortunately this"
+ ewarn "causes older versions of rrdtool restore to be unhappy."
+ ewarn
+ ewarn "To restore a new dump with an old rrdtool restore version, either remove"
+ ewarn "the xml header and the doctype by hand (both on the first line of the dump)"
+ ewarn "or use rrdtool dump --no-header."
+ ewarn
+ ewarn "Note: rrdtool-1.3.x doesn't have any default font bundled. Thus if you've"
+ ewarn "upgraded from rrdtool-1.2.x and don't have any font installed to make"
+ ewarn "lables visible, please, install some font, e.g. media-fonts/dejavu."
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}