summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin McCarthy <signals@gentoo.org>2011-04-05 17:04:16 +0000
committerKevin McCarthy <signals@gentoo.org>2011-04-05 17:04:16 +0000
commitde5ddc2a89f2b6fecd63d16b5de60e7d443a078d (patch)
treea91733df8a728fdceba2d95773af56cff5264880 /net-analyzer/rtpbreak
parentConverted libpng15 patch from DOS to Unix (diff)
downloadgentoo-2-de5ddc2a89f2b6fecd63d16b5de60e7d443a078d.tar.gz
gentoo-2-de5ddc2a89f2b6fecd63d16b5de60e7d443a078d.tar.bz2
gentoo-2-de5ddc2a89f2b6fecd63d16b5de60e7d443a078d.zip
Add missing udp.h include. #351602
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/rtpbreak')
-rw-r--r--net-analyzer/rtpbreak/ChangeLog6
-rw-r--r--net-analyzer/rtpbreak/files/rtpbreak-1.3a-missing-headers.patch14
-rw-r--r--net-analyzer/rtpbreak/rtpbreak-1.3a.ebuild7
3 files changed, 23 insertions, 4 deletions
diff --git a/net-analyzer/rtpbreak/ChangeLog b/net-analyzer/rtpbreak/ChangeLog
index 956b48d64ae3..e0a6ad5a21c9 100644
--- a/net-analyzer/rtpbreak/ChangeLog
+++ b/net-analyzer/rtpbreak/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/rtpbreak
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rtpbreak/ChangeLog,v 1.7 2011/03/01 20:22:30 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rtpbreak/ChangeLog,v 1.8 2011/04/05 17:04:16 signals Exp $
+
+ 05 Apr 2011; Kevin McCarthy <signals@gentoo.org> rtpbreak-1.3a.ebuild,
+ +files/rtpbreak-1.3a-missing-headers.patch:
+ Add missing udp.h include. #351602
01 Mar 2011; Christian Ruppert <idl0r@gentoo.org>
-files/rtpbreak-1.0-ldflags.patch, -files/rtpbreak-1.2-build.patch,
diff --git a/net-analyzer/rtpbreak/files/rtpbreak-1.3a-missing-headers.patch b/net-analyzer/rtpbreak/files/rtpbreak-1.3a-missing-headers.patch
new file mode 100644
index 000000000000..8f9bb14e37cd
--- /dev/null
+++ b/net-analyzer/rtpbreak/files/rtpbreak-1.3a-missing-headers.patch
@@ -0,0 +1,14 @@
+Fix build failure due to missing include of udp.h #351602
+
+Patch by Kevin McCarthy <signals@gentoo.org>
+
+--- rtpbreak-1.3a.orig/src/main.c 2011-01-29 11:10:46.960653580 -0500
++++ rtpbreak-1.3a/src/main.c 2011-01-29 11:15:15.833884433 -0500
+@@ -27,6 +27,7 @@
+ #include <sys/stat.h>
+ #include <pwd.h>
+ #include <grp.h>
++#include <netinet/udp.h>
+ #include "queue.h"
+ #include "rtp.h"
+ #include "common.h"
diff --git a/net-analyzer/rtpbreak/rtpbreak-1.3a.ebuild b/net-analyzer/rtpbreak/rtpbreak-1.3a.ebuild
index 0c6a2e74b2f5..efb7bb1128de 100644
--- a/net-analyzer/rtpbreak/rtpbreak-1.3a.ebuild
+++ b/net-analyzer/rtpbreak/rtpbreak-1.3a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rtpbreak/rtpbreak-1.3a.ebuild,v 1.2 2009/12/23 16:16:08 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rtpbreak/rtpbreak-1.3a.ebuild,v 1.3 2011/04/05 17:04:16 signals Exp $
EAPI=1
@@ -23,7 +23,8 @@ RDEPEND=$DEPEND
src_unpack() {
unpack ${A}
# Use limits.h PATH_MAX
- epatch "${FILESDIR}"/${P}-limits.patch
+ epatch "${FILESDIR}"/${P}-limits.patch \
+ "${FILESDIR}"/${P}-missing-headers.patch
}
src_compile() {