summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-01-29 05:04:30 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-01-29 05:04:30 +0000
commita62db20d8a2e26258b0678cfacc005ad79b549cc (patch)
tree04bc1b0a2b2bdf1f02b238795df94cdd18110cae /net-analyzer/sniffit/sniffit-0.3.7.ebuild
parentMasked pspell-ispell till the other *spell 's are fixed. (diff)
downloadgentoo-2-a62db20d8a2e26258b0678cfacc005ad79b549cc.tar.gz
gentoo-2-a62db20d8a2e26258b0678cfacc005ad79b549cc.tar.bz2
gentoo-2-a62db20d8a2e26258b0678cfacc005ad79b549cc.zip
bug #327: sniffit remote root exploit fixed by m0rpheus@poseidon.mine.nu (Ferry Meyndert)
Diffstat (limited to 'net-analyzer/sniffit/sniffit-0.3.7.ebuild')
-rw-r--r--net-analyzer/sniffit/sniffit-0.3.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/sniffit/sniffit-0.3.7.ebuild b/net-analyzer/sniffit/sniffit-0.3.7.ebuild
new file mode 100644
index 000000000000..64369d28f9e9
--- /dev/null
+++ b/net-analyzer/sniffit/sniffit-0.3.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <lamer@gentoo.org>, Ferry Meyndert <m0rpheus@poseidon.mine.nu>, Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sniffit/sniffit-0.3.7.ebuild,v 1.1 2002/01/29 05:04:30 blocke Exp $
+
+P=sniffit.0.3.7.beta
+S=${WORKDIR}/${P}
+DESCRIPTION="Interactive Packet Sniffer"
+SRC_URI="http://reptile.rug.ac.be/~coder/sniffit/files/${P}.tar.gz
+ http://www.clan-tva.com/m0rpheus/sniffit_0.3.7.beta-10.diff"
+HOMEPAGE="http://reptile.rug.ac.be/~coder/sniffit/sniffit.html"
+
+DEPEND=">=net-libs/libpcap-0.6.2 >=sys-libs/ncurses-5.2"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ patch < ${DISTDIR}/sniffit_0.3.7.beta-10.diff || die
+}
+
+src_compile() {
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} || die
+
+ emake OBJ_FLAG="-w -c ${CFLAGS}" EXE_FLAG="-w ${CFLAGS} -o sniffit" || die
+}
+
+src_install () {
+ dobin sniffit
+ doman sniffit.5 sniffit.8
+ dodoc README.FIRST PLUGIN-HOWTO
+}
+