summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-06-30 13:04:05 +0000
committerJeroen Roovers <jer@gentoo.org>2014-06-30 13:04:05 +0000
commit50d296ca5e724759704ca33468c2fd655dec2d2c (patch)
tree2741e90d65994665d1017f162af2b37c9d207908 /net-analyzer/tcpstat
parentInitial commit, ebuild written by me. (diff)
downloadgentoo-2-50d296ca5e724759704ca33468c2fd655dec2d2c.tar.gz
gentoo-2-50d296ca5e724759704ca33468c2fd655dec2d2c.tar.bz2
gentoo-2-50d296ca5e724759704ca33468c2fd655dec2d2c.zip
EAPI bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/tcpstat')
-rw-r--r--net-analyzer/tcpstat/ChangeLog9
-rw-r--r--net-analyzer/tcpstat/tcpstat-1.5-r2.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/net-analyzer/tcpstat/ChangeLog b/net-analyzer/tcpstat/ChangeLog
index 2ac292df728f..8decac48bd52 100644
--- a/net-analyzer/tcpstat/ChangeLog
+++ b/net-analyzer/tcpstat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/tcpstat
-# Copyright 2002-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpstat/ChangeLog,v 1.21 2012/06/14 13:29:17 ago Exp $
+# Copyright 2002-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpstat/ChangeLog,v 1.22 2014/06/30 13:04:05 jer Exp $
+
+*tcpstat-1.5-r2 (30 Jun 2014)
+
+ 30 Jun 2014; Jeroen Roovers <jer@gentoo.org> +tcpstat-1.5-r2.ebuild:
+ EAPI bump.
14 Jun 2012; Agostino Sarubbo <ago@gentoo.org> tcpstat-1.5-r1.ebuild:
stable for amd64
diff --git a/net-analyzer/tcpstat/tcpstat-1.5-r2.ebuild b/net-analyzer/tcpstat/tcpstat-1.5-r2.ebuild
new file mode 100644
index 000000000000..b203401e0ff5
--- /dev/null
+++ b/net-analyzer/tcpstat/tcpstat-1.5-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpstat/tcpstat-1.5-r2.ebuild,v 1.1 2014/06/30 13:04:05 jer Exp $
+
+EAPI=5
+inherit eutils autotools flag-o-matic
+
+DESCRIPTION="Reports network interface statistics"
+SRC_URI="http://www.frenchfries.net/paul/tcpstat/${P}.tar.gz"
+HOMEPAGE="http://www.frenchfries.net/paul/tcpstat/"
+
+DEPEND="net-libs/libpcap"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-db.patch
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -Wall -Wextra
+ econf $(use_enable ipv6)
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README doc/Tips_and_Tricks.txt )
+
+src_install() {
+ default
+ dobin src/{catpcap,packetdump}
+ newdoc src/README README.src
+}