summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerry Meyndert <m0rpheus@gentoo.org>2002-02-13 00:26:39 +0000
committerFerry Meyndert <m0rpheus@gentoo.org>2002-02-13 00:26:39 +0000
commita00341daf334d672b82ae685468e74cdd7044640 (patch)
treed546e1173e4b0553c6bb571dd9b607a715ee2423 /net-analyzer/ucd-snmp/ucd-snmp-4.2.3.ebuild
parentAdded support for Gnu plotutils library to gnuplot. Plotutils dependency and... (diff)
downloadgentoo-2-a00341daf334d672b82ae685468e74cdd7044640.tar.gz
gentoo-2-a00341daf334d672b82ae685468e74cdd7044640.tar.bz2
gentoo-2-a00341daf334d672b82ae685468e74cdd7044640.zip
Added new version 4.2.3 that fixes a security issue and removed all
previous versions
Diffstat (limited to 'net-analyzer/ucd-snmp/ucd-snmp-4.2.3.ebuild')
-rw-r--r--net-analyzer/ucd-snmp/ucd-snmp-4.2.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/ucd-snmp/ucd-snmp-4.2.3.ebuild b/net-analyzer/ucd-snmp/ucd-snmp-4.2.3.ebuild
new file mode 100644
index 000000000000..ff58a505a78a
--- /dev/null
+++ b/net-analyzer/ucd-snmp/ucd-snmp-4.2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ucd-snmp/ucd-snmp-4.2.3.ebuild,v 1.1 2002/02/13 00:26:39 m0rpheus Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Software for generating and retrieving SNMP data"
+SRC_URI="http://download.sourceforge.net/net-snmp/${P}.tar.gz"
+HOMEPAGE="http://net-snmp.sourceforge.net/"
+
+DEPEND="virtual/glibc <sys-libs/db-2
+ >=sys-libs/zlib-1.1.3
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+src_compile() {
+ local myconf
+ use ssl && myconf="${myconf} --with-openssl=/usr"
+ use ssl || myconf="${myconf} --enable-internal-md5 --with-openssl=no"
+ use tcpd && myconf="${myconf} --with-libwrap"
+ use ipv6 && myconf="${myconf} --with-ipv6"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
+ --with-zlib --enable-shared --with-sys-contact="root@Unknown" \
+ --with-sys-location="Unknown" --with-logfile=/var/log/snmpd.log \
+ --with-persistent-directory=/var/lib/ucd-snmp ${myconf}
+ assert
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr exec_prefix=${D}/usr mandir=${D}/usr/share/man \
+ persistentdir=${D}/var/lib/ucd-snmp install || die
+
+ dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO EXAMPLE.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/snmpd.rc6 snmpd
+}