summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-09-03 08:34:46 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-09-03 08:34:46 +0000
commit0439e453b14066aa219b366d5e4aaf667bb94cdb (patch)
treeb9fb2e29649f2a0f29ad328ad2f6e746fc9eb121 /net-analyzer
parentmissing digest (diff)
downloadgentoo-2-0439e453b14066aa219b366d5e4aaf667bb94cdb.tar.gz
gentoo-2-0439e453b14066aa219b366d5e4aaf667bb94cdb.tar.bz2
gentoo-2-0439e453b14066aa219b366d5e4aaf667bb94cdb.zip
Resolves bug #7399. Version bump. Repoman fix. Gcc3.2 patch.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nload/ChangeLog11
-rw-r--r--net-analyzer/nload/files/digest-nload-0.5.01
-rw-r--r--net-analyzer/nload/files/nload-0.5.0-gcc3-gentoo.patch12
-rw-r--r--net-analyzer/nload/nload-0.5.0.ebuild37
4 files changed, 60 insertions, 1 deletions
diff --git a/net-analyzer/nload/ChangeLog b/net-analyzer/nload/ChangeLog
index a18c69366420..0cba9a5d79ed 100644
--- a/net-analyzer/nload/ChangeLog
+++ b/net-analyzer/nload/ChangeLog
@@ -1,7 +1,16 @@
# ChangeLog for net-analyzer/nload
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nload/ChangeLog,v 1.2 2002/07/18 14:40:44 nitro Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nload/ChangeLog,v 1.3 2002/09/03 08:34:46 mkennedy Exp $
+*nload-0.5.0 (3 Sep 2002)
+
+ 3 Sep 2002; Matthew Kennedy <mkennedy@gentoo.org>
+ nload-0.5.0.ebuild, files/digest-nload-0.5.0,
+ files/nload-0.5.0-gcc-gentoo.patch :
+
+ Resolves bug #7399. Version bump to 0.5.0 and add patch to correct
+ C++ compile problems on gcc3.2. Added minor fix to get a happy
+ repoman.
*nload-0.4.0 (14 Jun 2002)
diff --git a/net-analyzer/nload/files/digest-nload-0.5.0 b/net-analyzer/nload/files/digest-nload-0.5.0
new file mode 100644
index 000000000000..c787c698ff57
--- /dev/null
+++ b/net-analyzer/nload/files/digest-nload-0.5.0
@@ -0,0 +1 @@
+MD5 4b6bdc397f25af456ccecbf748b1af26 nload-0.5.0.tar.gz 105512
diff --git a/net-analyzer/nload/files/nload-0.5.0-gcc3-gentoo.patch b/net-analyzer/nload/files/nload-0.5.0-gcc3-gentoo.patch
new file mode 100644
index 000000000000..fd717e182460
--- /dev/null
+++ b/net-analyzer/nload/files/nload-0.5.0-gcc3-gentoo.patch
@@ -0,0 +1,12 @@
+diff -ur nload-0.5.0.orig/src/form_field.cpp nload-0.5.0/src/form_field.cpp
+--- nload-0.5.0.orig/src/form_field.cpp 2002-08-01 12:21:31.000000000 -0500
++++ nload-0.5.0/src/form_field.cpp 2002-09-03 03:27:31.000000000 -0500
+@@ -133,7 +133,7 @@
+ }
+
+
+-Form::Form( Slots* slots = 0 ) : m_slots( slots ), m_form(0), m_visible( false )
++Form::Form( Slots* slots) : m_slots( slots ), m_form(0), m_visible( false )
+ {
+ m_instances.push_back( this );
+ }
diff --git a/net-analyzer/nload/nload-0.5.0.ebuild b/net-analyzer/nload/nload-0.5.0.ebuild
new file mode 100644
index 000000000000..fca38d6cb398
--- /dev/null
+++ b/net-analyzer/nload/nload-0.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nload/nload-0.5.0.ebuild,v 1.1 2002/09/03 08:34:46 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="console application which monitors network traffic and bandwidth usage in real time"
+SRC_URI="mirror://sourceforge/nload/${P}.tar.gz"
+HOMEPAGE="http://roland-riegel.de/nload/index_en.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 <${FILESDIR}/nload-0.5.0-gcc3-gentoo.patch
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --host=${CHOST} || die "./configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install
+ dodoc README INSTALL ChangeLog AUTHORS
+}
+