summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-07-25 02:18:43 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-07-25 02:18:43 +0000
commit186f119dc5f0a08ace05ad1ae56225a3beddfb1f (patch)
tree1e011c7b4003d2dae6ce5470359359abe9955dbe /net-analyzer
parentamd64 stable, bug 277843 (diff)
downloadgentoo-2-186f119dc5f0a08ace05ad1ae56225a3beddfb1f.tar.gz
gentoo-2-186f119dc5f0a08ace05ad1ae56225a3beddfb1f.tar.bz2
gentoo-2-186f119dc5f0a08ace05ad1ae56225a3beddfb1f.zip
Fix compilation with gcc-4.4. Thanks to Victor Ostorga <vostorga AT gentoo DOT org>; bug #273845
(Portage version: 2.2_rc33-r1/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nepenthes/ChangeLog9
-rw-r--r--net-analyzer/nepenthes/files/nepenthes-0.2.2-gcc44.patch348
-rw-r--r--net-analyzer/nepenthes/nepenthes-0.2.2.ebuild5
3 files changed, 358 insertions, 4 deletions
diff --git a/net-analyzer/nepenthes/ChangeLog b/net-analyzer/nepenthes/ChangeLog
index 61b807cf2684..22756bb3f02a 100644
--- a/net-analyzer/nepenthes/ChangeLog
+++ b/net-analyzer/nepenthes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nepenthes
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/ChangeLog,v 1.18 2009/02/03 10:03:53 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/ChangeLog,v 1.19 2009/07/25 02:18:43 halcy0n Exp $
+
+ 25 Jul 2009; Mark Loeser <halcy0n@gentoo.org> nepenthes-0.2.2.ebuild,
+ +files/nepenthes-0.2.2-gcc44.patch:
+ Fix compilation with gcc-4.4. Thanks to Victor Ostorga <vostorga AT gentoo
+ DOT org>; bug #273845
03 Feb 2009; Peter Volkov <pva@gentoo.org>
+files/nepenthes-0.2.2-gcc4.patch, nepenthes-0.2.2.ebuild:
diff --git a/net-analyzer/nepenthes/files/nepenthes-0.2.2-gcc44.patch b/net-analyzer/nepenthes/files/nepenthes-0.2.2-gcc44.patch
new file mode 100644
index 000000000000..3a16f85a5207
--- /dev/null
+++ b/net-analyzer/nepenthes/files/nepenthes-0.2.2-gcc44.patch
@@ -0,0 +1,348 @@
+diff -NrU5 nepenthes-0.2.2.orig/modules/download-creceive/CReceiveDialogue.cpp nepenthes-0.2.2/modules/download-creceive/CReceiveDialogue.cpp
+--- nepenthes-0.2.2.orig/modules/download-creceive/CReceiveDialogue.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/download-creceive/CReceiveDialogue.cpp 2009-06-13 15:44:07.000000000 -0600
+@@ -51,10 +51,12 @@
+ #include "DownloadUrl.cpp"
+ #include "DownloadBuffer.cpp"
+
+ #include "SubmitManager.hpp"
+
++#include <cstdio>
++
+ #ifdef STDTAGS
+ #undef STDTAGS
+ #endif
+ #define STDTAGS l_dl | l_dia | l_hlr
+
+diff -NrU5 nepenthes-0.2.2.orig/modules/download-http/HTTPDialogue.cpp nepenthes-0.2.2/modules/download-http/HTTPDialogue.cpp
+--- nepenthes-0.2.2.orig/modules/download-http/HTTPDialogue.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/download-http/HTTPDialogue.cpp 2009-06-13 15:44:52.000000000 -0600
+@@ -27,10 +27,11 @@
+
+ /* $Id: nepenthes-0.2.2-gcc44.patch,v 1.1 2009/07/25 02:18:43 halcy0n Exp $ */
+
+ #include "HTTPDialogue.hpp"
+
++#include <cstdio>
+
+ #include "Message.hpp"
+ #include "Nepenthes.hpp"
+ #include "LogManager.hpp"
+
+diff -NrU5 nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_connect_trans.cpp nepenthes-0.2.2/modules/shellcode-generic/sch_generic_connect_trans.cpp
+--- nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_connect_trans.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/shellcode-generic/sch_generic_connect_trans.cpp 2009-06-13 15:34:15.000000000 -0600
+@@ -29,10 +29,11 @@
+
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
++#include <cstdio>
+
+ #include "LogManager.hpp"
+ #include "Message.hpp"
+ #include "sch_generic_connect_trans.hpp"
+ #include "Socket.hpp"
+diff -NrU5 nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_createprocess.cpp nepenthes-0.2.2/modules/shellcode-generic/sch_generic_createprocess.cpp
+--- nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_createprocess.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/shellcode-generic/sch_generic_createprocess.cpp 2009-06-13 15:36:08.000000000 -0600
+@@ -36,11 +36,11 @@
+ *
+ */
+
+ /* $Id: nepenthes-0.2.2-gcc44.patch,v 1.1 2009/07/25 02:18:43 halcy0n Exp $ */
+
+-
++#include <cstdio>
+
+ #include "sch_generic_createprocess.hpp"
+
+ #include "Nepenthes.hpp"
+ #include "Message.hpp"
+diff -NrU5 nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_link_bind_trans.cpp nepenthes-0.2.2/modules/shellcode-generic/sch_generic_link_bind_trans.cpp
+--- nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_link_bind_trans.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/shellcode-generic/sch_generic_link_bind_trans.cpp 2009-06-13 15:37:03.000000000 -0600
+@@ -25,10 +25,12 @@
+ *
+ *******************************************************************************/
+
+ /* $Id: nepenthes-0.2.2-gcc44.patch,v 1.1 2009/07/25 02:18:43 halcy0n Exp $ */
+
++#include <cstdio>
++
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+
+diff -NrU5 nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_link_trans.cpp nepenthes-0.2.2/modules/shellcode-generic/sch_generic_link_trans.cpp
+--- nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_link_trans.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/shellcode-generic/sch_generic_link_trans.cpp 2009-06-13 15:37:47.000000000 -0600
+@@ -25,10 +25,11 @@
+ *
+ *******************************************************************************/
+
+ /* $Id: nepenthes-0.2.2-gcc44.patch,v 1.1 2009/07/25 02:18:43 halcy0n Exp $ */
+
++#include <cstdio>
+
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+diff -NrU5 nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_stuttgart.cpp nepenthes-0.2.2/modules/shellcode-generic/sch_generic_stuttgart.cpp
+--- nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_stuttgart.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/shellcode-generic/sch_generic_stuttgart.cpp 2009-06-13 15:39:10.000000000 -0600
+@@ -24,11 +24,13 @@
+ * contact nepenthesdev@users.sourceforge.net
+ *
+ *******************************************************************************/
+
+ /* $Id: nepenthes-0.2.2-gcc44.patch,v 1.1 2009/07/25 02:18:43 halcy0n Exp $ */
+-
++
++#include <cstdio>
++
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+
+diff -NrU5 nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_url.cpp nepenthes-0.2.2/modules/shellcode-generic/sch_generic_url.cpp
+--- nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_url.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/shellcode-generic/sch_generic_url.cpp 2009-06-13 15:40:23.000000000 -0600
+@@ -36,11 +36,11 @@
+ * wikipedia states bsd code can be relicensed on to gpl, but we got no information what has to be done
+ *
+ *
+ */
+
+-
++#include <cstdio>
+
+ #include "sch_generic_url.hpp"
+ #include "LogManager.hpp"
+ #include "Message.hpp"
+ #include "DownloadManager.hpp"
+diff -NrU5 nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_wuerzburg.cpp nepenthes-0.2.2/modules/shellcode-generic/sch_generic_wuerzburg.cpp
+--- nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_wuerzburg.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/shellcode-generic/sch_generic_wuerzburg.cpp 2009-06-13 15:41:02.000000000 -0600
+@@ -25,10 +25,12 @@
+ *
+ *******************************************************************************/
+
+ /* $Id: nepenthes-0.2.2-gcc44.patch,v 1.1 2009/07/25 02:18:43 halcy0n Exp $ */
+
++#include <cstdio>
++
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+
+diff -NrU5 nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_xor.cpp nepenthes-0.2.2/modules/shellcode-generic/sch_generic_xor.cpp
+--- nepenthes-0.2.2.orig/modules/shellcode-generic/sch_generic_xor.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/shellcode-generic/sch_generic_xor.cpp 2009-06-13 15:41:47.000000000 -0600
+@@ -40,10 +40,12 @@
+
+
+
+ #include "sch_generic_xor.hpp"
+
++#include <cstdio>
++
+ #include "Nepenthes.hpp"
+ #include "Message.hpp"
+ #include "Message.cpp"
+ #include "LogManager.hpp"
+ #include "Utilities.hpp"
+diff -NrU5 nepenthes-0.2.2.orig/modules/shellcode-signatures/sch_namespace_bindfiletransfer.cpp nepenthes-0.2.2/modules/shellcode-signatures/sch_namespace_bindfiletransfer.cpp
+--- nepenthes-0.2.2.orig/modules/shellcode-signatures/sch_namespace_bindfiletransfer.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/shellcode-signatures/sch_namespace_bindfiletransfer.cpp 2009-06-13 15:42:56.000000000 -0600
+@@ -25,10 +25,12 @@
+ *
+ *******************************************************************************/
+
+ /* $Id: nepenthes-0.2.2-gcc44.patch,v 1.1 2009/07/25 02:18:43 halcy0n Exp $ */
+
++#include <cstdio>
++
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+
+diff -NrU5 nepenthes-0.2.2.orig/modules/shellcode-signatures/sch_namespace_connectbackfiletransfer.cpp nepenthes-0.2.2/modules/shellcode-signatures/sch_namespace_connectbackfiletransfer.cpp
+--- nepenthes-0.2.2.orig/modules/shellcode-signatures/sch_namespace_connectbackfiletransfer.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/shellcode-signatures/sch_namespace_connectbackfiletransfer.cpp 2009-06-13 15:42:24.000000000 -0600
+@@ -25,10 +25,12 @@
+ *
+ *******************************************************************************/
+
+ /* $Id: nepenthes-0.2.2-gcc44.patch,v 1.1 2009/07/25 02:18:43 halcy0n Exp $ */
+
++#include <cstdio>
++
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+
+diff -NrU5 nepenthes-0.2.2.orig/modules/shellemu-winnt/VFS.cpp nepenthes-0.2.2/modules/shellemu-winnt/VFS.cpp
+--- nepenthes-0.2.2.orig/modules/shellemu-winnt/VFS.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/shellemu-winnt/VFS.cpp 2009-06-13 15:45:28.000000000 -0600
+@@ -20,10 +20,11 @@
+ *
+ *******************************************************************************/
+
+
+ #include <ctype.h>
++#include <cstdio>
+
+ #include "VFS.hpp"
+ #include "VFSNode.hpp"
+ #include "VFSDir.hpp"
+ #include "VFSFile.hpp"
+diff -NrU5 nepenthes-0.2.2.orig/modules/shellemu-winnt/VFSCommand.hpp nepenthes-0.2.2/modules/shellemu-winnt/VFSCommand.hpp
+--- nepenthes-0.2.2.orig/modules/shellemu-winnt/VFSCommand.hpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/shellemu-winnt/VFSCommand.hpp 2009-06-13 15:46:21.000000000 -0600
+@@ -28,10 +28,11 @@
+ /* $Id: nepenthes-0.2.2-gcc44.patch,v 1.1 2009/07/25 02:18:43 halcy0n Exp $ */
+
+ #ifndef HAVE_VFSCOMMANDECHO
+ #define HAVE_VFSCOMMANDECHO
+
++#include <stdint.h>
+ #include <list>
+ #include <string>
+ #include <vector>
+
+ #include "VFSNode.hpp"
+diff -NrU5 nepenthes-0.2.2.orig/modules/shellemu-winnt/VFSCommandRCP.cpp nepenthes-0.2.2/modules/shellemu-winnt/VFSCommandRCP.cpp
+--- nepenthes-0.2.2.orig/modules/shellemu-winnt/VFSCommandRCP.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/shellemu-winnt/VFSCommandRCP.cpp 2009-06-13 15:46:53.000000000 -0600
+@@ -24,11 +24,13 @@
+ * contact nepenthesdev@users.sourceforge.net
+ *
+ *******************************************************************************/
+
+ /* $Id: nepenthes-0.2.2-gcc44.patch,v 1.1 2009/07/25 02:18:43 halcy0n Exp $ */
+-
++
++#include <cstdio>
++
+ #include "VFSCommandRCP.hpp"
+ #include "VFSNode.hpp"
+ #include "VFSDir.hpp"
+ #include "VFSFile.hpp"
+ #include "Nepenthes.hpp"
+diff -NrU5 nepenthes-0.2.2.orig/modules/submit-file/submit-file.cpp nepenthes-0.2.2/modules/submit-file/submit-file.cpp
+--- nepenthes-0.2.2.orig/modules/submit-file/submit-file.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/submit-file/submit-file.cpp 2009-06-13 15:43:26.000000000 -0600
+@@ -28,10 +28,11 @@
+ /* $Id: nepenthes-0.2.2-gcc44.patch,v 1.1 2009/07/25 02:18:43 halcy0n Exp $ */
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <errno.h>
++#include <cstdio>
+
+ #include "submit-file.hpp"
+ #include "Download.hpp"
+ #include "DownloadBuffer.hpp"
+ #include "Utilities.hpp"
+diff -NrU5 nepenthes-0.2.2.orig/modules/submit-postgres/PGDownloadContext.cpp nepenthes-0.2.2/modules/submit-postgres/PGDownloadContext.cpp
+--- nepenthes-0.2.2.orig/modules/submit-postgres/PGDownloadContext.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/modules/submit-postgres/PGDownloadContext.cpp 2009-06-13 16:33:01.000000000 -0600
+@@ -25,10 +25,11 @@
+ *
+ *******************************************************************************/
+
+ /* $Id: nepenthes-0.2.2-gcc44.patch,v 1.1 2009/07/25 02:18:43 halcy0n Exp $ */
+
++#include <cstdio>
+
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+diff -NrU5 nepenthes-0.2.2.orig/nepenthes-core/src/DownloadManager.cpp nepenthes-0.2.2/nepenthes-core/src/DownloadManager.cpp
+--- nepenthes-0.2.2.orig/nepenthes-core/src/DownloadManager.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/nepenthes-core/src/DownloadManager.cpp 2009-06-13 15:47:38.000000000 -0600
+@@ -40,10 +40,12 @@
+ #include "Config.hpp"
+
+ #include "SubmitEvent.hpp"
+ #include "EventManager.hpp"
+
++#include <cstdio>
++
+ using namespace std;
+ using namespace nepenthes;
+
+ #ifdef STDTAGS
+ #undef STDTAGS
+diff -NrU5 nepenthes-0.2.2.orig/nepenthes-core/src/ModuleManager.cpp nepenthes-0.2.2/nepenthes-core/src/ModuleManager.cpp
+--- nepenthes-0.2.2.orig/nepenthes-core/src/ModuleManager.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/nepenthes-core/src/ModuleManager.cpp 2009-06-13 15:48:19.000000000 -0600
+@@ -33,10 +33,12 @@
+ #include "Module.hpp"
+ #include "Config.hpp"
+ #include "Nepenthes.hpp"
+ #include "LogManager.hpp"
+
++#include <cstdio>
++
+ using namespace nepenthes;
+ using namespace std;
+
+ #ifdef STDTAGS
+ #undef STDTAGS
+diff -NrU5 nepenthes-0.2.2.orig/nepenthes-core/src/ShellcodeManager.cpp nepenthes-0.2.2/nepenthes-core/src/ShellcodeManager.cpp
+--- nepenthes-0.2.2.orig/nepenthes-core/src/ShellcodeManager.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/nepenthes-core/src/ShellcodeManager.cpp 2009-06-13 16:00:35.000000000 -0600
+@@ -33,10 +33,12 @@
+ #include "LogManager.hpp"
+ #include "Message.hpp"
+ #include "SocketEvent.hpp"
+ #include "EventManager.hpp"
+
++#include <cstdio>
++
+ using namespace nepenthes;
+
+ #ifdef STDTAGS
+ #undef STDTAGS
+ #endif
+diff -NrU5 nepenthes-0.2.2.orig/nepenthes-core/src/Socket.cpp nepenthes-0.2.2/nepenthes-core/src/Socket.cpp
+--- nepenthes-0.2.2.orig/nepenthes-core/src/Socket.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/nepenthes-core/src/Socket.cpp 2009-06-13 15:49:04.000000000 -0600
+@@ -27,10 +27,11 @@
+
+ /* $Id: nepenthes-0.2.2-gcc44.patch,v 1.1 2009/07/25 02:18:43 halcy0n Exp $ */
+
+ #include <string>
+ #include <sstream>
++#include <cstdio>
+
+ #include <time.h>
+
+ #include <sys/types.h>
+ #include <sys/socket.h>
+diff -NrU5 nepenthes-0.2.2.orig/nepenthes-core/src/Utilities.cpp nepenthes-0.2.2/nepenthes-core/src/Utilities.cpp
+--- nepenthes-0.2.2.orig/nepenthes-core/src/Utilities.cpp 2009-06-13 15:32:10.000000000 -0600
++++ nepenthes-0.2.2/nepenthes-core/src/Utilities.cpp 2009-06-13 16:01:09.000000000 -0600
+@@ -36,10 +36,12 @@
+ #include <string.h>
+ #include <sys/types.h>
+ #include <inttypes.h>
+ #include <ctype.h>
+
++#include <cstdio>
++
+ #include "Utilities.hpp"
+ #include "LogManager.hpp"
+ #include "Config.hpp"
+
+ using namespace nepenthes;
diff --git a/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild b/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild
index 9c2f53a91dcb..3a85d3489036 100644
--- a/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild
+++ b/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild,v 1.2 2009/02/03 10:03:53 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild,v 1.3 2009/07/25 02:18:43 halcy0n Exp $
EAPI="2"
inherit eutils autotools
@@ -28,7 +28,8 @@ pkg_setup() {
}
src_prepare() {
- epatch ${FILESDIR}/${P}-gcc4.patch
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
sed 's|var/cache|/var/lib/cache|' -i modules/shellcode-signatures/shellcode-signatures.cpp
find . -name Makefile.am -exec sed 's: -Werror::' -i '{}' \;
eautoreconf