summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2007-04-03 14:34:03 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2007-04-03 14:34:03 +0000
commit1b645178f3abce2f0264fee6bb1d2fe18c301811 (patch)
treee3e6840c6ac5db632dbc94e9046a9e4570d74c3c /net-analyzer
parent2.2.9 version bump for bug 169466. Thanks to Jared Breland <nitro322 at gmail... (diff)
downloadgentoo-2-1b645178f3abce2f0264fee6bb1d2fe18c301811.tar.gz
gentoo-2-1b645178f3abce2f0264fee6bb1d2fe18c301811.tar.bz2
gentoo-2-1b645178f3abce2f0264fee6bb1d2fe18c301811.zip
2.2.9 version bump for bug 169466. Thanks to Jared Breland <nitro322 at gmail dot com>.
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nessus-core/ChangeLog9
-rw-r--r--net-analyzer/nessus-core/files/digest-nessus-core-2.2.93
-rw-r--r--net-analyzer/nessus-core/nessus-core-2.2.9.ebuild49
3 files changed, 60 insertions, 1 deletions
diff --git a/net-analyzer/nessus-core/ChangeLog b/net-analyzer/nessus-core/ChangeLog
index 8ff9db0c80fc..0433a92a1a5d 100644
--- a/net-analyzer/nessus-core/ChangeLog
+++ b/net-analyzer/nessus-core/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/nessus-core
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/ChangeLog,v 1.109 2007/03/26 19:38:47 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/ChangeLog,v 1.110 2007/04/03 14:34:03 vanquirius Exp $
+
+*nessus-core-2.2.9 (03 Apr 2007)
+
+ 03 Apr 2007; Marcelo Goes <vanquirius@gentoo.org>
+ +nessus-core-2.2.9.ebuild:
+ 2.2.9 version bump for bug 169466. Thanks to Jared Breland <nitro322 at
+ gmail dot com>.
26 Mar 2007; Fabian Groffen <grobian@gentoo.org> nessus-core-2.3.1.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/net-analyzer/nessus-core/files/digest-nessus-core-2.2.9 b/net-analyzer/nessus-core/files/digest-nessus-core-2.2.9
new file mode 100644
index 000000000000..9dbe3fb44226
--- /dev/null
+++ b/net-analyzer/nessus-core/files/digest-nessus-core-2.2.9
@@ -0,0 +1,3 @@
+MD5 c3f9db836d3b866b4a9395ee833638be nessus-core-2.2.9.tar.gz 674390
+RMD160 ba911192a78ee1c6ae1a5d64badff9d18ef666a8 nessus-core-2.2.9.tar.gz 674390
+SHA256 b725ace4ef619bc19b372eac9a60db7b083a3e155e11c65443618e52b56c847e nessus-core-2.2.9.tar.gz 674390
diff --git a/net-analyzer/nessus-core/nessus-core-2.2.9.ebuild b/net-analyzer/nessus-core/nessus-core-2.2.9.ebuild
new file mode 100644
index 000000000000..16d4c2e1e2ff
--- /dev/null
+++ b/net-analyzer/nessus-core/nessus-core-2.2.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.2.9.ebuild,v 1.1 2007/04/03 14:34:03 vanquirius Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A remote security scanner for Linux (nessus-core)"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X tcpd debug prelude"
+DEPEND="=net-analyzer/nessus-libraries-${PV}
+ =net-analyzer/libnasl-${PV}
+ tcpd? ( sys-apps/tcp-wrappers )
+ X? ( =x11-libs/gtk+-2* )
+ prelude? ( dev-libs/libprelude )
+ !net-analyzer/nessus-client"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+
+ export CC="$(tc-getCC)"
+ econf `use_enable tcpd tcpwrappers` \
+ `use_enable debug` \
+ `use_enable X gtk` \
+ || die "configure failed"
+ emake -j1 || die "emake failed"
+
+}
+
+src_install() {
+ make DESTDIR="${D}" \
+ install || die "Install failed nessus-core"
+ cd "${S}"
+ dodoc README* UPGRADE_README CHANGES
+ dodoc doc/*.txt doc/ntp/*
+ insinto /etc/init.d
+ insopts -m 755
+ newins "${FILESDIR}"/nessusd-r7 nessusd
+ keepdir /var/lib/nessus/logs
+ keepdir /var/lib/nessus/users
+ # newer version is provided by nessus-libraries
+ # should be fixed upstream in version 2.2.6
+ rm "${D}"/usr/include/nessus/includes.h
+}