summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-10-03 15:24:07 +0000
committerJeroen Roovers <jer@gentoo.org>2012-10-03 15:24:07 +0000
commit214bafd367f13d19fad3929991cfd58c9ac566f7 (patch)
tree01db7044415ac39c7f1932b854699707ca610627 /net-analyzer
parentx86 stable wrt bug #427544 (diff)
downloadgentoo-2-214bafd367f13d19fad3929991cfd58c9ac566f7.tar.gz
gentoo-2-214bafd367f13d19fad3929991cfd58c9ac566f7.tar.bz2
gentoo-2-214bafd367f13d19fad3929991cfd58c9ac566f7.zip
Add upstream patch (bug #437032).
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.8.3-dtls-sctp.patch22
-rw-r--r--net-analyzer/wireshark/wireshark-1.8.3.ebuild6
3 files changed, 31 insertions, 3 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index fe51f8feb137..495f1a4102bb 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.402 2012/10/02 23:45:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.403 2012/10/03 15:24:07 jer Exp $
+
+ 03 Oct 2012; Jeroen Roovers <jer@gentoo.org> wireshark-1.8.3.ebuild,
+ +files/wireshark-1.8.3-dtls-sctp.patch:
+ Add upstream patch (bug #437032).
*wireshark-1.8.3 (02 Oct 2012)
*wireshark-1.6.11 (02 Oct 2012)
diff --git a/net-analyzer/wireshark/files/wireshark-1.8.3-dtls-sctp.patch b/net-analyzer/wireshark/files/wireshark-1.8.3-dtls-sctp.patch
new file mode 100644
index 000000000000..f5cfc9964dde
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.8.3-dtls-sctp.patch
@@ -0,0 +1,22 @@
+--- a/epan/dissectors/packet-dtls.c
++++ b/epan/dissectors/packet-dtls.c
+@@ -2724,7 +2724,6 @@
+
+ register_dissector("dtls", dissect_dtls, proto_dtls);
+ dtls_handle = find_dissector("dtls");
+- dissector_add_uint("sctp.ppi", DIAMETER_DTLS_PROTOCOL_ID, dtls_handle);
+ dtls_associations = g_tree_new(ssl_association_cmp);
+
+ register_init_routine(dtls_init);
+@@ -2750,8 +2749,10 @@
+ dtls_parse_uat();
+ dtls_parse_old_keys();
+
+- if (initialized == FALSE)
++ if (initialized == FALSE) {
+ heur_dissector_add("udp", dissect_dtls_heur, proto_dtls);
++ dissector_add_uint("sctp.ppi", DIAMETER_DTLS_PROTOCOL_ID, find_dissector("dtls"));
++ }
+
+ initialized = TRUE;
+ }
diff --git a/net-analyzer/wireshark/wireshark-1.8.3.ebuild b/net-analyzer/wireshark/wireshark-1.8.3.ebuild
index 1fc8e7fa8b41..38dece773154 100644
--- a/net-analyzer/wireshark/wireshark-1.8.3.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.8.3.ebuild,v 1.1 2012/10/02 23:45:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.8.3.ebuild,v 1.2 2012/10/03 15:24:07 jer Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
@@ -106,7 +106,9 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.8.1-ldflags.patch
+ epatch \
+ "${FILESDIR}"/${PN}-1.8.1-ldflags.patch \
+ "${FILESDIR}"/${PN}-1.8.3-dtls-sctp.patch
sed -i -e 's|.png||g' ${PN}.desktop || die
eautoreconf
}