summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-11-18 12:44:52 +0000
committerPeter Volkov <pva@gentoo.org>2007-11-18 12:44:52 +0000
commit2281a379b658122e36a0c647f5117b0cf5926b33 (patch)
treeb54b5ff3e4a39e5f962ad2b16891a9cccdc06389 /net-analyzer
parentinitial import (diff)
downloadgentoo-2-2281a379b658122e36a0c647f5117b0cf5926b33.tar.gz
gentoo-2-2281a379b658122e36a0c647f5117b0cf5926b33.tar.bz2
gentoo-2-2281a379b658122e36a0c647f5117b0cf5926b33.zip
New release 0.8.7a and new patch 0.8.6j-r7. Fixes possible Possible SQL injection issue was resolved, bug #199509.
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti/ChangeLog10
-rw-r--r--net-analyzer/cacti/cacti-0.8.6j-r7.ebuild (renamed from net-analyzer/cacti/cacti-0.8.7.ebuild)14
-rw-r--r--net-analyzer/cacti/cacti-0.8.7a.ebuild92
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6j-r721
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.73
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.7a3
6 files changed, 134 insertions, 9 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index c21783003851..0b2146aaadea 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.113 2007/11/03 18:53:22 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.114 2007/11/18 12:44:52 pva Exp $
+
+*cacti-0.8.7a (18 Nov 2007)
+*cacti-0.8.6j-r7 (18 Nov 2007)
+
+ 18 Nov 2007; <pva@gentoo.org> +cacti-0.8.6j-r7.ebuild,
+ -cacti-0.8.7.ebuild, +cacti-0.8.7a.ebuild:
+ New release 0.8.7a and new patch 0.8.6j-r7. Fixes possible Possible SQL
+ injection issue was resolved, bug #199509.
*cacti-0.8.7-r1 (03 Nov 2007)
diff --git a/net-analyzer/cacti/cacti-0.8.7.ebuild b/net-analyzer/cacti/cacti-0.8.6j-r7.ebuild
index 9a94664bda51..6b274c7ed8ff 100644
--- a/net-analyzer/cacti/cacti-0.8.7.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.6j-r7.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.7.ebuild,v 1.1 2007/10/29 15:03:46 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r7.ebuild,v 1.1 2007/11/18 12:44:52 pva Exp $
inherit eutils webapp depend.apache depend.php
# Support for _p* in version.
MY_P=${P/_p*/}
-HAS_PATCHES=0
+HAS_PATCHES=1
DESCRIPTION="Cacti is a complete frontend to rrdtool"
HOMEPAGE="http://www.cacti.net/"
@@ -18,7 +18,8 @@ if [ $HAS_PATCHES == 1 ] ; then
tree_console_missing_hosts
thumbnail_graphs_not_working
graph_debug_lockup_fix
- snmpwalk_fix"
+ snmpwalk_fix
+ sec_sql_injection-0.8.6j"
for i in $UPSTREAM_PATCHES ; do
SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
done
@@ -53,9 +54,11 @@ src_unpack() {
unpack ${MY_P}.tar.gz
fi
+ epatch "${FILESDIR}/${P}"-dos-large-values.patch
+
use bundled-adodb || sed -i -e \
- 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"/usr/share/php5/adodb/adodb.inc.php":' \
- "${S}"/include/global.php
+ 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"adodb/adodb.inc.php":' \
+ "${S}"/include/config.php
}
pkg_setup() {
@@ -77,6 +80,7 @@ src_compile() {
src_install() {
webapp_src_preinst
+ rm LICENSE README
dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
rm -rf docs
use bundled-adodb || rm -rf lib/adodb
diff --git a/net-analyzer/cacti/cacti-0.8.7a.ebuild b/net-analyzer/cacti/cacti-0.8.7a.ebuild
new file mode 100644
index 000000000000..2ce6b63d661d
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.7a.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.7a.ebuild,v 1.1 2007/11/18 12:44:52 pva Exp $
+
+inherit eutils webapp depend.apache depend.php
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+HAS_PATCHES=0
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+# patches
+if [ $HAS_PATCHES == 1 ] ; then
+ UPSTREAM_PATCHES=""
+ for i in $UPSTREAM_PATCHES ; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
+ done
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp bundled-adodb"
+
+DEPEND=""
+
+want_apache
+need_php_cli
+need_php_httpd
+
+RDEPEND="!apache2? ( www-servers/lighttpd )
+ snmp? ( net-analyzer/net-snmp )
+ net-analyzer/rrdtool
+ !bundled-adodb? ( dev-php/adodb )
+ virtual/mysql
+ virtual/cron"
+
+src_unpack() {
+ if [ $HAS_PATCHES == 1 ] ; then
+ unpack ${MY_P}.tar.gz
+ [ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
+ # patches
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
+ done ;
+ else
+ unpack ${MY_P}.tar.gz
+ fi
+
+ use bundled-adodb || sed -i -e \
+ 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"adodb/adodb.inc.php":' \
+ "${S}"/include/global.php
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [ $PHP_VERSION = 5 ] ; then
+ phpUseFlags="cli mysql xml session pcre"
+ elif [ $PHP_VERSION = 4 ] ; then
+ phpUseFlags="cli mysql xml session pcre expat"
+ fi
+ use bundled-adodb || phpUseFlags="${phpUseFlags} sockets"
+ require_php_with_use ${phpUseFlags}
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm LICENSE README
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+ use bundled-adodb || rm -rf lib/adodb
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6j-r7 b/net-analyzer/cacti/files/digest-cacti-0.8.6j-r7
new file mode 100644
index 000000000000..e8fc9681bcba
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.6j-r7
@@ -0,0 +1,21 @@
+MD5 29436be46b289d13dfce48e7618129e2 cacti-0.8.6j.tar.gz 1126337
+RMD160 981d24753d440af1d3fcfdb20cd988f73fcc44fe cacti-0.8.6j.tar.gz 1126337
+SHA256 0ddf8a740a5725de67eeea71c38433447ff75388e6e399ce92ccadc36d25bd46 cacti-0.8.6j.tar.gz 1126337
+MD5 85a95eaef5fac31d5ca87cb915493cdd graph_debug_lockup_fix.patch 927
+RMD160 8bf2112cb537b330547b8b571cc573a0f3135123 graph_debug_lockup_fix.patch 927
+SHA256 c8ea30c6bf5764663d106d28b3308377a8c2003cc2afd3d0ba0102ed5fddee1b graph_debug_lockup_fix.patch 927
+MD5 bedf583646e59dd628d4aced7e83fdf3 ping_php_version4_snmpgetnext.patch 1262
+RMD160 94882973199b8e59c40ad43a132548862654f312 ping_php_version4_snmpgetnext.patch 1262
+SHA256 1e19110c696eb56c6de68247c926c5ec7a2e7554df222f39a663556241644170 ping_php_version4_snmpgetnext.patch 1262
+MD5 ebf8ce0e11845ebcd838847e7cc2912d sec_sql_injection-0.8.6j.patch 749
+RMD160 c8c93f6bddd7e032cede65872cdea3df0850ec05 sec_sql_injection-0.8.6j.patch 749
+SHA256 0f05946e598ce34b9507b8eeaa431c45280c2f6e07003cf583a11735fc01d245 sec_sql_injection-0.8.6j.patch 749
+MD5 9ccde09fe134a6f8c9c83d0e573e1759 snmpwalk_fix.patch 1056
+RMD160 ba1a70dc95ceba6f5716dd8d8351db4a400abcc3 snmpwalk_fix.patch 1056
+SHA256 ecf344ff6674306c52f6bbeea621d56310444ad12f679202b0de141485429106 snmpwalk_fix.patch 1056
+MD5 1a3c9580a1f94d991502c8650d18b617 thumbnail_graphs_not_working.patch 1515
+RMD160 6b228cab1bc99b3f20ddb4e1d45b467fc8dadf35 thumbnail_graphs_not_working.patch 1515
+SHA256 3b18602aed1aa8b9773a75a4e89413cd12ce2670fd185eae113de1aa2c1186bd thumbnail_graphs_not_working.patch 1515
+MD5 109afedcd49dc173da8c27fb23c322fe tree_console_missing_hosts.patch 771
+RMD160 d33f3916317e989b379d1188f3ed23b7d61a7a9e tree_console_missing_hosts.patch 771
+SHA256 5807bb408227b1c9f2ebecf220c048eb7c7148eee41fcd06fdc086124a206180 tree_console_missing_hosts.patch 771
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.7 b/net-analyzer/cacti/files/digest-cacti-0.8.7
deleted file mode 100644
index a2fe27dc114b..000000000000
--- a/net-analyzer/cacti/files/digest-cacti-0.8.7
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 d28e8f9fd4b657c2ad79c4bcf1e3694d cacti-0.8.7.tar.gz 2405448
-RMD160 2d7b111fea85c59483621aa5c30056332976b05d cacti-0.8.7.tar.gz 2405448
-SHA256 6a30ef4588f27fd885389710003ead98a229c01d6b355dc958fc61be49eb3545 cacti-0.8.7.tar.gz 2405448
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.7a b/net-analyzer/cacti/files/digest-cacti-0.8.7a
new file mode 100644
index 000000000000..720d62c6aaa1
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.7a
@@ -0,0 +1,3 @@
+MD5 7d298e496058ec91f6d1ecdc97e0cca5 cacti-0.8.7a.tar.gz 2002270
+RMD160 7e1c66a2b91487d6bf8ccff25ce50e0c6f5a277d cacti-0.8.7a.tar.gz 2002270
+SHA256 5e75b0058bb6dc755221f540845699fb383a18f8f3011f0f81bf321db09bf623 cacti-0.8.7a.tar.gz 2002270