summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-10-09 18:04:12 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-10-09 18:04:12 +0000
commit2b007857f373dfbda9575a1c4c455f65f034dc09 (patch)
tree67780e774a4881c99e6b96fa6b26ae0bc94cc93d /net-analyzer
parentsparc stable wrt #191296 (diff)
downloadgentoo-2-2b007857f373dfbda9575a1c4c455f65f034dc09.tar.gz
gentoo-2-2b007857f373dfbda9575a1c4c455f65f034dc09.tar.bz2
gentoo-2-2b007857f373dfbda9575a1c4c455f65f034dc09.zip
Version bump wrt bug #194890
(Portage version: 2.1.3.12)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpdump/ChangeLog7
-rw-r--r--net-analyzer/tcpdump/files/digest-tcpdump-3.9.83
-rw-r--r--net-analyzer/tcpdump/tcpdump-3.9.8.ebuild76
3 files changed, 85 insertions, 1 deletions
diff --git a/net-analyzer/tcpdump/ChangeLog b/net-analyzer/tcpdump/ChangeLog
index 959620ddb956..d47ea7a7447d 100644
--- a/net-analyzer/tcpdump/ChangeLog
+++ b/net-analyzer/tcpdump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/tcpdump
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/ChangeLog,v 1.119 2007/09/29 00:14:36 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/ChangeLog,v 1.120 2007/10/09 18:04:12 jokey Exp $
+
+*tcpdump-3.9.8 (09 Oct 2007)
+
+ 09 Oct 2007; Markus Ullmann <jokey@gentoo.org> +tcpdump-3.9.8.ebuild:
+ Version bump wrt bug #194890
29 Sep 2007; Christoph Mende <angelos@gentoo.org> tcpdump-3.9.7-r1.ebuild:
Stable on amd64 wrt bug #193787
diff --git a/net-analyzer/tcpdump/files/digest-tcpdump-3.9.8 b/net-analyzer/tcpdump/files/digest-tcpdump-3.9.8
new file mode 100644
index 000000000000..f711ce9323c0
--- /dev/null
+++ b/net-analyzer/tcpdump/files/digest-tcpdump-3.9.8
@@ -0,0 +1,3 @@
+MD5 c491a78c52fe73f1f7271aa5d8c6ab2e tcpdump-3.9.8.tar.gz 938054
+RMD160 76b17d131f4d89342c2bcdc27c40d23d29ecb1f1 tcpdump-3.9.8.tar.gz 938054
+SHA256 2309c8eb1dc87436a410f4a8d041b0453ade5753c35ce7a2c5bc9a0263a8d299 tcpdump-3.9.8.tar.gz 938054
diff --git a/net-analyzer/tcpdump/tcpdump-3.9.8.ebuild b/net-analyzer/tcpdump/tcpdump-3.9.8.ebuild
new file mode 100644
index 000000000000..12c3a76e8181
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-3.9.8.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.9.8.ebuild,v 1.1 2007/10/09 18:04:12 jokey Exp $
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl ipv6 samba"
+
+DEPEND="net-libs/libpcap
+ ssl? ( >=dev-libs/openssl-0.9.6m )"
+
+pkg_setup() {
+ if use samba ; then
+ ewarn
+ ewarn "CAUTION !!! CAUTION !!! CAUTION"
+ ewarn
+ ewarn "You're about to compile tcpdump with samba printing support"
+ ewarn "Upstream tags it as 'possibly-buggy SMB printer'"
+ ewarn "So think twice whether this is fine with you"
+ ewarn
+ ewarn "CAUTION !!! CAUTION !!! CAUTION"
+ ewarn
+ ewarn "(Giving you 10 secs to think about it)"
+ ewarn
+ ebeep 5
+ epause 5
+ fi
+}
+
+src_compile() {
+ # tcpdump needs some optymalization. see bug #108391
+ ( ! is-flag -O? || is-flag -O0 ) && append-flags -O
+
+ replace-flags -O[3-9] -O2
+ filter-flags -finline-functions
+
+ # Fix wrt bug #48747
+ if [[ $(gcc-major-version) -gt 3 ]] || \
+ [[ $(gcc-major-version) -eq 3 && $(gcc-minor-version) -ge 4 ]]
+ then
+ filter-flags -funit-at-a-time
+ append-flags -fno-unit-at-a-time
+ fi
+
+ local myconf
+ if ! use ssl ; then
+ myconf="--without-crypto"
+ fi
+
+ econf --with-user=tcpdump \
+ $(use_enable ipv6) \
+ $(use_enable samba smb) \
+ ${myconf} || die "configure failed"
+
+ make CCOPT="$CFLAGS" || die "make failed"
+}
+
+pkg_preinst() {
+ enewgroup tcpdump || die "Failed to add group tcpdump"
+ enewuser tcpdump -1 -1 -1 tcpdump || die "Failed to add user tcpdump"
+}
+
+src_install() {
+ dosbin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc README FILES VERSION CHANGES CREDITS TODO
+}