summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-18 18:19:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-18 18:19:33 +0000
commit3e635979b02dfb5775024d0a62a315672f902ceb (patch)
tree660b6a4b562fb1e41d465b379e5e286d2828bf35 /net-analyzer
parentVersion bump. (diff)
downloadgentoo-2-3e635979b02dfb5775024d0a62a315672f902ceb.tar.gz
gentoo-2-3e635979b02dfb5775024d0a62a315672f902ceb.tar.bz2
gentoo-2-3e635979b02dfb5775024d0a62a315672f902ceb.zip
Fix LICENSE from GPL-2 to openssl. Fix econf argument --without-crypto to --without-openssl. basically rewrite the ebuild for cleanup, the intresting stuff is in ChangeLog for users
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ssldump/ChangeLog8
-rw-r--r--net-analyzer/ssldump/ssldump-0.9-r1.ebuild43
-rw-r--r--net-analyzer/ssldump/ssldump-0.9.ebuild41
3 files changed, 29 insertions, 63 deletions
diff --git a/net-analyzer/ssldump/ChangeLog b/net-analyzer/ssldump/ChangeLog
index 8f4938bde01a..6d9627edc4c4 100644
--- a/net-analyzer/ssldump/ChangeLog
+++ b/net-analyzer/ssldump/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/ssldump
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ssldump/ChangeLog,v 1.20 2008/11/07 10:21:34 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ssldump/ChangeLog,v 1.21 2011/01/18 18:19:33 ssuominen Exp $
+
+ 18 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> ssldump-0.9-r1.ebuild:
+ Fix LICENSE from GPL-2 to openssl. Fix econf argument --without-crypto to
+ --without-openssl.
07 Nov 2008; Raúl Porcel <armin76@gentoo.org> ssldump-0.9-r1.ebuild:
sparc stable wrt #244232
diff --git a/net-analyzer/ssldump/ssldump-0.9-r1.ebuild b/net-analyzer/ssldump/ssldump-0.9-r1.ebuild
index 9b9f6dc8f53b..6f8a7738c299 100644
--- a/net-analyzer/ssldump/ssldump-0.9-r1.ebuild
+++ b/net-analyzer/ssldump/ssldump-0.9-r1.ebuild
@@ -1,42 +1,45 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ssldump/ssldump-0.9-r1.ebuild,v 1.4 2008/11/07 10:21:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ssldump/ssldump-0.9-r1.ebuild,v 1.5 2011/01/18 18:19:33 ssuominen Exp $
-inherit eutils autotools
+EAPI=2
+inherit autotools eutils
MY_P=${PN}-0.9b3
+
DESCRIPTION="A Tool for network monitoring and data acquisition"
-SRC_URI="http://www.rtfm.com/ssldump/${MY_P}.tar.gz"
HOMEPAGE="http://www.rtfm.com/ssldump/"
-IUSE="ssl"
+SRC_URI="http://www.rtfm.com/ssldump/${MY_P}.tar.gz"
+LICENSE="openssl"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-LICENSE="GPL-2"
+IUSE="ssl"
-DEPEND="net-libs/libpcap
- ssl? ( >=dev-libs/openssl-0.6.9 )"
+RDEPEND="net-libs/libpcap
+ ssl? ( >=dev-libs/openssl-1 )"
+DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A} ; cd ${S}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpcap-header.patch \
+ "${FILESDIR}"/${P}-configure-dylib.patch \
+ "${FILESDIR}"/${P}-openssl-0.9.8.compile-fix.patch \
+ "${FILESDIR}"/${P}-DLT_LINUX_SLL.patch
- epatch "${FILESDIR}/${P}"-libpcap-header.patch
- epatch "${FILESDIR}/${P}"-configure-dylib.patch
- epatch "${FILESDIR}/${P}"-openssl-0.9.8.compile-fix.patch
- epatch "${FILESDIR}/${P}"-DLT_LINUX_SLL.patch
- eautoreconf # fixes compiler detection
+ eautoreconf
}
-src_compile() {
- econf $(use_with ssl crypto)
- emake || die
+src_configure() {
+ local myconf
+ use ssl || myconf="--without-openssl"
+
+ econf ${myconf}
}
src_install() {
- into /usr
dosbin ssldump || die
doman ssldump.1 || die
- dodoc COPYRIGHT CREDITS README FILES VERSION INSTALL ChangeLog
+ dodoc ChangeLog CREDITS README
}
diff --git a/net-analyzer/ssldump/ssldump-0.9.ebuild b/net-analyzer/ssldump/ssldump-0.9.ebuild
deleted file mode 100644
index a65f961621b9..000000000000
--- a/net-analyzer/ssldump/ssldump-0.9.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ssldump/ssldump-0.9.ebuild,v 1.16 2008/02/06 21:12:19 grobian Exp $
-
-inherit eutils
-
-IUSE="ssl"
-
-MY_P=${PN}-0.9b3
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="A Tool for network monitoring and data acquisition"
-SRC_URI="http://www.rtfm.com/ssldump/${MY_P}.tar.gz"
-HOMEPAGE="http://www.rtfm.com/ssldump/"
-
-SLOT="0"
-KEYWORDS="amd64 ~ppc sparc x86"
-LICENSE="GPL-2"
-
-DEPEND="net-libs/libpcap
- ssl? ( >=dev-libs/openssl-0.6.9 )"
-
-src_unpack() {
- unpack ${A} ; cd ${S}
-
- epatch "${FILESDIR}/${P}"-libpcap-header.patch
- epatch "${FILESDIR}/${P}"-configure-dylib.patch
- epatch "${FILESDIR}/${P}"-openssl-0.9.8.compile-fix.patch
-}
-
-src_compile() {
-
- econf `use_with ssl crypto` || die
- emake || die
-}
-
-src_install() {
- into /usr
- dosbin ssldump
- doman ssldump.1
- dodoc COPYRIGHT CREDITS README FILES VERSION INSTALL ChangeLog
-}