summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-03-29 13:18:33 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-03-29 13:18:33 +0000
commit535ede82654083792c4d1e0ea631912699df9e31 (patch)
tree5dfebaf166802b98e090d93a6b240a336a0adea8 /net-analyzer
parentStable on hppa & sparc wrt security #127889 (diff)
downloadgentoo-2-535ede82654083792c4d1e0ea631912699df9e31.tar.gz
gentoo-2-535ede82654083792c4d1e0ea631912699df9e31.tar.bz2
gentoo-2-535ede82654083792c4d1e0ea631912699df9e31.zip
Add patch for building with gcc-4.1.
(Portage version: 2.1_pre7-r2)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ns/ChangeLog6
-rw-r--r--net-analyzer/ns/files/digest-ns-2.282
-rw-r--r--net-analyzer/ns/files/ns-2.28-gcc41.patch38
-rw-r--r--net-analyzer/ns/ns-2.28.ebuild3
4 files changed, 47 insertions, 2 deletions
diff --git a/net-analyzer/ns/ChangeLog b/net-analyzer/ns/ChangeLog
index 01927eb67610..ce7245d97c3c 100644
--- a/net-analyzer/ns/ChangeLog
+++ b/net-analyzer/ns/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/ns
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ChangeLog,v 1.20 2006/01/30 10:13:04 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ChangeLog,v 1.21 2006/03/29 13:18:32 exg Exp $
+
+ 29 Mar 2006; Emanuele Giaquinta <exg@gentoo.org>
+ +files/ns-2.28-gcc41.patch, ns-2.28.ebuild:
+ Add patch for building with gcc-4.1.
30 Jan 2006; Robin H. Johnson <robbat2@gentoo.org> Manifest:
Manifest fix.
diff --git a/net-analyzer/ns/files/digest-ns-2.28 b/net-analyzer/ns/files/digest-ns-2.28
index 0459d41cf277..5f690360021a 100644
--- a/net-analyzer/ns/files/digest-ns-2.28
+++ b/net-analyzer/ns/files/digest-ns-2.28
@@ -1 +1,3 @@
MD5 45ed7d066236aa981fd6cef6f9f44117 ns-src-2.28.tar.gz 46599585
+RMD160 f2ec76b7dc96bbfb75d8485ef2822ebdf50b8ed1 ns-src-2.28.tar.gz 46599585
+SHA256 422ffc5b6f4e0a5a4cfddebf97c728703368435800ce77716adaa7472f4faae1 ns-src-2.28.tar.gz 46599585
diff --git a/net-analyzer/ns/files/ns-2.28-gcc41.patch b/net-analyzer/ns/files/ns-2.28-gcc41.patch
new file mode 100644
index 000000000000..13c43131112a
--- /dev/null
+++ b/net-analyzer/ns/files/ns-2.28-gcc41.patch
@@ -0,0 +1,38 @@
+--- ns-2.28.orig/sctp/sctp.h 2006-03-28 18:53:00.496028739 +0200
++++ ns-2.28/sctp/sctp.h 2006-03-28 18:52:41.114371797 +0200
+@@ -627,7 +627,7 @@
+
+ /* debugging functions
+ */
+- void SctpAgent::DumpSendBuffer();
++ void DumpSendBuffer();
+
+ /* sctp association state variable
+ */
+--- ns-2.28.orig/mobile/god.h 2006-03-28 18:59:00.835568499 +0200
++++ ns-2.28/mobile/god.h 2006-03-28 18:59:29.789995089 +0200
+@@ -85,20 +85,20 @@
+ return sqrt(X*X + Y*Y + Z*Z);
+ }
+
+- inline void vector::operator=(const vector a) {
++ inline void operator=(const vector a) {
+ X = a.X;
+ Y = a.Y;
+ Z = a.Z;
+ }
+- inline void vector::operator+=(const vector a) {
++ inline void operator+=(const vector a) {
+ X += a.X;
+ Y += a.Y;
+ Z += a.Z;
+ }
+- inline int vector::operator==(const vector a) {
++ inline int operator==(const vector a) {
+ return (X == a.X && Y == a.Y && Z == a.Z);
+ }
+- inline int vector::operator!=(const vector a) {
++ inline int operator!=(const vector a) {
+ return (X != a.X || Y != a.Y || Z != a.Z);
+ }
+ inline vector operator-(const vector a) {
diff --git a/net-analyzer/ns/ns-2.28.ebuild b/net-analyzer/ns/ns-2.28.ebuild
index 64f5ea23a120..5106abf16cbb 100644
--- a/net-analyzer/ns/ns-2.28.ebuild
+++ b/net-analyzer/ns/ns-2.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ns-2.28.ebuild,v 1.4 2006/01/29 20:23:46 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ns-2.28.ebuild,v 1.5 2006/03/29 13:18:32 exg Exp $
inherit eutils toolchain-funcs
@@ -31,6 +31,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-gcc41.patch
}
src_compile() {