summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2009-09-26 10:39:33 +0000
committerMichael Januszewski <spock@gentoo.org>2009-09-26 10:39:33 +0000
commit556d13973eca4a8476f82c6ce6330391b751c497 (patch)
tree240b0de09ffea213efd3091b07c11ee699725683 /net-analyzer
parentStable for amd64 per bug #284088 (diff)
downloadgentoo-2-556d13973eca4a8476f82c6ce6330391b751c497.tar.gz
gentoo-2-556d13973eca4a8476f82c6ce6330391b751c497.tar.bz2
gentoo-2-556d13973eca4a8476f82c6ce6330391b751c497.zip
Add the bundled-libs USE flag, fix bug #280772 (properly specify liblua dependencies).
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/ChangeLog9
-rw-r--r--net-analyzer/nmap/metadata.xml8
-rw-r--r--net-analyzer/nmap/nmap-5.00-r1.ebuild64
3 files changed, 80 insertions, 1 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 8afbb43e6ec8..d73f72a78479 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/nmap
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.202 2009/07/16 20:19:47 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.203 2009/09/26 10:39:33 spock Exp $
+
+*nmap-5.00-r1 (26 Sep 2009)
+
+ 26 Sep 2009; Michał Januszewski <spock@gentoo.org> +nmap-5.00-r1.ebuild,
+ metadata.xml:
+ Add the bundled-libs USE flag, fix bug #280772 (properly specify liblua
+ dependencies).
*nmap-5.00 (16 Jul 2009)
diff --git a/net-analyzer/nmap/metadata.xml b/net-analyzer/nmap/metadata.xml
index f0607ae32cc0..03eb23051262 100644
--- a/net-analyzer/nmap/metadata.xml
+++ b/net-analyzer/nmap/metadata.xml
@@ -5,4 +5,12 @@
<maintainer>
<email>spock@gentoo.org</email>
</maintainer>
+<use>
+ <flag name="bundled-libs">
+ Use the liblua library bundled with nmap instead of the system one.
+ This doesn't affect the other libraries because the bundled libpcre
+ and libpcap are the same as the system libraries, and the bundled
+ libdnet is incompatible with the version available in the tree.
+ </flag>
+</use>
</pkgmetadata>
diff --git a/net-analyzer/nmap/nmap-5.00-r1.ebuild b/net-analyzer/nmap/nmap-5.00-r1.ebuild
new file mode 100644
index 000000000000..2dcf8b60b048
--- /dev/null
+++ b/net-analyzer/nmap/nmap-5.00-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-5.00-r1.ebuild,v 1.1 2009/09/26 10:39:33 spock Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+MY_P=${P//_rc1/RC1}
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="http://download.insecure.org/nmap/dist/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="bundled-libs gtk lua ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ || ( >=dev-lang/python-2.5[sqlite]
+ >=dev-python/pysqlite-2 )
+ )
+ ssl? ( dev-libs/openssl )
+ !bundled-libs? (
+ lua? ( >=dev-lang/lua-5.1.4-r1[deprecated] )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.75-include.patch"
+ epatch "${FILESDIR}/${PN}-4.75-nolua.patch"
+ sed -i -e 's/-m 755 -s ncat/-m 755 ncat/' ncat/Makefile.in
+}
+
+src_configure() {
+ local myconf=""
+
+ if use lua ; then
+ if use bundled-libs ; then
+ myconf="--with-liblua=included"
+ else
+ myconf="--with-liblua"
+ fi
+ else
+ myconf="--without-liblua"
+ fi
+
+ econf ${myconf} \
+ --with-libdnet=included \
+ $(use_with gtk zenmap) \
+ $(use_with ssl openssl) || die
+}
+
+src_install() {
+ LC_ALL=C emake DESTDIR="${D}" -j1 STRIP=: nmapdatadir=/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}