summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-20 08:07:32 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-20 08:07:32 +0000
commit6f2bfc9bd1337cc729bd93992f007c148c4bac04 (patch)
treef37ce128f8210f53ce19b0fa97ea8de0a215a343 /net-analyzer
parenthppa repoman (diff)
downloadgentoo-2-6f2bfc9bd1337cc729bd93992f007c148c4bac04.tar.gz
gentoo-2-6f2bfc9bd1337cc729bd93992f007c148c4bac04.tar.bz2
gentoo-2-6f2bfc9bd1337cc729bd93992f007c148c4bac04.zip
touch it
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.45-r2.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.45-r2.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.45-r2.ebuild
index 7c4410ce9fce..f4fb49238836 100644
--- a/net-analyzer/rrdtool/rrdtool-1.0.45-r2.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.0.45-r2.ebuild
@@ -1,21 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.45-r2.ebuild,v 1.4 2004/02/17 22:37:58 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.45-r2.ebuild,v 1.5 2004/02/20 08:07:32 vapier Exp $
inherit perl-module flag-o-matic gnuconfig
DESCRIPTION="A system to store and display time-series data"
-SRC_URI="http://people.ee.ethz.ch/%7Eoetiker/webtools/${PN}/pub/${P}.tar.gz"
HOMEPAGE="http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/"
+SRC_URI="http://people.ee.ethz.ch/%7Eoetiker/webtools/${PN}/pub/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc sparc ~amd64 alpha ia64 hppa"
IUSE="tcltk perl"
-filter-mfpmath "sse"
-filter-flags "-ffast-math"
-
DEPEND="perl? ( dev-lang/perl )
sys-apps/gawk
>=media-libs/libgd-1.8.3"
@@ -23,16 +20,19 @@ RDEPEND="tcltk? ( dev-lang/tcl )"
TCLVER=""
pkg_setup() {
- if [ "`use tcltk`" ]; then
+ if use tcltk ; then
TCLVER=`awk -F\' '/TCL_VERSION/ {print $2}' /usr/lib/tclConfig.sh`
fi
- if [ "`use perl`" ]; then
+ if use perl ; then
perl-module_pkg_setup
fi
}
src_compile() {
+ filter-mfpmath sse
+ filter-flags -ffast-math
+
local myconf
use tcltk \
&& myconf="${myconf} --with-tcllib=/usr/lib" \