summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 20:20:41 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 20:20:41 +0000
commit83bfa71f87e57728f36e380931df6b1261e2147b (patch)
treefdd5c1108ae70a02b1ca90a80f2d4d4894c7ca29 /net-analyzer
parentFix for gcc 4.3.3 / fortify_sources. Patch by Romain Perier. (diff)
downloadgentoo-2-83bfa71f87e57728f36e380931df6b1261e2147b.tar.gz
gentoo-2-83bfa71f87e57728f36e380931df6b1261e2147b.tar.bz2
gentoo-2-83bfa71f87e57728f36e380931df6b1261e2147b.zip
Fix for gcc 4.3.3 / fortify_sources. Patch by Jonathan-Christofer Demay.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ettercap/ChangeLog10
-rw-r--r--net-analyzer/ettercap/ettercap-0.7.3-r3.ebuild64
-rw-r--r--net-analyzer/ettercap/files/ettercap-0.7.3-open_missing_mode.patch12
3 files changed, 84 insertions, 2 deletions
diff --git a/net-analyzer/ettercap/ChangeLog b/net-analyzer/ettercap/ChangeLog
index 73630d212335..bc1d603864e6 100644
--- a/net-analyzer/ettercap/ChangeLog
+++ b/net-analyzer/ettercap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/ettercap
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.65 2007/09/06 16:31:55 jokey Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.66 2009/03/01 20:20:40 patrick Exp $
+
+*ettercap-0.7.3-r3 (01 Mar 2009)
+
+ 01 Mar 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/ettercap-0.7.3-open_missing_mode.patch, +ettercap-0.7.3-r3.ebuild:
+ Fix for gcc 4.3.3 / fortify_sources. Patch by Jonathan-Christofer Demay.
06 Sep 2007; Markus Ullmann <jokey@gentoo.org> -ettercap-0.7.3.ebuild:
Cleanup
diff --git a/net-analyzer/ettercap/ettercap-0.7.3-r3.ebuild b/net-analyzer/ettercap/ettercap-0.7.3-r3.ebuild
new file mode 100644
index 000000000000..d963212ca2ce
--- /dev/null
+++ b/net-analyzer/ettercap/ettercap-0.7.3-r3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-0.7.3-r3.ebuild,v 1.1 2009/03/01 20:20:40 patrick Exp $
+
+# the actual version is "NG-0.7.0" but I suppose portage people will not be
+# happy with it (as for the 0.6.b version), so let's set it to "0.7.0".
+# since 'ettercap NG' has to be intended as an upgrade to 0.6.x series and not as
+# a new project or branch, this will be fine...
+
+WANT_AUTOMAKE="1.8"
+
+# libtool is needed because it provides libltdl (needed for plugins)
+inherit autotools flag-o-matic libtool
+
+MY_P="${PN}-NG-${PV}"
+DESCRIPTION="A suite for man in the middle attacks and network mapping"
+HOMEPAGE="http://ettercap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug gtk ncurses ssl"
+
+RDEPEND=">=net-libs/libnet-1.1.2.1-r1
+ net-libs/libpcap
+ ncurses? ( sys-libs/ncurses )
+ ssl? ( dev-libs/openssl )
+ gtk? ( >=x11-libs/gtk+-2.2.2 )"
+DEPEND=${RDEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ epatch "${FILESDIR}"/${P}-open_missing_mode.patch
+ eautomake
+}
+
+src_compile() {
+ strip-flags
+
+ local myconf
+
+ if use ssl; then
+ myconf="${myconf} --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-openssl"
+ fi
+
+ econf ${myconf} \
+ $(use_enable gtk) \
+ $(use_enable debug) \
+ $(use_with ncurses) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}
diff --git a/net-analyzer/ettercap/files/ettercap-0.7.3-open_missing_mode.patch b/net-analyzer/ettercap/files/ettercap-0.7.3-open_missing_mode.patch
new file mode 100644
index 000000000000..03837fc9a3e9
--- /dev/null
+++ b/net-analyzer/ettercap/files/ettercap-0.7.3-open_missing_mode.patch
@@ -0,0 +1,12 @@
+diff -Naur ettercap-NG-0.7.3-orig/src/ec_log.c ettercap-NG-0.7.3-patch/src/ec_log.c
+--- ettercap-NG-0.7.3-orig/src/ec_log.c 2004-09-30 16:01:45.000000000 +0000
++++ ettercap-NG-0.7.3-patch/src/ec_log.c 2009-02-16 13:04:23.000000000 +0000
+@@ -190,7 +190,7 @@
+ if (fd->cfd == NULL)
+ SEMIFATAL_ERROR("%s", gzerror(fd->cfd, &zerr));
+ } else {
+- fd->fd = open(filename, O_CREAT | O_TRUNC | O_RDWR | O_BINARY);
++ fd->fd = open(filename, O_CREAT | O_TRUNC | O_RDWR | O_BINARY, S_IRUSR | S_IWUSR);
+ if (fd->fd == -1)
+ SEMIFATAL_ERROR("Can't create %s: %s", filename, strerror(errno));
+ }