summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-12-26 09:57:51 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-12-26 09:57:51 +0000
commit901c70da1d4cf23dd41dea5bc60ca8b327deefb5 (patch)
tree7edd0dcf2707c63d4eef789512538cf071c9aa2a /net-analyzer
parent[bump] dev-perl/File-Map-0.560.0 (diff)
downloadgentoo-2-901c70da1d4cf23dd41dea5bc60ca8b327deefb5.tar.gz
gentoo-2-901c70da1d4cf23dd41dea5bc60ca8b327deefb5.tar.bz2
gentoo-2-901c70da1d4cf23dd41dea5bc60ca8b327deefb5.zip
Revision bump: EAPI 5, fix for crosscompilation, wrt bug #375655
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/arpoison/ChangeLog7
-rw-r--r--net-analyzer/arpoison/arpoison-0.6-r2.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/net-analyzer/arpoison/ChangeLog b/net-analyzer/arpoison/ChangeLog
index 8c867d3c16d8..120c8f57a5cf 100644
--- a/net-analyzer/arpoison/ChangeLog
+++ b/net-analyzer/arpoison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/arpoison
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/arpoison/ChangeLog,v 1.11 2012/10/09 07:57:16 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/arpoison/ChangeLog,v 1.12 2012/12/26 09:57:51 pinkbyte Exp $
+
+*arpoison-0.6-r2 (26 Dec 2012)
+
+ 26 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> +arpoison-0.6-r2.ebuild:
+ Revision bump: EAPI 5, fix for crosscompilation, wrt bug #375655
09 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> +arpoison-0.6.ebuild:
Bring old revision back, cause it's the one stable on ppc and x86
diff --git a/net-analyzer/arpoison/arpoison-0.6-r2.ebuild b/net-analyzer/arpoison/arpoison-0.6-r2.ebuild
new file mode 100644
index 000000000000..95d0a72524bd
--- /dev/null
+++ b/net-analyzer/arpoison/arpoison-0.6-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/arpoison/arpoison-0.6-r2.ebuild,v 1.1 2012/12/26 09:57:51 pinkbyte Exp $
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A utility to poison ARP caches"
+HOMEPAGE="http://arpoison.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=net-libs/libnet-1.1.0"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # respect CFLAGS, LDFLAGS and compiler, bug #337896
+ # fix for crosscompilation, bug #375655
+ sed -i Makefile \
+ -e 's|gcc \(-Wall\)|$(CC) \1 $(CFLAGS) $(LDFLAGS)|' \
+ -e "s|libnet-config|${ROOT}usr/bin/libnet-config|g" \
+ || die "sed on Makefile failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin arpoison
+ doman arpoison.8
+ dodoc README TODO
+}