summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-08-01 14:51:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-08-01 14:51:59 +0000
commit981179cfba67e365f860a8f22e91d0b5319cef9e (patch)
tree921d1c05d484e28b449b462c3f7620fcc3bd6454 /net-analyzer
parentForce Manifest signing (diff)
downloadgentoo-2-981179cfba67e365f860a8f22e91d0b5319cef9e.tar.gz
gentoo-2-981179cfba67e365f860a8f22e91d0b5319cef9e.tar.bz2
gentoo-2-981179cfba67e365f860a8f22e91d0b5319cef9e.zip
Bump, fixes #292312. Thanks to everyone who worked on it
(Portage version: 2.2.0_alpha49/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nikto/ChangeLog9
-rw-r--r--net-analyzer/nikto/nikto-2.1.4.ebuild58
2 files changed, 65 insertions, 2 deletions
diff --git a/net-analyzer/nikto/ChangeLog b/net-analyzer/nikto/ChangeLog
index 690097bb20e5..1f3f2c382659 100644
--- a/net-analyzer/nikto/ChangeLog
+++ b/net-analyzer/nikto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nikto
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/ChangeLog,v 1.25 2010/05/26 16:38:56 abcd Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/ChangeLog,v 1.26 2011/08/01 14:51:59 patrick Exp $
+
+*nikto-2.1.4 (01 Aug 2011)
+
+ 01 Aug 2011; Patrick Lauer <patrick@gentoo.org> +nikto-2.1.4.ebuild:
+ Bump, fixes #292312. Thanks to everyone who worked on it
26 May 2010; Jonathan Callen <abcd@gentoo.org> nikto-2.03.ebuild:
Bump to EAPI=3, add prefix keywords, cleanup QA issues
diff --git a/net-analyzer/nikto/nikto-2.1.4.ebuild b/net-analyzer/nikto/nikto-2.1.4.ebuild
new file mode 100644
index 000000000000..eb8895945015
--- /dev/null
+++ b/net-analyzer/nikto/nikto-2.1.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/nikto-2.1.4.ebuild,v 1.1 2011/08/01 14:51:59 patrick Exp $
+
+EAPI=2
+
+DESCRIPTION="Web Server vulnerability scanner."
+HOMEPAGE="http://www.cirt.net/code/nikto.shtml"
+SRC_URI="http://www.cirt.net/nikto/ARCHIVE/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="ssl"
+
+RDEPEND="dev-lang/perl
+ >=net-libs/libwhisker-2.5
+ ssl? (
+ dev-libs/openssl
+ dev-perl/Net-SSLeay
+ )"
+
+src_prepare() {
+ sed -i -e 's:config.txt:nikto.conf:g' \
+ plugins/* || die
+
+ sed -i -e 's:/etc/nikto.conf:/etc/nikto/nikto.conf:' \
+ nikto.pl || die
+
+ sed -i -e 's:# EXECDIR=/usr/local/nikto:EXECDIR=/usr/share/nikto:' \
+ nikto.conf || die
+
+ sed -i -e 's:# use LW2:use LW2:' \
+ nikto.pl || die
+ sed -i -e 's:require "$CONFIGFILE{'\''PLUGINDIR'\''}/LW2.pm":# require "$CONFIGFILE{'\''PLUGINDIR'\''}/LW2.pm":' \
+ nikto.pl || die
+ rm plugins/LW2.pm || die "removing bundled lib LW2.pm failed"
+}
+
+src_compile() {
+ einfo "nothing to compile"
+ true
+}
+
+src_install() {
+ insinto /etc/nikto
+ doins nikto.conf || die "config install failed"
+
+ dobin nikto.pl || die "install failed"
+ dosym /usr/bin/nikto.pl /usr/bin/nikto || die
+
+ dodir /usr/share/nikto
+ insinto /usr/share/nikto
+ doins -r plugins templates || die
+
+ dodoc docs/*.txt || die
+ dohtml docs/nikto_manual.html || die
+}