summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2011-11-15 01:47:18 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2011-11-15 01:47:18 +0000
commitca45e7fac7f209c7bafc09f86128f84a3e96cffa (patch)
treeb9958e04bfa2ec63a61eb5d6563a7d687f4b66c8 /net-analyzer
parentRestore latest stable 4.4 ebuild. Remove 5.2.2-r1 for bug #336166 (removal of... (diff)
downloadgentoo-2-ca45e7fac7f209c7bafc09f86128f84a3e96cffa.tar.gz
gentoo-2-ca45e7fac7f209c7bafc09f86128f84a3e96cffa.tar.bz2
gentoo-2-ca45e7fac7f209c7bafc09f86128f84a3e96cffa.zip
Revbump to 1.5.1-r1 to fix prestripped-binaries
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/icinga/ChangeLog8
-rw-r--r--net-analyzer/icinga/files/fix-prestripped-binaries.patch23
-rw-r--r--net-analyzer/icinga/icinga-1.5.1-r1.ebuild213
3 files changed, 243 insertions, 1 deletions
diff --git a/net-analyzer/icinga/ChangeLog b/net-analyzer/icinga/ChangeLog
index 0e8fa8cad8e3..a38e8bd5ba89 100644
--- a/net-analyzer/icinga/ChangeLog
+++ b/net-analyzer/icinga/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/icinga
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/ChangeLog,v 1.1 2011/11/15 00:14:29 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/ChangeLog,v 1.2 2011/11/15 01:47:18 prometheanfire Exp $
+
+*icinga-1.5.1-r1 (15 Nov 2011)
+
+ 15 Nov 2011; mthode <mthode@gentoo.org> +icinga-1.5.1-r1.ebuild,
+ +files/fix-prestripped-binaries.patch:
+ Revbump to fix prestripped-binaries
*icinga-1.5.1 (15 Nov 2011)
diff --git a/net-analyzer/icinga/files/fix-prestripped-binaries.patch b/net-analyzer/icinga/files/fix-prestripped-binaries.patch
new file mode 100644
index 000000000000..1ee52c55a933
--- /dev/null
+++ b/net-analyzer/icinga/files/fix-prestripped-binaries.patch
@@ -0,0 +1,23 @@
+diff -Naur icinga-1.5.1.orig//base/Makefile.in icinga-1.5.1/base/Makefile.in
+--- icinga-1.5.1.orig//base/Makefile.in 2011-09-09 11:50:53.000000000 -0400
++++ icinga-1.5.1/base/Makefile.in 2011-11-14 19:45:36.000000000 -0500
+@@ -39,7 +39,7 @@
+ INSTALL=@INSTALL@
+ INSTALL_OPTS=@INSTALL_OPTS@
+ COMMAND_OPTS=@COMMAND_OPTS@
+-STRIP=@STRIP@
++STRIP=/bin/true
+
+ CGIURL=@cgiurl@
+ HTMURL=@htmurl@
+diff -Naur icinga-1.5.1.orig//cgi/Makefile.in icinga-1.5.1/cgi/Makefile.in
+--- icinga-1.5.1.orig//cgi/Makefile.in 2011-09-09 11:50:53.000000000 -0400
++++ icinga-1.5.1/cgi/Makefile.in 2011-11-14 19:45:47.000000000 -0500
+@@ -20,7 +20,7 @@
+ INSTALL_OPTS=@INSTALL_OPTS@
+ INSTALL_OPTS_WEB=@INSTALL_OPTS_WEB@
+ COMMAND_OPTS=@COMMAND_OPTS@
+-STRIP=@STRIP@
++STRIP=/bin/true
+
+ CGIEXTRAS=@CGIEXTRAS@
diff --git a/net-analyzer/icinga/icinga-1.5.1-r1.ebuild b/net-analyzer/icinga/icinga-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..9a853b9135be
--- /dev/null
+++ b/net-analyzer/icinga/icinga-1.5.1-r1.ebuild
@@ -0,0 +1,213 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/icinga-1.5.1-r1.ebuild,v 1.1 2011/11/15 01:47:18 prometheanfire Exp $
+
+EAPI=2
+
+inherit depend.apache eutils multilib toolchain-funcs
+
+DESCRIPTION="Nagios Fork - Check daemon, CGIs, docs, IDOutils"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+apache2 api debug +idoutils lighttpd +mysql perl plugins postgres ssl +vim-syntax +web"
+DEPEND="idoutils? ( dev-db/libdbi-drivers[mysql?,postgres?] )
+ perl? ( dev-lang/perl )
+ virtual/mailx
+ web? (
+ media-libs/gd[jpeg,png]
+ lighttpd? ( www-servers/lighttpd dev-lang/php[cgi] )
+ apache2? ( || ( dev-lang/php[apache2] dev-lang/php[cgi] ) )
+ )
+ !net-analyzer/nagios-core"
+RDEPEND="${DEPEND}
+ plugins? ( net-analyzer/nagios-plugins )"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+ enewgroup icinga
+ enewuser icinga -1 -1 /var/spool/icinga icinga
+ if use web ; then
+ elog "This does not include cgis that are perl-dependent"
+ elog "Currently traceroute.cgi is perl-dependent"
+ elog "Note that the user your webserver is running as needs"
+ elog "read-access to /etc/icinga."
+ elog
+ if use apache2 || use lighttpd ; then
+ elog "There are several possible solutions to accomplish this,"
+ elog "choose the one you are most comfortable with:"
+ elog
+ if use apache2 ; then
+ elog " usermod -G icinga apache"
+ elog "or"
+ elog " chown icinga:apache /etc/icinga"
+ elog
+ elog "Also edit /etc/conf.d/apache2 and add \"-D ICINGA\""
+ elif use lighttpd ; then
+ elog " usermod -G icinga lighttpd "
+ elog "or"
+ elog " chown icinga:lighttpd /etc/icinga"
+ elog "Also edit /etc/lighttpd/lighttpd.conf and add 'include \"lighttpd_icinga.conf\"'"
+ fi
+ elog
+ elog "That will make icinga's web front end visable via"
+ elog "http://localhost/icinga/"
+ elog
+ else
+ elog "IMPORTANT: Do not forget to add the user your webserver"
+ elog "is running as to the icinga group!"
+ fi
+
+ else
+ ewarn "Please note that you have installed Icinga without web interface."
+ ewarn "Please don't file any bugs about having no web interface when you do this."
+ ewarn "Thank you!"
+ fi
+
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/fix-prestripped-binaries.patch"
+}
+
+src_configure() {
+ local myconf
+ local myconf2
+
+ myconf="$(use_enable perl embedded-perl)
+ $(use_with perl perlcache)
+ $(use_enable idoutils)
+ $(use_enable ssl)
+ $(use_enable debug DEBUG0)
+ $(use_enable debug DEBUG1)
+ $(use_enable debug DEBUG2)
+ $(use_enable debug DEBUG3)
+ $(use_enable debug DEBUG4)
+ $(use_enable debug DEBUG5)
+ --disable-statuswrl
+ --with-cgiurl=/icinga/cgi-bin
+ --with-log-dir=/var/log/icinga"
+
+ myconf2="--bindir=/usr/sbin
+ --sbindir=/usr/$(get_libdir)/icinga/cgi-bin
+ --datarootdir=/usr/share/icinga/htdocs
+ --localstatedir=/var/icinga
+ --sysconfdir=/etc/icinga"
+
+ if use plugins ; then
+ myconf2+=" --libexecdir=/usr/$(get_libdir)/nagios/plugins"
+ else
+ myconf2+=" --libexecdir=/usr/$(get_libdir)/icinga/plugins"
+ fi
+
+ if use !apache2 && use !lighttpd ; then
+ myconf2+=" --with-command-group=icinga"
+ else
+ if use apache2 ; then
+ myconf+=" --with-httpd-conf=/etc/apache2/conf.d"
+ myconf2+=" --with-command-group=apache"
+ elif use lighttpd ; then
+ myconf2+=" --with-command-group=lighttpd"
+ fi
+ fi
+
+ econf ${myconf} ${myconf2}
+ if use api ; then
+ cd module/icinga-api || die
+ econf ${myconf2}
+ fi
+}
+
+src_compile() {
+ tc-export CC
+
+ emake icinga || die "make failed"
+
+ if use web ; then
+ emake DESTDIR="${D}" cgis || die
+ fi
+
+ if use idoutils ; then
+ emake DESTDIR="${D}" idoutils || die
+ fi
+}
+
+src_install() {
+ dodoc Changelog README UPGRADING || die
+
+ if ! use web ; then
+ sed -i -e '/cd $(SRC_\(CGI\|HTM\))/d' Makefile || die
+ fi
+ sed -i -e 's/^contactgroups$//g' Makefile || die
+
+ emake DESTDIR="${D}" install{,-config,-commandmode} || die
+
+ if use idoutils ; then
+ emake DESTDIR="${D}" install-idoutils || die
+ fi
+ if use api ; then
+ emake DESTDIR="${D}" install-api || die
+ fi
+
+ newinitd "${FILESDIR}"/icinga-init.d icinga || die
+ newconfd "${FILESDIR}"/icinga-conf.d icinga || die
+ if use idoutils ; then
+ newinitd "${FILESDIR}"/ido2db-init.d ido2db || die
+ newconfd "${FILESDIR}"/ido2db-conf.d ido2db || die
+ insinto /usr/share/icinga/contrib/db
+ doins -r module/idoutils/db/* || die
+ fi
+ # Apache Module
+ if use web ; then
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}"/icinga-apache.conf 99_icinga.conf || die
+ elif use lighttpd ; then
+ insinto /etc/lighttpd
+ newins "${FILESDIR}"/icinga-lighty.conf lighttpd_icinga.conf || die
+ else
+ ewarn "${CATEGORY}/${PF} only supports Apache-2.x or Lighttpd webserver"
+ ewarn "out-of-the-box. Since you are not using one of them, you"
+ ewarn "have to configure your webserver accordingly yourself."
+ fi
+ fi
+
+ fowners -R root:root /usr/$(get_libdir)/icinga || die
+ cd "${D}" || die
+ find usr/$(get_libdir)/icinga -type d -exec fperms 755 {} +
+ find usr/$(get_libdir)/icinga/cgi-bin -type f -exec fperms 755 {} +
+
+ keepdir /etc/icinga
+ keepdir /var/icinga
+ keepdir /var/icinga/archives
+ keepdir /var/icinga/rw
+ keepdir /var/icinga/spool/checkresults
+
+ if use apache2 ; then
+ webserver=apache
+ elif use lighttpd ; then
+ webserver=lighttpd
+ else
+ webserver=icinga
+ fi
+ fowners -R icinga:${webserver} /var/icinga/rw || die "Failed chown of /var/icinga/rw"
+
+ fperms 6755 /var/icinga/rw || die "Failed Chmod of ${D}/var/icinga/rw"
+ fperms 0750 /etc/icinga || die "Failed chmod of ${D}/etc/icinga"
+}
+
+pkg_postinst() {
+ elog "If you want icinga to start at boot time"
+ elog "remember to execute:"
+ elog " rc-update add icinga default"
+ elog
+ elog "If your kernel has /proc protection, icinga"
+ elog "will not be happy as it relies on accessing the proc"
+ elog "filesystem. You can fix this by adding icinga into"
+ elog "the group wheel, but this is not recomended."
+}