summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-04-25 09:30:10 +0000
committerAlin Năstac <mrness@gentoo.org>2009-04-25 09:30:10 +0000
commitce282689f205a1e248e944988e3bd95b295f2c02 (patch)
treeb3c8a452f8b02c3bd05967f85aca38d8088514ef /net-analyzer
parentVersion bump (diff)
downloadgentoo-2-ce282689f205a1e248e944988e3bd95b295f2c02.tar.gz
gentoo-2-ce282689f205a1e248e944988e3bd95b295f2c02.tar.bz2
gentoo-2-ce282689f205a1e248e944988e3bd95b295f2c02.zip
Fix insecure log file creation (#266947).
(Portage version: 2.1.6.7/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ntop/ChangeLog9
-rw-r--r--net-analyzer/ntop/files/ntop-3.3.9-accesslog-umask.patch11
-rw-r--r--net-analyzer/ntop/ntop-3.3.9-r2.ebuild (renamed from net-analyzer/ntop/ntop-3.3.9-r1.ebuild)3
3 files changed, 21 insertions, 2 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index 3d7423a61b02..e0f5df3052fd 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/ntop
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.74 2009/04/22 21:13:45 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.75 2009/04/25 09:30:09 mrness Exp $
+
+*ntop-3.3.9-r2 (25 Apr 2009)
+
+ 25 Apr 2009; Alin Năstac <mrness@gentoo.org>
+ +files/ntop-3.3.9-accesslog-umask.patch, -ntop-3.3.9-r1.ebuild,
+ +ntop-3.3.9-r2.ebuild:
+ Fix insecure log file creation (#266947).
22 Apr 2009; Markus Meier <maekke@gentoo.org> ntop-3.3.9-r1:
x86 stable, bug #265704
diff --git a/net-analyzer/ntop/files/ntop-3.3.9-accesslog-umask.patch b/net-analyzer/ntop/files/ntop-3.3.9-accesslog-umask.patch
new file mode 100644
index 000000000000..75eda9e3f7b9
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-3.3.9-accesslog-umask.patch
@@ -0,0 +1,11 @@
+diff -Nru ntop-3.3.9.orig/http.c ntop-3.3.9/http.c
+--- ntop-3.3.9.orig/http.c 2008-11-07 00:56:35.000000000 +0000
++++ ntop-3.3.9/http.c 2009-04-25 09:23:50.000000000 +0000
+@@ -1341,6 +1341,7 @@
+ void initAccessLog(void) {
+
+ if(myGlobals.runningPref.accessLogFile) {
++ umask(0137);
+ myGlobals.accessLogFd = fopen(myGlobals.runningPref.accessLogFile, "a");
+ if(myGlobals.accessLogFd == NULL) {
+ traceEvent(CONST_TRACE_ERROR, "Unable to create file %s. Access log is disabled.",
diff --git a/net-analyzer/ntop/ntop-3.3.9-r1.ebuild b/net-analyzer/ntop/ntop-3.3.9-r2.ebuild
index b6adb76884b1..34308abecfe8 100644
--- a/net-analyzer/ntop/ntop-3.3.9-r1.ebuild
+++ b/net-analyzer/ntop/ntop-3.3.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.3.9-r1.ebuild,v 1.6 2009/04/22 21:13:45 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.3.9-r2.ebuild,v 1.1 2009/04/25 09:30:09 mrness Exp $
EAPI="2"
@@ -69,6 +69,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
epatch "${FILESDIR}"/${P}-external-geoip.patch
+ epatch "${FILESDIR}"/${P}-accesslog-umask.patch
cat acinclude.m4.in acinclude.m4.ntop > acinclude.m4
eautoreconf
}