summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-06 10:14:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-06 10:14:30 +0000
commitd7b01e1d382872a5f19b8d2c4ad6324514a9b6e2 (patch)
tree2bb6e850b28282e3e73df03586d56b71b9b2e4e5 /net-analyzer
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-d7b01e1d382872a5f19b8d2c4ad6324514a9b6e2.tar.gz
gentoo-2-d7b01e1d382872a5f19b8d2c4ad6324514a9b6e2.tar.bz2
gentoo-2-d7b01e1d382872a5f19b8d2c4ad6324514a9b6e2.zip
Fix building with GCC 4.5+ wrt #318483 by Kacper Kowalik.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmapsi/ChangeLog6
-rw-r--r--net-analyzer/nmapsi/files/nmapsi-0.2_alpha3-gcc45.patch188
-rw-r--r--net-analyzer/nmapsi/nmapsi-0.2_alpha3.ebuild8
3 files changed, 199 insertions, 3 deletions
diff --git a/net-analyzer/nmapsi/ChangeLog b/net-analyzer/nmapsi/ChangeLog
index 07ba67334b6c..d153fbd39ca4 100644
--- a/net-analyzer/nmapsi/ChangeLog
+++ b/net-analyzer/nmapsi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nmapsi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/ChangeLog,v 1.2 2010/02/18 09:14:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/ChangeLog,v 1.3 2010/05/06 10:14:30 ssuominen Exp $
+
+ 06 May 2010; Samuli Suominen <ssuominen@gentoo.org>
+ nmapsi-0.2_alpha3.ebuild, +files/nmapsi-0.2_alpha3-gcc45.patch:
+ Fix building with GCC 4.5+ wrt #318483 by Kacper Kowalik.
*nmapsi-0.2_alpha3 (18 Feb 2010)
diff --git a/net-analyzer/nmapsi/files/nmapsi-0.2_alpha3-gcc45.patch b/net-analyzer/nmapsi/files/nmapsi-0.2_alpha3-gcc45.patch
new file mode 100644
index 000000000000..692af44ee794
--- /dev/null
+++ b/net-analyzer/nmapsi/files/nmapsi-0.2_alpha3-gcc45.patch
@@ -0,0 +1,188 @@
+diff -ur nmapsi4-0.2-alpha3.orig/lib/history/loghistory.cpp nmapsi4-0.2-alpha3/lib/history/loghistory.cpp
+--- nmapsi4-0.2-alpha3.orig/lib/history/loghistory.cpp 2010-01-14 18:37:42.000000000 +0200
++++ nmapsi4-0.2-alpha3/lib/history/loghistory.cpp 2010-05-06 13:13:18.000000000 +0300
+@@ -105,7 +105,7 @@
+ qDeleteAll(ItemListHistory);
+ ItemListHistory.clear();
+ logTree->clear();
+- logTree->setIconSize(QSize::QSize(32, 32));
++ logTree->setIconSize(QSize(32, 32));
+
+ QFile *tmpFile = new QFile();
+ short index = 0;
+@@ -166,7 +166,7 @@
+ qDeleteAll(ItemListHistory);
+ ItemListHistory.clear();
+ logTree->clear();
+- logTree->setIconSize(QSize::QSize(22, 22));
++ logTree->setIconSize(QSize(22, 22));
+
+ if (!urlList.isEmpty() && urlList.first().compare("NULL") && urlListTime.first().compare("NULL")) {
+ #ifndef HISTORY_NO_DEBUG
+diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/core/digSupport/digSupport.cpp nmapsi4-0.2-alpha3/nmapsi4/core/digSupport/digSupport.cpp
+--- nmapsi4-0.2-alpha3.orig/nmapsi4/core/digSupport/digSupport.cpp 2010-01-14 18:37:43.000000000 +0200
++++ nmapsi4-0.2-alpha3/nmapsi4/core/digSupport/digSupport.cpp 2010-05-06 13:13:18.000000000 +0300
+@@ -88,7 +88,7 @@
+ QTextStream stream1(&buff1);
+ QString line;
+
+- Wview->setIconSize(QSize::QSize(32, 32));
++ Wview->setIconSize(QSize(32, 32));
+ QTreeWidgetItem *rootLook = new QTreeWidgetItem(Wview);
+ itemList.push_front(rootLook);
+
+@@ -107,7 +107,7 @@
+ #endif
+ itemLook = new QTreeWidgetItem(rootLook);
+ itemList.push_front(itemLook);
+- itemLook->setSizeHint(0, QSize::QSize(22, 22));
++ itemLook->setSizeHint(0, QSize(22, 22));
+ itemLook->setIcon(0, QIcon(QString::fromUtf8(":/images/images/view-web-browser-dom-tree.png")));
+ itemLook->setText(0,line);
+ if(!resultFlag) {
+diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/core/hostCheck.cpp nmapsi4-0.2-alpha3/nmapsi4/core/hostCheck.cpp
+--- nmapsi4-0.2-alpha3.orig/nmapsi4/core/hostCheck.cpp 2010-01-14 18:37:43.000000000 +0200
++++ nmapsi4-0.2-alpha3/nmapsi4/core/hostCheck.cpp 2010-05-06 13:13:18.000000000 +0300
+@@ -30,7 +30,7 @@
+ this->delMonitorHost(scanMonitor,hostname);
+ return;
+ }
+- treeLookup->setIconSize(QSize::QSize(32, 32));
++ treeLookup->setIconSize(QSize(32, 32));
+ treeLookup->header()->setResizeMode(0, QHeaderView::Interactive);
+
+ rootLook = new QTreeWidgetItem(treeLookup);
+diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/core/nmapParser.cpp nmapsi4-0.2-alpha3/nmapsi4/core/nmapParser.cpp
+--- nmapsi4-0.2-alpha3.orig/nmapsi4/core/nmapParser.cpp 2010-01-14 18:37:43.000000000 +0200
++++ nmapsi4-0.2-alpha3/nmapsi4/core/nmapParser.cpp 2010-05-06 13:13:18.000000000 +0300
+@@ -187,17 +187,17 @@
+ *out << nmap_command << endl << endl;
+ }
+
+- listWscan->setIconSize(QSize::QSize(32, 32));
++ listWscan->setIconSize(QSize(32, 32));
+ listWscan->header()->setResizeMode(0, QHeaderView::Interactive);
+- listScanError->setIconSize(QSize::QSize(32, 32));
++ listScanError->setIconSize(QSize(32, 32));
+ listScanError->header()->setResizeMode(0, QHeaderView::Interactive);
+- listScan->setIconSize(QSize::QSize(32, 32));
++ listScan->setIconSize(QSize(32, 32));
+ listScan->header()->setResizeMode(0, QHeaderView::Interactive);
+- treeWinfo->setIconSize(QSize::QSize(32, 32));
++ treeWinfo->setIconSize(QSize(32, 32));
+ treeWinfo->header()->setResizeMode(0, QHeaderView::Interactive);
+- treeTraceroot->setIconSize(QSize::QSize(32, 32));
++ treeTraceroot->setIconSize(QSize(32, 32));
+ treeTraceroot->header()->setResizeMode(0, QHeaderView::Interactive);
+- treeNSS->setIconSize(QSize::QSize(32, 32));
++ treeNSS->setIconSize(QSize(32, 32));
+ treeNSS->header()->setResizeMode(0, QHeaderView::Interactive);
+
+ int tmpBox = toolBox->currentIndex();
+@@ -270,16 +270,16 @@
+ || b2_line.contains("unfiltered")) {
+
+ if (b2_line.contains("filtered") || b2_line.contains("unfiltered")) {
+- item2->setSizeHint(0, QSize::QSize(22, 22));
++ item2->setSizeHint(0, QSize(22, 22));
+ item2->setIcon(0, QIcon(QString::fromUtf8(":/images/images/flag_yellow.png")));
+ filtered_port++;
+ } else {
+- item2->setSizeHint(0, QSize::QSize(22, 22));
++ item2->setSizeHint(0, QSize(22, 22));
+ item2->setIcon(0, QIcon(QString::fromUtf8(":/images/images/flag_green.png")));
+ open_port++;
+ }
+ } else {
+- item2->setSizeHint(0, QSize::QSize(22, 22));
++ item2->setSizeHint(0, QSize(22, 22));
+ item2->setIcon(0, QIcon(QString::fromUtf8(":/images/images/flag_red.png")));
+ close_port++;
+ }
+@@ -392,7 +392,7 @@
+ itemList.push_front(infoItemObj); // reference to address
+
+ if (!b3_line.isEmpty()) {
+- infoItemObj->setSizeHint(0, QSize::QSize(22, 22));
++ infoItemObj->setSizeHint(0, QSize(22, 22));
+ infoItemObj->setIcon(0, QIcon(QString::fromUtf8(":/images/images/messagebox_info.png")));
+ infoItemObj->setText(0, b3_line);
+ infoItemObj->setToolTip(0, b3_line); // field information
+@@ -451,7 +451,7 @@
+ }
+ // ------------------------------------------------------------------------
+
+- infoTracerootObj->setSizeHint(0, QSize::QSize(22, 22));
++ infoTracerootObj->setSizeHint(0, QSize(22, 22));
+ infoTracerootObj->setIcon(0, QIcon(QString::fromUtf8(":/images/images/traceroute.png")));
+ if ((PFile) && (!verboseLog)) *out << infoTracerootObj->text(0) << endl;
+ }
+@@ -475,7 +475,7 @@
+ infoNSSObj = new QTreeWidgetItem(infoNSS);
+ itemList.push_front(infoNSSObj);
+
+- infoNSSObj->setSizeHint(0, QSize::QSize(22, 22));
++ infoNSSObj->setSizeHint(0, QSize(22, 22));
+ infoNSSObj->setIcon(0, QIcon(QString::fromUtf8(":/images/images/traceroute.png")));
+ infoNSSObj->setText(0, bNSS_line);
+ infoNSSObj->setToolTip(0, bNSS_line); // field information
+diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/core/resizeNmapsi4.cpp nmapsi4-0.2-alpha3/nmapsi4/core/resizeNmapsi4.cpp
+--- nmapsi4-0.2-alpha3.orig/nmapsi4/core/resizeNmapsi4.cpp 2010-01-14 18:37:43.000000000 +0200
++++ nmapsi4-0.2-alpha3/nmapsi4/core/resizeNmapsi4.cpp 2010-05-06 13:13:18.000000000 +0300
+@@ -96,7 +96,7 @@
+
+ void nmapClass::optionListCreate() {
+
+- optionsListScan->setIconSize(QSize::QSize(52, 52));
++ optionsListScan->setIconSize(QSize(52, 52));
+
+ scanW = new QListWidgetItem(optionsListScan);
+ scanW->setIcon(QIcon(QString::fromUtf8(":/images/images/viewmag.png")));
+diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/core/scanMonitor.cpp nmapsi4-0.2-alpha3/nmapsi4/core/scanMonitor.cpp
+--- nmapsi4-0.2-alpha3.orig/nmapsi4/core/scanMonitor.cpp 2010-01-14 18:37:43.000000000 +0200
++++ nmapsi4-0.2-alpha3/nmapsi4/core/scanMonitor.cpp 2010-05-06 13:13:18.000000000 +0300
+@@ -20,7 +20,7 @@
+ #include "../mainwin.h"
+
+ void nmapClass::addMonitorHost(QTreeWidget* monitor, const QString host) {
+- scanMonitor->setIconSize(QSize::QSize(32, 32));
++ scanMonitor->setIconSize(QSize(32, 32));
+ scanMonitor->header()->setResizeMode(0, QHeaderView::Interactive);
+ tabWidget->setTabIcon(2,QIcon(QString::fromUtf8(":/images/images/reload.png")));
+ QTreeWidgetItem *hostThread = new QTreeWidgetItem(monitor);
+diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/preference/listExtension.cpp nmapsi4-0.2-alpha3/nmapsi4/preference/listExtension.cpp
+--- nmapsi4-0.2-alpha3.orig/nmapsi4/preference/listExtension.cpp 2010-01-14 18:37:43.000000000 +0200
++++ nmapsi4-0.2-alpha3/nmapsi4/preference/listExtension.cpp 2010-05-06 13:13:18.000000000 +0300
+@@ -26,7 +26,7 @@
+ vulnExt = extension.value("vulnFlag", "false").toBool();
+ extList->clear(); // clear listWidget for reload use
+
+- extList->setIconSize(QSize::QSize(48, 48));
++ extList->setIconSize(QSize(48, 48));
+ QIcon imgA = QIcon(QString::fromUtf8(":/images/nmapsi4/preference/images/preferences-pluginA.png"));
+ QIcon imgD = QIcon(QString::fromUtf8(":/images/nmapsi4/preference/images/preferences-pluginD.png"));
+
+diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/preference/profilemain.cpp nmapsi4-0.2-alpha3/nmapsi4/preference/profilemain.cpp
+--- nmapsi4-0.2-alpha3.orig/nmapsi4/preference/profilemain.cpp 2010-01-14 18:37:43.000000000 +0200
++++ nmapsi4-0.2-alpha3/nmapsi4/preference/profilemain.cpp 2010-05-06 13:13:18.000000000 +0300
+@@ -90,7 +90,7 @@
+
+ // Create listview items
+ // TODO insert history item and window setup
+- listViewOptions->setIconSize(QSize::QSize(52, 52));
++ listViewOptions->setIconSize(QSize(52, 52));
+
+ profileItem = new QListWidgetItem(listViewOptions);
+ profileItem->setIcon(QIcon(QString::fromUtf8(":/images/images/preferences-system-windows.png")));
+diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4-logr/mainwin.cpp nmapsi4-0.2-alpha3/nmapsi4-logr/mainwin.cpp
+--- nmapsi4-0.2-alpha3.orig/nmapsi4-logr/mainwin.cpp 2010-01-14 18:37:43.000000000 +0200
++++ nmapsi4-0.2-alpha3/nmapsi4-logr/mainwin.cpp 2010-05-06 13:13:18.000000000 +0300
+@@ -99,7 +99,7 @@
+ QTextStream buffer(logF);
+ QString tmpLine;
+
+- treeLogView->setIconSize(QSize::QSize(32, 32));
++ treeLogView->setIconSize(QSize(32, 32));
+
+ while (!buffer.atEnd()) {
+ tmpLine = buffer.readLine();
diff --git a/net-analyzer/nmapsi/nmapsi-0.2_alpha3.ebuild b/net-analyzer/nmapsi/nmapsi-0.2_alpha3.ebuild
index e992b5fbbb91..d59d59fa5dd8 100644
--- a/net-analyzer/nmapsi/nmapsi-0.2_alpha3.ebuild
+++ b/net-analyzer/nmapsi/nmapsi-0.2_alpha3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/nmapsi-0.2_alpha3.ebuild,v 1.1 2010/02/18 09:14:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/nmapsi-0.2_alpha3.ebuild,v 1.2 2010/05/06 10:14:30 ssuominen Exp $
EAPI=2
-inherit cmake-utils
+inherit cmake-utils eutils
MY_P=${PN}4-${PV/_/-}
@@ -25,6 +25,10 @@ S=${WORKDIR}/${MY_P}
DOCS="AUTHORS NEWS README TODO Translation"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+}
+
src_install() {
cmake-utils_src_install
fperms 755 /usr/bin/nmapsi4{,-logr}