summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:25:09 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:25:09 +0000
commit0970619cde17d4ef0fb31fea949e7f53b65fc26b (patch)
treef44f79a6575d18f38acba173be3b78b33984fcad /net-dialup/fcclassic
parentfixing string.h problem (see bug #202385) + patches for kernel 2.6.24 (thanks... (diff)
downloadgentoo-2-0970619cde17d4ef0fb31fea949e7f53b65fc26b.tar.gz
gentoo-2-0970619cde17d4ef0fb31fea949e7f53b65fc26b.tar.bz2
gentoo-2-0970619cde17d4ef0fb31fea949e7f53b65fc26b.zip
fixing string.h problem (see bug #202385).
(Portage version: 2.1.4)
Diffstat (limited to 'net-dialup/fcclassic')
-rw-r--r--net-dialup/fcclassic/ChangeLog8
-rw-r--r--net-dialup/fcclassic/fcclassic-0.1-r1.ebuild46
-rw-r--r--net-dialup/fcclassic/files/digest-fcclassic-0.1-r13
3 files changed, 56 insertions, 1 deletions
diff --git a/net-dialup/fcclassic/ChangeLog b/net-dialup/fcclassic/ChangeLog
index 02257f0d9c5e..9999c33804d1 100644
--- a/net-dialup/fcclassic/ChangeLog
+++ b/net-dialup/fcclassic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/fcclassic
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcclassic/ChangeLog,v 1.1 2008/01/06 01:30:19 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcclassic/ChangeLog,v 1.2 2008/01/30 01:25:08 sbriesen Exp $
+
+*fcclassic-0.1-r1 (30 Jan 2008)
+
+ 30 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ +fcclassic-0.1-r1.ebuild:
+ fixing string.h problem (see bug #202385).
*fcclassic-0.1 (06 Jan 2008)
diff --git a/net-dialup/fcclassic/fcclassic-0.1-r1.ebuild b/net-dialup/fcclassic/fcclassic-0.1-r1.ebuild
new file mode 100644
index 000000000000..11b0f8b3c9dc
--- /dev/null
+++ b/net-dialup/fcclassic/fcclassic-0.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcclassic/fcclassic-0.1-r1.ebuild,v 1.1 2008/01/30 01:25:08 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!Card Classic"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="!net-dialup/fritzcapi"
+RDEPEND="${DEPEND} net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-*.tar.bz2
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[01234]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ convert_to_m src/Makefile
+
+ for i in lib/*-lib.o; do
+ einfo "Localize symbols in ${i##*/} ..."
+ objcopy -L memcmp -L memcpy -L memmove -L memset -L strcat \
+ -L strcmp -L strcpy -L strlen -L strncmp -L strncpy "${i}"
+ done
+}
diff --git a/net-dialup/fcclassic/files/digest-fcclassic-0.1-r1 b/net-dialup/fcclassic/files/digest-fcclassic-0.1-r1
new file mode 100644
index 000000000000..b736f2ba7270
--- /dev/null
+++ b/net-dialup/fcclassic/files/digest-fcclassic-0.1-r1
@@ -0,0 +1,3 @@
+MD5 65196061f1e695e0e78a3939bb7870b8 fcclassic-0.1-0.src.rpm 279140
+RMD160 de91024d8ceafa58732c69c27e403b697eddc17f fcclassic-0.1-0.src.rpm 279140
+SHA256 5125202114517b49fd32bf108cbc811438b7791c4da4c6ee13af7b61cd2b6be7 fcclassic-0.1-0.src.rpm 279140