summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-06 02:00:34 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-06 02:00:34 +0000
commitdde865f9e497896eb9b240302bd6389d9a252b43 (patch)
treeb298b39a9aadd72b9ff6fc149bb96c364b281266 /net-dialup/fcpnp/fcpnp-0.1.ebuild
parentusing special openSUSE repository for AVM drivers from now on. (diff)
downloadgentoo-2-dde865f9e497896eb9b240302bd6389d9a252b43.tar.gz
gentoo-2-dde865f9e497896eb9b240302bd6389d9a252b43.tar.bz2
gentoo-2-dde865f9e497896eb9b240302bd6389d9a252b43.zip
using special openSUSE repository for AVM drivers from now on.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'net-dialup/fcpnp/fcpnp-0.1.ebuild')
-rw-r--r--net-dialup/fcpnp/fcpnp-0.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-dialup/fcpnp/fcpnp-0.1.ebuild b/net-dialup/fcpnp/fcpnp-0.1.ebuild
new file mode 100644
index 000000000000..19a61d66ef47
--- /dev/null
+++ b/net-dialup/fcpnp/fcpnp-0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpnp/fcpnp-0.1.ebuild,v 1.1 2008/01/06 02:00:33 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!Card PnP"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="!net-dialup/fritzcapi"
+RDEPEND="${DEPEND} net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-*.tar.bz2
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[01234]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ convert_to_m "src/Makefile"
+}