summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-30 14:34:03 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-30 14:34:03 +0000
commit16bbd3b7e571efdb45c96cad0681890e00bbf318 (patch)
tree8fd2777ab95791b742ba18b82312743f6c11b5d1 /net-dialup/fxusb
parentalpha/ia64/sparc stable wrt #207663 (diff)
downloadgentoo-2-16bbd3b7e571efdb45c96cad0681890e00bbf318.tar.gz
gentoo-2-16bbd3b7e571efdb45c96cad0681890e00bbf318.tar.bz2
gentoo-2-16bbd3b7e571efdb45c96cad0681890e00bbf318.zip
fixing string.h problem (see bug #202385) + patches for kernel 2.6.24 (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
(Portage version: 2.1.4)
Diffstat (limited to 'net-dialup/fxusb')
-rw-r--r--net-dialup/fxusb/ChangeLog9
-rw-r--r--net-dialup/fxusb/files/digest-fxusb-0.1-r13
-rw-r--r--net-dialup/fxusb/files/fxusb_kernel-2.6.24.diff46
-rw-r--r--net-dialup/fxusb/fxusb-0.1-r1.ebuild53
4 files changed, 110 insertions, 1 deletions
diff --git a/net-dialup/fxusb/ChangeLog b/net-dialup/fxusb/ChangeLog
index 39d37433a4f4..fcb9f87a9da0 100644
--- a/net-dialup/fxusb/ChangeLog
+++ b/net-dialup/fxusb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/fxusb
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/fxusb/ChangeLog,v 1.1 2008/01/06 02:07:08 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fxusb/ChangeLog,v 1.2 2008/01/30 14:34:02 sbriesen Exp $
+
+*fxusb-0.1-r1 (30 Jan 2008)
+
+ 30 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/fxusb_kernel-2.6.24.diff, +fxusb-0.1-r1.ebuild:
+ fixing string.h problem (see bug #202385) + patches for kernel 2.6.24
+ (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
*fxusb-0.1 (06 Jan 2008)
diff --git a/net-dialup/fxusb/files/digest-fxusb-0.1-r1 b/net-dialup/fxusb/files/digest-fxusb-0.1-r1
new file mode 100644
index 000000000000..65fb22ac67e7
--- /dev/null
+++ b/net-dialup/fxusb/files/digest-fxusb-0.1-r1
@@ -0,0 +1,3 @@
+MD5 4fa0d610a73779ca78df2f76cb1810c9 fxusb-0.1-0.src.rpm 868249
+RMD160 c82f20e1e3663df2e942223080a933afb8f11323 fxusb-0.1-0.src.rpm 868249
+SHA256 4fd1c48c7414665a97349819675da4551e6d5e70f4ae6749fbba0cc7cc431be6 fxusb-0.1-0.src.rpm 868249
diff --git a/net-dialup/fxusb/files/fxusb_kernel-2.6.24.diff b/net-dialup/fxusb/files/fxusb_kernel-2.6.24.diff
new file mode 100644
index 000000000000..b4444f2fb670
--- /dev/null
+++ b/net-dialup/fxusb/files/fxusb_kernel-2.6.24.diff
@@ -0,0 +1,46 @@
+--- src/driver.c.orig 2008-01-30 15:23:46.000000000 +0100
++++ src/driver.c 2008-01-30 15:23:47.000000000 +0100
+@@ -92,8 +92,12 @@
+ static DECLARE_WAIT_QUEUE_HEAD(capi_wait);
+ static DECLARE_WAIT_QUEUE_HEAD(tx_wait);
+ static DECLARE_WAIT_QUEUE_HEAD(rx_wait);
++static DECLARE_COMPLETION(hotplug); /* New DECLARE, <arnd.feldmueller@web.de> */
++static DECLARE_COMPLETION(notify); /* New DECLARE, <arnd.feldmueller@web.de> */
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ static DECLARE_MUTEX_LOCKED(hotplug);
+ static DECLARE_MUTEX_LOCKED(notify);
++#endif
+
+ #define SCHED_WAKEUP_CAPI { atomic_set (&thread_capi_flag, 1); wake_up_interruptible (&capi_wait); }
+ #define SCHED_WAKEUP { atomic_set (&got_kicked, 1); wake_up_interruptible (&wait); }
+@@ -787,7 +791,7 @@
+ close_func = func;
+ close_data = data;
+
+- INIT_WORK (&closing_work, closing_worker);
++ INIT_WORK (&closing_work, (work_func_t)closing_worker);
+ schedule_work (&closing_work);
+ LOG("Worker scheduled.\n");
+ } /* start_closing_worker */
+@@ -1211,7 +1215,10 @@
+ }
+ }
+ LOG("Scheduler thread stopped.\n");
++ complete(&hotplug); /* Complete Thread Sync here <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ up (&hotplug);
++ #endif
+ return 0;
+ } /* scheduler */
+
+@@ -1246,7 +1253,10 @@
+ SCHED_WAKEUP;
+ }
+ LOG("Scheduler thread signalled, waiting...\n");
++ wait_for_completion(&hotplug); /* Wait for complete Thread Sync <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ down (&hotplug);
++ #endif
+ LOG("Scheduler thread[%d] terminated.\n", thread_pid);
+ }
+ thread_pid = -1;
diff --git a/net-dialup/fxusb/fxusb-0.1-r1.ebuild b/net-dialup/fxusb/fxusb-0.1-r1.ebuild
new file mode 100644
index 000000000000..206d0e7ea1cd
--- /dev/null
+++ b/net-dialup/fxusb/fxusb-0.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fxusb/fxusb-0.1-r1.ebuild,v 1.1 2008/01/30 14:34:02 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!X USB"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="!net-dialup/fritzcapi"
+RDEPEND="${DEPEND} net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-suse[0-9][0-9]-[0-9].[0-9]*-[0-9]*.tar.gz
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[01234]:\s*\(.*\)|../\1|p" ../${PN}.spec | uniq)
+ epatch "${FILESDIR}/${PN}_kernel-2.6.24.diff"
+ convert_to_m src/Makefile
+
+ for i in lib/*-lib.o; do
+ einfo "Localize symbols in ${i##*/} ..."
+ objcopy -L memcmp -L memcpy -L memmove -L memset -L strcat \
+ -L strcmp -L strcpy -L strlen -L strncmp -L strncpy "${i}"
+ done
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc CAPI*.txt
+ dohtml *.html
+}