summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2004-11-07 21:44:26 +0000
committerAlin Năstac <mrness@gentoo.org>2004-11-07 21:44:26 +0000
commit457dea4548b591a45e9a50c1f98fe4aff385aaf6 (patch)
tree72e7901795508278c5746a68a465fea44b87a664 /net-dialup/gigaset-isdn
parent (Manifest recommit) (diff)
downloadgentoo-2-457dea4548b591a45e9a50c1f98fe4aff385aaf6.tar.gz
gentoo-2-457dea4548b591a45e9a50c1f98fe4aff385aaf6.tar.bz2
gentoo-2-457dea4548b591a45e9a50c1f98fe4aff385aaf6.zip
initial import from bug 58660
Diffstat (limited to 'net-dialup/gigaset-isdn')
-rw-r--r--net-dialup/gigaset-isdn/ChangeLog11
-rw-r--r--net-dialup/gigaset-isdn/Manifest4
-rw-r--r--net-dialup/gigaset-isdn/files/digest-gigaset-isdn-0.4.01
-rw-r--r--net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild44
-rw-r--r--net-dialup/gigaset-isdn/metadata.xml8
5 files changed, 68 insertions, 0 deletions
diff --git a/net-dialup/gigaset-isdn/ChangeLog b/net-dialup/gigaset-isdn/ChangeLog
new file mode 100644
index 000000000000..f9ca27619673
--- /dev/null
+++ b/net-dialup/gigaset-isdn/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-dialup/gigaset-isdn
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gigaset-isdn/ChangeLog,v 1.1 2004/11/07 21:44:26 mrness Exp $
+
+*gigaset-isdn-0.4.0 (07 Nov 2004)
+
+ 07 Nov 2004; Alin Nastac <mrness@gentoo.org>
+ +gigaset-isdn-0.4.0.ebuild, +metadata.xml :
+ Initial import. Thanks goes to Florian Zwoch <zwoch@backendmedia.com>
+ who submitted the first version of this ebuild (see bug #58660).
+ \ No newline at end of file
diff --git a/net-dialup/gigaset-isdn/Manifest b/net-dialup/gigaset-isdn/Manifest
new file mode 100644
index 000000000000..22f0a459bc3d
--- /dev/null
+++ b/net-dialup/gigaset-isdn/Manifest
@@ -0,0 +1,4 @@
+MD5 33bfbdbd71def45499283d86e0109823 gigaset-isdn-0.4.0.ebuild 932
+MD5 bcb8da102fb210674bba37f6ae00d38f metadata.xml 271
+MD5 ddb149d2c615a3b64364b97cea0c03f4 ChangeLog 395
+MD5 a283ea44b003b4bf0c6fd0dfcb336b22 files/digest-gigaset-isdn-0.4.0 66
diff --git a/net-dialup/gigaset-isdn/files/digest-gigaset-isdn-0.4.0 b/net-dialup/gigaset-isdn/files/digest-gigaset-isdn-0.4.0
new file mode 100644
index 000000000000..9e79ec8b11a8
--- /dev/null
+++ b/net-dialup/gigaset-isdn/files/digest-gigaset-isdn-0.4.0
@@ -0,0 +1 @@
+MD5 65d2999b63c89af64646c522077d614f gigaset-0.4.0.tar.bz2 146255
diff --git a/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild b/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild
new file mode 100644
index 000000000000..830636ac82d9
--- /dev/null
+++ b/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild,v 1.1 2004/11/07 21:44:26 mrness Exp $
+
+inherit kernel-mod
+
+MY_P=${P/-isdn/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Kernel driver for Gigaset 307X/M105/M101 and compatible ISDN adapters."
+HOMEPAGE="http://gigaset307x.sourceforge.net/"
+LICENSE="GPL-2"
+DEPEND="virtual/linux-sources"
+
+SRC_URI="mirror://sourceforge/gigaset307x/${MY_P}.tar.bz2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug"
+
+src_compile() {
+ check_KV
+ cd "${S}"
+ ./configure --kernel=${KV} --kerneldir=${KV_DIR} --root=${D} --prefix=/usr \
+ --with-ring `use_with debug`
+
+ (
+ unset ARCH
+ emake || die "Compilation failed"
+ )
+}
+
+src_install () {
+ check_KV
+ cd "${S}"
+ #Disable depmod while in sandbox
+ sed -i -e 's:.*depmod :#&:' generic/post
+ einstall ROOT=${D} || die "Failed to install drivers"
+
+ dodoc README Release.notes TODO known_bugs.txt
+}
+
+pkg_postinst () {
+ check_KV
+ depmod -ae ${KV}
+}
diff --git a/net-dialup/gigaset-isdn/metadata.xml b/net-dialup/gigaset-isdn/metadata.xml
new file mode 100644
index 000000000000..135da7c6ffd5
--- /dev/null
+++ b/net-dialup/gigaset-isdn/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-dialup</herd>
+<longdescription>
+Kernel driver for Gigaset 307X/M105/M101 and compatible ISDN adapters.
+</longdescription>
+</pkgmetadata>