summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-07-03 09:41:20 +0000
committerAlin Năstac <mrness@gentoo.org>2005-07-03 09:41:20 +0000
commit9b19f2bb0ef13e34c720c5d544dd8e1878d8aa53 (patch)
treec79f0068bc7801d9cc7381cbd1e22bdde7bc611d /net-dialup/ivam2/ivam2-0.3-r1.ebuild
parentAdd ~alpha keyword. (diff)
downloadgentoo-2-9b19f2bb0ef13e34c720c5d544dd8e1878d8aa53.tar.gz
gentoo-2-9b19f2bb0ef13e34c720c5d544dd8e1878d8aa53.tar.bz2
gentoo-2-9b19f2bb0ef13e34c720c5d544dd8e1878d8aa53.zip
fix dependencies (#96937); use openssl as an alternative base64 encoder
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-dialup/ivam2/ivam2-0.3-r1.ebuild')
-rw-r--r--net-dialup/ivam2/ivam2-0.3-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-dialup/ivam2/ivam2-0.3-r1.ebuild b/net-dialup/ivam2/ivam2-0.3-r1.ebuild
new file mode 100644
index 000000000000..cdaddd1b17b2
--- /dev/null
+++ b/net-dialup/ivam2/ivam2-0.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ivam2/ivam2-0.3-r1.ebuild,v 1.1 2005/07/03 09:41:20 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic phone answering machine software for ISDN"
+SRC_URI="http://0pointer.de/lennart/projects/ivam2/${P}.tar.gz"
+HOMEPAGE="http://0pointer.de/lennart/projects/ivam2/"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+IUSE=""
+SLOT="0"
+
+DEPEND="virtual/libc
+ dev-libs/liboop
+ >=dev-libs/libdaemon-0.4
+ >=dev-lang/python-2.3
+ net-dialup/isdn4k-utils"
+RDEPEND="${DEPEND}
+ media-sound/sox
+ media-sound/vorbis-tools
+ || ( net-mail/metamail dev-libs/openssl )" #needed for base64 encoding
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-base64-enc.patch
+}
+
+src_compile() {
+ local myconf="--disable-lynx --disable-xmltoman --disable-gengetopt"
+ econf $myconf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ keepdir /var/spool/ivam2
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc doc/{README,README.VoiceBox,TODO}
+ dohtml doc/*.{html,css}
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/ivam2.init ivam2
+}
+
+pkg_preinst() {
+ enewgroup ivam || die "Problem adding ivam group"
+ enewuser ivam -1 /bin/false /dev/null ivam || die "Problem adding ivam user"
+}
+
+pkg_postinst() {
+ chown ivam:ivam /var/spool/ivam2
+}