summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-19 17:19:08 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-19 17:19:08 +0000
commitac71f6bad2989bdc06a50034e1c6e35479c0e57f (patch)
tree8c34672edbdbaf327574e4780311770267dd833c /net-dialup/minicom
parentapp-mobilephone/obex-data-server is required by obexftp backend (diff)
downloadgentoo-2-ac71f6bad2989bdc06a50034e1c6e35479c0e57f.tar.gz
gentoo-2-ac71f6bad2989bdc06a50034e1c6e35479c0e57f.tar.bz2
gentoo-2-ac71f6bad2989bdc06a50034e1c6e35479c0e57f.zip
Bump to 2.4, thanks to Tim Harder. Fixes #304167
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup/minicom')
-rw-r--r--net-dialup/minicom/ChangeLog9
-rw-r--r--net-dialup/minicom/minicom-2.4.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/net-dialup/minicom/ChangeLog b/net-dialup/minicom/ChangeLog
index 5b913ca2f954..bfb8566406c4 100644
--- a/net-dialup/minicom/ChangeLog
+++ b/net-dialup/minicom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/minicom
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/ChangeLog,v 1.73 2009/07/11 20:35:53 josejx Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/ChangeLog,v 1.74 2010/02/19 17:19:08 patrick Exp $
+
+*minicom-2.4 (19 Feb 2010)
+
+ 19 Feb 2010; Patrick Lauer <patrick@gentoo.org> +minicom-2.4.ebuild:
+ Bump to 2.4, thanks to Tim Harder. Fixes #304167
11 Jul 2009; Joseph Jezak <josejx@gentoo.org> minicom-2.3-r2.ebuild:
Marked ppc stable for bug #274781.
diff --git a/net-dialup/minicom/minicom-2.4.ebuild b/net-dialup/minicom/minicom-2.4.ebuild
new file mode 100644
index 000000000000..bd666b8b85b5
--- /dev/null
+++ b/net-dialup/minicom/minicom-2.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/minicom-2.4.ebuild,v 1.1 2010/02/19 17:19:08 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+STUPID_NUM="3195"
+
+DESCRIPTION="Serial Communication Program"
+HOMEPAGE="http://alioth.debian.org/projects/minicom"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+COMMON_DEPEND="sys-libs/ncurses"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${COMMON_DEPEND}
+ net-dialup/lrzsz"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" cs da de es fi fr hu id ja nb pl pt_BR ro ru rw sv vi zh_TW"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.3-gentoo-runscript.patch
+}
+
+src_configure() {
+ econf --sysconfdir=/etc/${PN} \
+ $(use_enable nls) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "einstall failed"
+
+ dodoc AUTHORS ChangeLog NEWS README doc/minicom.FAQ
+ insinto /etc/minicom
+ doins "${FILESDIR}"/minirc.dfl
+}
+
+pkg_preinst() {
+ [[ -s ${ROOT}/etc/minicom/minirc.dfl ]] \
+ && rm -f "${D}"/etc/minicom/minirc.dfl
+}