summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-08-28 15:37:20 +0000
committerTilman Klar <phoenix@gentoo.org>2002-08-28 15:37:20 +0000
commitb18f9353e4adaca6a740c91bd653d4f7c26e6a1a (patch)
tree0b40dbeb254ef94887130937e60b2e749e608c44 /net-dialup/ppp
parentFresco-base shouldnt be in there (diff)
downloadgentoo-2-b18f9353e4adaca6a740c91bd653d4f7c26e6a1a.tar.gz
gentoo-2-b18f9353e4adaca6a740c91bd653d4f7c26e6a1a.tar.bz2
gentoo-2-b18f9353e4adaca6a740c91bd653d4f7c26e6a1a.zip
ppp-2.4.1-r11 supports the ipv6 useflag.
Diffstat (limited to 'net-dialup/ppp')
-rw-r--r--net-dialup/ppp/ChangeLog9
-rw-r--r--net-dialup/ppp/files/digest-ppp-2.4.1-r111
-rw-r--r--net-dialup/ppp/ppp-2.4.1-r11.ebuild115
3 files changed, 124 insertions, 1 deletions
diff --git a/net-dialup/ppp/ChangeLog b/net-dialup/ppp/ChangeLog
index 230c60fc805a..c2f7c7ea14c6 100644
--- a/net-dialup/ppp/ChangeLog
+++ b/net-dialup/ppp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/ppp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.7 2002/08/03 16:19:50 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.8 2002/08/28 15:37:20 phoenix Exp $
+
+*ppp-2.4.1-r11 (28 Aug 2002)
+
+ 3 Aug 2002; phoen][x <phoenix@gentoo.org> ppp-2.4.1-r11.ebuild :
+
+ Added ipv6 useflag support.
+ This closes bug 6972.
*ppp-2.4.1-r10 (31 Jul 2002)
diff --git a/net-dialup/ppp/files/digest-ppp-2.4.1-r11 b/net-dialup/ppp/files/digest-ppp-2.4.1-r11
new file mode 100644
index 000000000000..b3c7b1676065
--- /dev/null
+++ b/net-dialup/ppp/files/digest-ppp-2.4.1-r11
@@ -0,0 +1 @@
+MD5 7f655448fbb6bebcede7a515fbcd481e ppp-2.4.1-pppoe4.tgz 556218
diff --git a/net-dialup/ppp/ppp-2.4.1-r11.ebuild b/net-dialup/ppp/ppp-2.4.1-r11.ebuild
new file mode 100644
index 000000000000..35b5181df235
--- /dev/null
+++ b/net-dialup/ppp/ppp-2.4.1-r11.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.1-r11.ebuild,v 1.1 2002/08/28 15:37:20 phoenix Exp $
+
+S=${WORKDIR}/${P}.pppoe4
+DESCRIPTION="Point-to-point protocol - patched for pppoe"
+SRC_URI="http://www.shoshin.uwaterloo.ca/~mostrows/${P}-pppoe4.tgz"
+HOMEPAGE="http://www.samba.org/ppp"
+
+DEPEND="virtual/glibc"
+PROVIDE="virtual/pppd"
+
+SLOT="0"
+LICENSE="BSD GPL"
+KEYWORDS="x86 ppc"
+
+src_compile() {
+
+ use crypt && {
+ zcat ${FILESDIR}/ppp-2.4.1-openssl-0.9.6-mppe-patch.gz | patch -p1
+ patch -p1 < ${FILESDIR}/ppp-2.4.1-MSCHAPv2-fix.patch
+ }
+
+ patch -p0 < ${FILESDIR}/${P}-r10.patch
+
+ ./configure --prefix=/usr || die
+
+ #fix Makefiles to compile optimized
+ cd pppd
+ mv Makefile Makefile.orig
+ if([ `use ipv6` ]) then
+ sed -e "s:COPTS = -O2 -pipe -Wall -g:COPTS = ${CFLAGS}:" \
+ -e "s/LIBS =/LIBS = -lcrypt/" \
+ -e "s/#HAVE_INET6/HAVE_INET6/" \
+ Makefile.orig > Makefile
+ else
+ sed -e "s:COPTS = -O2 -pipe -Wall -g:COPTS = ${CFLAGS}:" \
+ -e "s/LIBS =/LIBS = -lcrypt/" \
+ Makefile.orig > Makefile
+ fi
+
+ cd plugins
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS\t= -g -O2:CFLAGS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd pppoe
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS\t= -g :CFLAGS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd ../../../pppstats
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS= -O:COPTS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd ../chat
+ mv Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ../pppdump
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS= -O:CFLAGS= ${CFLAGS}:" Makefile.orig > Makefile
+ cd ..
+
+ export CC=gcc
+
+ emake || die
+}
+
+src_install() {
+ for y in chat pppd pppdump pppstats
+ do
+ doman ${y}/${y}.8
+ dosbin ${y}/${y}
+ done
+
+ chmod u+s-w ${D}/usr/sbin/pppd
+ chown root:daemon ${D}/usr/sbin/pppstats
+
+ dodir /etc/ppp/peers
+ insinto /etc/ppp
+ insopts -m0600
+ doins etc.ppp/pap-secrets etc.ppp/chap-secrets
+ insopts -m0644
+ doins etc.ppp/options
+
+ dolib.so pppd/plugins/minconn.so
+ dolib.so pppd/plugins/passprompt.so
+ dolib.so pppd/plugins/pppoe/pppoe.so
+ dodir /usr/lib/pppd/$(awk -F '"' '/VERSION/ {print $2}' pppd/patchlevel.h)
+ mv ${D}/usr/lib/*.so ${D}/usr/lib/pppd/$(awk -F '"' '/VERSION/ {print $2}' pppd/patchlevel.h)
+ insinto /etc/modules.d
+ newins ${FILESDIR}/modules.ppp ppp
+
+ dodoc PLUGINS README* SETUP Changes-2.3 FAQ
+ dohtml ${FILESDIR}/pppoe.html
+
+# This will have to be updated to work with the new net.ppp0
+# # Added a couple scripts to simplify dialing up
+# # borrowed from debian, man they got some nice little apps :-)
+# dosbin ${FILESDIR}/pon
+# dosbin ${FILESDIR}/poff
+# doman ${FILESDIR}/pon.1
+}
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}dev/.devfsd ]
+ then
+ if [ ! -e ${ROOT}dev/ppp ]; then
+ mknod ${ROOT}dev/ppp c 108 0
+ fi
+ fi
+ if [ "$ROOT" = "/" ]
+ then
+ /usr/sbin/update-modules
+ fi
+ einfo "to enable kernel-pppoe read html/pppoe.html in the doc-directory"
+}