summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-04-02 07:11:33 +0000
committerAlin Năstac <mrness@gentoo.org>2006-04-02 07:11:33 +0000
commit3ddb14751e93f8d8559e91d469728116b4eca686 (patch)
treebb93671bab29758239124ee1bf7ffd2aee3b6518 /net-dialup/tkvoice/tkvoice-1.5.ebuild
parentBug #124309, fixes for new flex, based on submission by @4u <4u@vplace.de>. (diff)
downloadgentoo-2-3ddb14751e93f8d8559e91d469728116b4eca686.tar.gz
gentoo-2-3ddb14751e93f8d8559e91d469728116b4eca686.tar.bz2
gentoo-2-3ddb14751e93f8d8559e91d469728116b4eca686.zip
Initial import from bug #125266.
(Portage version: 2.0.54)
Diffstat (limited to 'net-dialup/tkvoice/tkvoice-1.5.ebuild')
-rw-r--r--net-dialup/tkvoice/tkvoice-1.5.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-dialup/tkvoice/tkvoice-1.5.ebuild b/net-dialup/tkvoice/tkvoice-1.5.ebuild
new file mode 100644
index 000000000000..ba7741c07e10
--- /dev/null
+++ b/net-dialup/tkvoice/tkvoice-1.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/tkvoice/tkvoice-1.5.ebuild,v 1.1 2006/04/02 07:11:32 mrness Exp $
+
+DESCRIPTION="TkVoice - Voice mail and Fax frontend program"
+HOMEPAGE="http://tkvoice.netfirms.com"
+SRC_URI="http://tkvoice.netfirms.com/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="dev-lang/tk
+ media-libs/netpbm
+ media-sound/sox
+ net-dialup/mgetty"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e "s:/usr/local/etc:/etc:g; s:/usr/local/bin:/usr/bin:g; s:/usr/local/tkvoice:/usr/lib/${P}:g" \
+ "${S}/tkvoice" "${S}/TCL/tkvfaq.tcl" "${S}/TCL/tkvsetupvoice.tcl"
+ sed -i -e "s:set STARTDIR .*:set STARTDIR /usr/lib/${P}:" \
+ "${S}/tkvoice"
+}
+
+src_install()
+{
+ exeinto /usr/bin
+ doexe ${PN}
+ insinto /usr/lib/${P}/TCL
+ doins TCL/*
+ insinto /usr/lib/${P}/image
+ doins image/*
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}/${PN}.desktop"
+ insinto /usr/share/pixmaps
+ doins ${PN}.xpm
+
+ dodoc BUGS FAQ README TODO
+}
+
+pkg_postinst()
+{
+ einfo "${P} has been installed. Run /usr/bin/${PN}."
+ einfo "For more information, see the home page, ${HOMEPAGE}"
+ einfo "or consult the documentation for this program as well as"
+ einfo "for mgetty/vgetty."
+}