summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-11-08 12:59:16 +0000
committerAlin Năstac <mrness@gentoo.org>2007-11-08 12:59:16 +0000
commit375c68ce5e3a6ac3c8c3d2c986705abf6d34643d (patch)
treeea616ff193f01ab453abcaea9bf218032091b97f /net-dialup
parentAdd patch and bump net-snmp-5.4 for 198346 (diff)
downloadgentoo-2-375c68ce5e3a6ac3c8c3d2c986705abf6d34643d.tar.gz
gentoo-2-375c68ce5e3a6ac3c8c3d2c986705abf6d34643d.tar.bz2
gentoo-2-375c68ce5e3a6ac3c8c3d2c986705abf6d34643d.zip
Drop kernel 2.4 support (#198258). Version bump.
(Portage version: 2.1.3.16)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ltmodem/ChangeLog7
-rw-r--r--net-dialup/ltmodem/files/digest-ltmodem-2.6.93
-rw-r--r--net-dialup/ltmodem/ltmodem-2.6.9.ebuild82
3 files changed, 91 insertions, 1 deletions
diff --git a/net-dialup/ltmodem/ChangeLog b/net-dialup/ltmodem/ChangeLog
index 27eb193413e6..5c2d361e6bd1 100644
--- a/net-dialup/ltmodem/ChangeLog
+++ b/net-dialup/ltmodem/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/ltmodem
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ltmodem/ChangeLog,v 1.35 2007/07/02 14:45:03 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ltmodem/ChangeLog,v 1.36 2007/11/08 12:59:15 mrness Exp $
+
+*ltmodem-2.6.9 (08 Nov 2007)
+
+ 08 Nov 2007; Alin Năstac <mrness@gentoo.org> +ltmodem-2.6.9.ebuild:
+ Drop kernel 2.4 support (#198258). Version bump.
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
ltmodem-8.31_alpha10-r3.ebuild:
diff --git a/net-dialup/ltmodem/files/digest-ltmodem-2.6.9 b/net-dialup/ltmodem/files/digest-ltmodem-2.6.9
new file mode 100644
index 000000000000..1a13ae507521
--- /dev/null
+++ b/net-dialup/ltmodem/files/digest-ltmodem-2.6.9
@@ -0,0 +1,3 @@
+MD5 de5116ffc872c434ced9ed6fcc00b15e ltmodem-2.6-alk-9.tar.bz2 436144
+RMD160 cba66ad674cd4fdb9254041e5f8ae70a52996b67 ltmodem-2.6-alk-9.tar.bz2 436144
+SHA256 fb5082cf62434be59a32dc8bd304d9946ba275412057dc439bc569e8be71293f ltmodem-2.6-alk-9.tar.bz2 436144
diff --git a/net-dialup/ltmodem/ltmodem-2.6.9.ebuild b/net-dialup/ltmodem/ltmodem-2.6.9.ebuild
new file mode 100644
index 000000000000..e88cb7e80a35
--- /dev/null
+++ b/net-dialup/ltmodem/ltmodem-2.6.9.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ltmodem/ltmodem-2.6.9.ebuild,v 1.1 2007/11/08 12:59:15 mrness Exp $
+
+inherit linux-mod
+
+MY_ALK_VER="${PV%.*}-alk-${PV##*.}"
+
+DESCRIPTION="Winmodems with Lucent Apollo (ISA) and Mars (PCI) chipsets"
+HOMEPAGE="http://linmodems.technion.ac.il/"
+SRC_URI="http://linmodems.technion.ac.il/packages/ltmodem/kernel-2.6/ltmodem-${MY_ALK_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+
+RESTRICT="userpriv"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_ALK_VER}"
+
+MODULE_NAMES="ltmodem(ltmodem:) ltserial(ltmodem:)"
+MODULESD_LTMODEM_ALIASES=(
+ "char-major-62 ltserial"
+ "/dev/tts/LT0 ltserial"
+ "/dev/modem ltserial"
+)
+CONFIG_CHECK="SERIAL_8250"
+SERIAL_8250_ERROR="This driver requires you to compile your kernel with serial core (CONFIG_SERIAL_8250) support."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is 2 4; then
+ eerror "This driver works only with 2.6 kernels!"
+ die "unsupported kernel detected"
+ fi
+
+ BUILD_TARGETS="module"
+ BUILD_PARAMS="KERNEL_DIR='${KV_DIR}'"
+}
+
+src_install() {
+ # Add configuration for udev
+ insinto /etc/udev/rules.d/; newins "${FILESDIR}/ltmodem_udev" 55-ltmodem.rules
+
+ # install kernel module
+ linux-mod_src_install
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ if [ "$ROOT" = "/" ]; then
+ /sbin/update-modules
+ fi
+
+ # Make some devices if we aren't using udev
+ if [ -e "${ROOT}/dev/.udev" ]; then
+ ebegin "Restarting udev to reread udev rules"
+ udevstart
+ eend $?
+ else
+ mknod --mode=0660 /dev/ttyLTM0 c 62 64 && chgrp dialout /dev/ttyLTM0
+ fi
+ elog "Use /dev/ttyLTM0 to access modem"
+
+ echo
+ ewarn "Remember, in order to access the modem,"
+ ewarn "you have to be in the 'dialout' group."
+ ewarn "Also, if your dialing application use locking mechanism (e.g wvdial),"
+ ewarn "you should have write access to /var/lock directory."
+
+ if linux_chkconfig_present SMP ; then
+ ewarn
+ ewarn "Please note that Linux support for SMP (symmetric multi processor)"
+ ewarn "is reported to be incompatible with this driver!"
+ ewarn "In case it doesn't work, you should try first to disable CONFIG_SMP in your kernel."
+ fi
+}