summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-01-29 11:45:10 +0000
committerAlin Năstac <mrness@gentoo.org>2008-01-29 11:45:10 +0000
commit49660b508756fce691bc47566a6bacc6838747ad (patch)
treef734c9d92bce20c07e54c428d6124037ed7e64ab /net-dialup
parentstable x86, security bug 206502 (diff)
downloadgentoo-2-49660b508756fce691bc47566a6bacc6838747ad.tar.gz
gentoo-2-49660b508756fce691bc47566a6bacc6838747ad.tar.bz2
gentoo-2-49660b508756fce691bc47566a6bacc6838747ad.zip
Fix broken compilation on hosts with kernel 2.6.24 (#207647).
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/openadsl/ChangeLog9
-rw-r--r--net-dialup/openadsl/files/openadsl-kernel-2.6.patch27
-rw-r--r--net-dialup/openadsl/files/openadsl-makefile.2.6.patch11
-rw-r--r--net-dialup/openadsl/openadsl-4.0.24.ebuild6
4 files changed, 37 insertions, 16 deletions
diff --git a/net-dialup/openadsl/ChangeLog b/net-dialup/openadsl/ChangeLog
index ebfa5ba66ac0..1b70d9894915 100644
--- a/net-dialup/openadsl/ChangeLog
+++ b/net-dialup/openadsl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/openadsl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/openadsl/ChangeLog,v 1.1 2007/08/21 20:55:09 mrness Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/openadsl/ChangeLog,v 1.2 2008/01/29 11:45:09 mrness Exp $
+
+ 29 Jan 2008; Alin Năstac <mrness@gentoo.org>
+ +files/openadsl-kernel-2.6.patch, -files/openadsl-makefile.2.6.patch,
+ openadsl-4.0.24.ebuild:
+ Fix broken compilation on hosts with kernel 2.6.24 (#207647).
*openadsl-4.0.24 (21 Aug 2007)
diff --git a/net-dialup/openadsl/files/openadsl-kernel-2.6.patch b/net-dialup/openadsl/files/openadsl-kernel-2.6.patch
new file mode 100644
index 000000000000..664677d310d1
--- /dev/null
+++ b/net-dialup/openadsl/files/openadsl-kernel-2.6.patch
@@ -0,0 +1,27 @@
+diff -Nru pulsar-4.0.24.orig/makefile.2.6 pulsar-4.0.24/makefile.2.6
+--- pulsar-4.0.24.orig/makefile.2.6 2007-06-26 09:49:40.000000000 +0300
++++ pulsar-4.0.24/makefile.2.6 2008-01-29 13:42:52.000000000 +0200
+@@ -5,7 +5,7 @@
+
+ ifneq ($(KERNELRELEASE),)
+
+-GCC = $(shell ${CC} --version | head -n 1 | sed -e 's/[^0-9. ]//g;s/^ *//;s\[.].*\\g')
++GCC = $(shell ${CC} --version | head -n 1 | sed -e 's/[[:alnum:]-]*//;s/[^0-9. ]//g;s/^ *//;s\[.].*\\g')
+
+ obj-m := pulsar_atm.o
+ pulsar_atm-lib := libpulsar_fw$(GCC).a
+diff -Nru pulsar-4.0.24.orig/pulsar.c pulsar-4.0.24/pulsar.c
+--- pulsar-4.0.24.orig/pulsar.c 2007-06-29 02:59:21.000000000 +0300
++++ pulsar-4.0.24/pulsar.c 2008-01-29 13:42:18.000000000 +0200
+@@ -1015,7 +1015,11 @@
+
+ /* Register interrupt */
+ adsl_irq_disable(pmodem);
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ err = request_irq(pci_dev->irq, isr, SA_SHIRQ, name, pmodem);
++#else
++ err = request_irq(pci_dev->irq, isr, IRQF_SHARED, name, pmodem);
++#endif
+ if (err) {
+ printk(KERN_ERR "%s: IRQ request failure\n", name);
+ goto pulsar_init_exit_irq;
diff --git a/net-dialup/openadsl/files/openadsl-makefile.2.6.patch b/net-dialup/openadsl/files/openadsl-makefile.2.6.patch
deleted file mode 100644
index 227fbab98a89..000000000000
--- a/net-dialup/openadsl/files/openadsl-makefile.2.6.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- makefile.2.6.old 2007-08-03 00:19:53.045547531 +0100
-+++ makefile.2.6 2007-08-03 00:20:21.297216989 +0100
-@@ -5,7 +5,7 @@
-
- ifneq ($(KERNELRELEASE),)
-
--GCC = $(shell ${CC} --version | head -n 1 | sed -e 's/[^0-9. ]//g;s/^ *//;s\[.].*\\g')
-+GCC = $(shell ${CC} --version | head -n 1 | sed -e 's/[[:alnum:]-]*//;s/[^0-9. ]//g;s/^ *//;s\[.].*\\g')
-
- obj-m := pulsar_atm.o
- pulsar_atm-lib := libpulsar_fw$(GCC).a
diff --git a/net-dialup/openadsl/openadsl-4.0.24.ebuild b/net-dialup/openadsl/openadsl-4.0.24.ebuild
index 604060a46651..4be51980c70e 100644
--- a/net-dialup/openadsl/openadsl-4.0.24.ebuild
+++ b/net-dialup/openadsl/openadsl-4.0.24.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/openadsl/openadsl-4.0.24.ebuild,v 1.1 2007/08/21 20:55:09 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/openadsl/openadsl-4.0.24.ebuild,v 1.2 2008/01/29 11:45:09 mrness Exp $
inherit linux-mod
@@ -31,7 +31,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${PN}-makefile.2.6.patch"
+ epatch "${FILESDIR}/${PN}-kernel-2.6.patch"
if kernel_is lt 2 6 0 ; then
mv "${S}"/makefile.2.4 "${S}"/Makefile || die "unable to copy Makefile"