summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-04-08 17:32:00 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-04-08 17:32:00 +0000
commit8cbe2ab7cf1d3d1670143e8e23cc36cec2ea7ebb (patch)
tree65f7b31fa4349195c6fd79db19ac84bd6795f18d /net-dialup
parent1.11.14 branch now supports the following: (diff)
downloadgentoo-2-8cbe2ab7cf1d3d1670143e8e23cc36cec2ea7ebb.tar.gz
gentoo-2-8cbe2ab7cf1d3d1670143e8e23cc36cec2ea7ebb.tar.bz2
gentoo-2-8cbe2ab7cf1d3d1670143e8e23cc36cec2ea7ebb.zip
version bump, remove old
(Portage version: 2.1_pre8)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/misdnuser/ChangeLog9
-rw-r--r--net-dialup/misdnuser/files/digest-misdnuser-0.1_pre200603071
-rw-r--r--net-dialup/misdnuser/misdnuser-0.1_pre20060307.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/net-dialup/misdnuser/ChangeLog b/net-dialup/misdnuser/ChangeLog
index 0d7ab70525c7..f7cdfb84581e 100644
--- a/net-dialup/misdnuser/ChangeLog
+++ b/net-dialup/misdnuser/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/misdnuser
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/misdnuser/ChangeLog,v 1.2 2006/02/28 00:15:55 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/misdnuser/ChangeLog,v 1.3 2006/04/08 17:32:00 genstef Exp $
+
+*misdnuser-0.1_pre20060307 (08 Apr 2006)
+
+ 08 Apr 2006; Stefan Schweizer <genstef@gentoo.org>
+ -misdnuser-0.1_pre20060203.ebuild, -misdnuser-0.1_pre20060222.ebuild,
+ +misdnuser-0.1_pre20060307.ebuild:
+ version bump, remove old
*misdnuser-0.1_pre20060222 (28 Feb 2006)
diff --git a/net-dialup/misdnuser/files/digest-misdnuser-0.1_pre20060307 b/net-dialup/misdnuser/files/digest-misdnuser-0.1_pre20060307
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/net-dialup/misdnuser/files/digest-misdnuser-0.1_pre20060307
@@ -0,0 +1 @@
+
diff --git a/net-dialup/misdnuser/misdnuser-0.1_pre20060307.ebuild b/net-dialup/misdnuser/misdnuser-0.1_pre20060307.ebuild
new file mode 100644
index 000000000000..6a9e5623bd3f
--- /dev/null
+++ b/net-dialup/misdnuser/misdnuser-0.1_pre20060307.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/misdnuser/misdnuser-0.1_pre20060307.ebuild,v 1.1 2006/04/08 17:32:00 genstef Exp $
+
+inherit flag-o-matic eutils cvs
+
+MY_P="mISDNuser"
+DESCRIPTION="mISDN (modular ISDN) kernel link library and includes"
+HOMEPAGE="http://www.isdn4linux.de/mISDN"
+SRC_URI=""
+ECVS_SERVER="cvs.isdn4linux.de:/i4ldev"
+ECVS_MODULE="${MY_P}"
+ECVS_PASS="readonly"
+ECVS_CO_OPTS="-D ${PV#*_pre}"
+ECVS_UP_OPTS="-dP ${ECVS_CO_OPTS}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+S=${WORKDIR}/${MY_P}
+RDEPEND=">=net-dialup/misdn-20051228"
+#DEPEND="voipisdn? ( media-sound/gsm
+# sys-libs/ncurses
+# sys-devel/flex )"
+
+src_unpack() {
+ cvs_src_unpack
+ cd ${S}
+# use voipisdn ||
+ mv voip voip.disabled
+}
+
+src_compile() {
+ append-flags -fPIC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dolib.a lib/libmISDN.a i4lnet/libisdnnet.a tenovis/lib/libtenovis.a
+
+ insinto /usr/include/mISDNuser
+ doins include/*.h tenovis/lib/tenovis.h i4lnet/*.h
+
+ dosbin example/loadfirm
+# use voipisdn && dobin voip/voipisdn
+}