summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-11-11 14:30:24 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-11-11 14:30:24 +0000
commit920ab031d0b0d0aedcb9a78928f7c04eb4467687 (patch)
treee9c5545a8a755f2606ad9074546a8115d3c5c72e /net-dialup
parentamd64 stable wrt #198564 (diff)
downloadgentoo-2-920ab031d0b0d0aedcb9a78928f7c04eb4467687.tar.gz
gentoo-2-920ab031d0b0d0aedcb9a78928f7c04eb4467687.tar.bz2
gentoo-2-920ab031d0b0d0aedcb9a78928f7c04eb4467687.zip
fix compile problems
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/capi4k-utils/ChangeLog6
-rw-r--r--net-dialup/capi4k-utils/capi4k-utils-20050718-r3.ebuild5
-rw-r--r--net-dialup/capi4k-utils/files/capi-compile.patch37
3 files changed, 46 insertions, 2 deletions
diff --git a/net-dialup/capi4k-utils/ChangeLog b/net-dialup/capi4k-utils/ChangeLog
index 93d45a82a604..5554e657c821 100644
--- a/net-dialup/capi4k-utils/ChangeLog
+++ b/net-dialup/capi4k-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/capi4k-utils
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/ChangeLog,v 1.57 2007/05/02 00:15:32 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/ChangeLog,v 1.58 2007/11/11 14:30:23 genstef Exp $
+
+ 11 Nov 2007; Stefan Schweizer <genstef@gentoo.org>
+ +files/capi-compile.patch, capi4k-utils-20050718-r3.ebuild:
+ fix compile problems
02 May 2007; Marius Mauch <genone@gentoo.org>
capi4k-utils-20050718-r3.ebuild:
diff --git a/net-dialup/capi4k-utils/capi4k-utils-20050718-r3.ebuild b/net-dialup/capi4k-utils/capi4k-utils-20050718-r3.ebuild
index 54cf5339650e..2cc7de1d6cd0 100644
--- a/net-dialup/capi4k-utils/capi4k-utils-20050718-r3.ebuild
+++ b/net-dialup/capi4k-utils/capi4k-utils-20050718-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/capi4k-utils-20050718-r3.ebuild,v 1.6 2007/05/02 00:15:32 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/capi4k-utils-20050718-r3.ebuild,v 1.7 2007/11/11 14:30:23 genstef Exp $
inherit eutils multilib linux-info
@@ -77,6 +77,9 @@ src_unpack() {
use fax || sed -i -e "s:^\(CONFIG_CAPIFAX=.*\)$:# \1:g" .config
# build pppdcapiplugin
use pppd || sed -i -e "s:^\(CONFIG_PPPDCAPIPLUGIN=.*\)$:# \1:g" .config
+
+ # compile fix
+ epatch "${FILESDIR}/capi-compile.patch"
}
src_compile() {
diff --git a/net-dialup/capi4k-utils/files/capi-compile.patch b/net-dialup/capi4k-utils/files/capi-compile.patch
new file mode 100644
index 000000000000..031cb83e05a5
--- /dev/null
+++ b/net-dialup/capi4k-utils/files/capi-compile.patch
@@ -0,0 +1,37 @@
+diff -ur capi4k-utils.orig/capi20/capi20.h capi4k-utils/capi20/capi20.h
+--- capi4k-utils.orig/capi20/capi20.h 2007-11-11 14:43:34.000000000 +0100
++++ capi4k-utils/capi20/capi20.h 2007-11-11 14:43:49.000000000 +0100
+@@ -62,9 +62,9 @@
+ int capi20ext_clr_flags(unsigned ApplID, unsigned flags);
+
+ char *capi20ext_get_tty_devname(unsigned applid, unsigned ncci,
+- char *buf, size_t size);
++ char *buf, unsigned int size);
+ char *capi20ext_get_raw_devname(unsigned applid, unsigned ncci,
+- char *buf, size_t size);
++ char *buf, unsigned int size);
+
+ int capi20ext_ncci_opencount(unsigned applid, unsigned ncci);
+
+diff -ur capi4k-utils.orig/capifax/id.h capi4k-utils/capifax/id.h
+--- capi4k-utils.orig/capifax/id.h 2007-11-11 14:43:34.000000000 +0100
++++ capi4k-utils/capifax/id.h 2007-11-11 14:44:07.000000000 +0100
+@@ -44,12 +44,12 @@
+
+ typedef struct {
+ _cbyte length;
+- _cword rate __attribute__ ((packed));
+- _cword resolution __attribute__ ((packed));
+- _cword format __attribute__ ((packed));
+- _cword pages __attribute__ ((packed));
+- _cbyte idlen __attribute__ ((packed));
+- _cbyte id[50] __attribute__ ((packed));
++ _cword rate;
++ _cword resolution;
++ _cword format;
++ _cword pages;
++ _cbyte idlen;
++ _cbyte id[50];
+ } faxNCPI_t;
+
+ extern const char *ConnectionStateString[7];