summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-04-11 17:05:45 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-04-11 17:05:45 +0000
commitd3e2180c0614cbd8b1e05bce0d39dc1e2f27cafc (patch)
tree5893f9dcaf3362477710198a3036e69fd4ee5bed /net-dns/bind-tools
parentstable amd64, bug 265307 (diff)
downloadgentoo-2-d3e2180c0614cbd8b1e05bce0d39dc1e2f27cafc.tar.gz
gentoo-2-d3e2180c0614cbd8b1e05bce0d39dc1e2f27cafc.tar.bz2
gentoo-2-d3e2180c0614cbd8b1e05bce0d39dc1e2f27cafc.zip
Version bump(s), #265095, #264301
(Portage version: 2.2_rc29/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/bind-tools')
-rw-r--r--net-dns/bind-tools/ChangeLog10
-rw-r--r--net-dns/bind-tools/bind-tools-9.4.3_p2.ebuild (renamed from net-dns/bind-tools/bind-tools-9.4.1_p1.ebuild)36
-rw-r--r--net-dns/bind-tools/bind-tools-9.5.1_p2.ebuild (renamed from net-dns/bind-tools/bind-tools-9.5.1_p1.ebuild)4
3 files changed, 31 insertions, 19 deletions
diff --git a/net-dns/bind-tools/ChangeLog b/net-dns/bind-tools/ChangeLog
index 744d76cf6843..7cc330e146bc 100644
--- a/net-dns/bind-tools/ChangeLog
+++ b/net-dns/bind-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-dns/bind-tools
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.124 2009/02/11 16:30:59 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.125 2009/04/11 17:05:45 dertobi123 Exp $
+
+*bind-tools-9.5.1_p2 (11 Apr 2009)
+*bind-tools-9.4.3_p2 (11 Apr 2009)
+
+ 11 Apr 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ -bind-tools-9.4.1_p1.ebuild, +bind-tools-9.4.3_p2.ebuild,
+ -bind-tools-9.5.1_p1.ebuild, +bind-tools-9.5.1_p2.ebuild:
+ Version bump(s), #265095, #264301
11 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
bind-tools-9.5.1_p1.ebuild, bind-tools-9.6.0_p1.ebuild:
diff --git a/net-dns/bind-tools/bind-tools-9.4.1_p1.ebuild b/net-dns/bind-tools/bind-tools-9.4.3_p2.ebuild
index 70bf5d23fc93..4ab7de35bfe3 100644
--- a/net-dns/bind-tools/bind-tools-9.4.1_p1.ebuild
+++ b/net-dns/bind-tools/bind-tools-9.4.3_p2.ebuild
@@ -1,23 +1,24 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.4.1_p1.ebuild,v 1.12 2008/08/02 12:22:05 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.4.3_p2.ebuild,v 1.1 2009/04/11 17:05:45 dertobi123 Exp $
inherit flag-o-matic
MY_PN=${PN//-tools}
-MY_PV=${PV/_p/-P}
-MY_P=${MY_PN}-${MY_PV}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="bind tools: dig, nslookup, and host"
+MY_PV=${PV/_p2/-P2}
+MY_P="${MY_PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
HOMEPAGE="http://www.isc.org/products/BIND/bind9.html"
SRC_URI="ftp://ftp.isc.org/isc/bind9/${MY_PV}/${MY_P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="idn ipv6"
-DEPEND="idn? ( || ( sys-libs/glibc dev-libs/libiconv ) )"
+DEPEND="idn? ( || ( sys-libs/glibc dev-libs/libiconv )
+ net-dns/idnkit )"
src_unpack() {
unpack ${A} || die
@@ -41,6 +42,9 @@ src_unpack() {
src_compile() {
local myconf=
use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --enable-ipv6=no"
+ use idn && myconf="${myconf} --with-idn"
+
+ has_version sys-libs/glibc || myconf="${myconf} --with-iconv"
econf ${myconf} || die "Configure failed"
@@ -56,13 +60,8 @@ src_compile() {
cd "${S}"/bin/nsupdate/
emake -j1 || die "make failed in /bin/nsupdate"
- use idn && {
- cd "${S}"/contrib/idn/idnkit-1.0-src
- local myconf=
- has_version sys-libs/glibc || myconf="${myconf} --with-iconv"
- econf ${myconf} || die "idn econf failed"
- emake -j1 || die "idn emake failed"
- }
+ cd "${S}"/bin/dnssec/
+ emake -j1 || die "make failed in /bin/dnssec"
}
src_install() {
@@ -74,6 +73,11 @@ src_install() {
cd "${S}"/bin/nsupdate
dobin nsupdate || die
- doman nsupdate.8 || die
+ doman nsupdate.1 || die
dohtml nsupdate.html || die
+
+ cd "${S}"/bin/dnssec
+ dobin dnssec-keygen || die
+ doman dnssec-keygen.8 || die
+ dohtml dnssec-keygen.html || die
}
diff --git a/net-dns/bind-tools/bind-tools-9.5.1_p1.ebuild b/net-dns/bind-tools/bind-tools-9.5.1_p2.ebuild
index ced392e370ab..ee8e13b87d38 100644
--- a/net-dns/bind-tools/bind-tools-9.5.1_p1.ebuild
+++ b/net-dns/bind-tools/bind-tools-9.5.1_p2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.5.1_p1.ebuild,v 1.2 2009/02/11 16:30:59 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.5.1_p2.ebuild,v 1.1 2009/04/11 17:05:45 dertobi123 Exp $
inherit flag-o-matic
MY_PN=${PN//-tools}
-MY_PV=${PV/_p1/-P1}
+MY_PV=${PV/_p2/-P2}
MY_P="${MY_PN}-${MY_PV}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"