summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-08-08 03:17:32 +0000
committerRoy Marples <uberlord@gentoo.org>2007-08-08 03:17:32 +0000
commit07f777a5fadc56e1478e919b4fba01b89ac8a37c (patch)
treef0a843da4b5047abb1be7004c369aab3b14eda08 /net-dns/ddclient
parentMarked ppc stable. (diff)
downloadgentoo-2-07f777a5fadc56e1478e919b4fba01b89ac8a37c.tar.gz
gentoo-2-07f777a5fadc56e1478e919b4fba01b89ac8a37c.tar.bz2
gentoo-2-07f777a5fadc56e1478e919b4fba01b89ac8a37c.zip
Init script works with baselayout-2, #170708 thanks to Paul Bredbury
(Portage version: 2.1.3.3)
Diffstat (limited to 'net-dns/ddclient')
-rw-r--r--net-dns/ddclient/ChangeLog8
-rw-r--r--net-dns/ddclient/ddclient-3.7.2-r1.ebuild79
-rw-r--r--net-dns/ddclient/files/ddclient.initd15
-rw-r--r--net-dns/ddclient/files/digest-ddclient-3.7.2-r13
4 files changed, 98 insertions, 7 deletions
diff --git a/net-dns/ddclient/ChangeLog b/net-dns/ddclient/ChangeLog
index 0b095b8d87f6..1d173dfcc038 100644
--- a/net-dns/ddclient/ChangeLog
+++ b/net-dns/ddclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/ddclient
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ChangeLog,v 1.26 2007/07/21 20:56:35 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ChangeLog,v 1.27 2007/08/08 03:17:32 uberlord Exp $
+
+*ddclient-3.7.2-r1 (08 Aug 2007)
+
+ 08 Aug 2007; Roy Marples <uberlord@gentoo.org> files/ddclient.initd,
+ +ddclient-3.7.2-r1.ebuild:
+ Init script works with baselayout-2, #170708 thanks to Paul Bredbury
*ddclient-3.7.2 (21 Jul 2007)
diff --git a/net-dns/ddclient/ddclient-3.7.2-r1.ebuild b/net-dns/ddclient/ddclient-3.7.2-r1.ebuild
new file mode 100644
index 000000000000..0e52473ede48
--- /dev/null
+++ b/net-dns/ddclient/ddclient-3.7.2-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ddclient-3.7.2-r1.ebuild,v 1.1 2007/08/08 03:17:32 uberlord Exp $
+
+inherit eutils
+
+DESCRIPTION="Perl updater client for dynamic DNS services"
+HOMEPAGE="http://ddclient.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl"
+
+RDEPEND=">=dev-lang/perl-5.1
+ ssl? ( dev-perl/IO-Socket-SSL )"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-reasonable-security.patch"
+
+ einfo "Applying version string fix"
+ if ! sed -i "s/3\.7\.1/$PV/" "$PN"; then
+ eerror "Failed to update ddclient's internal version string"
+ eerror 'ddclient 3.7.2 will erroneously report a version of 3.7.1'
+ fi
+
+ # Remove pid line, because it is specified in /etc/conf.d/ddclient
+ einfo "Applying PID setup"
+ if ! sed -i "/^pid=*/d" "sample-etc_${PN}.conf"; then
+ eerror "Failed to remove pid from /etc/$PN/$PN.conf"
+ eerror "Please set the PID in /etc/conf.d/$PN, not /etc/$PN/$PN.conf"
+ fi
+
+ if ! use ssl; then
+ einfo "Disabling ssl per your useflags"
+ sed -i "/^ssl=*/d" "sample-etc_${PN}.conf" ||
+ eerror "Failed to remove ssl from /etc/$PN/$PN.conf"
+ fi
+}
+
+src_install() {
+ dosbin ${PN} || die "dosbin failed"
+ dodoc README* Change* COPYRIGHT sample*
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die "newinitd failed"
+
+ # Filename of sample conf - use live filename if available
+ local sample=${PN}.conf
+ [[ -e "${ROOT}/etc/${PN}/${sample}" ]] && sample="${sample}.sample"
+
+ insinto /etc/${PN}
+ insopts -m 0640 -o root -g ${PN}
+ newins sample-etc_${PN}.conf "${sample}" || die "newins conf failed"
+
+ insinto /etc/conf.d
+ insopts -m 0644 -o root -g root
+ newins "${FILESDIR}"/${PN}.confd ${PN} || die "newins confd failed"
+
+ diropts -m 0755 -o ${PN} -g ${PN}
+ keepdir /var/{cache,run}/${PN}
+}
+pkg_postinst() {
+ use ssl && return
+ ewarn
+ ewarn "$PN will not have support for ssl, which means your dynamic DNS account"
+ ewarn "information -- including your password -- will be sent over the Internet in the"
+ ewarn "clear. To secure your information, add 'ssl' to your USEflags,"
+ ewarn "emerge -N ddclient, and add 'ssl=yes' to /etc/$PN/$PN.conf"
+ ewarn
+}
diff --git a/net-dns/ddclient/files/ddclient.initd b/net-dns/ddclient/files/ddclient.initd
index 3ec5283f9acb..db58c23aace6 100644
--- a/net-dns/ddclient/files/ddclient.initd
+++ b/net-dns/ddclient/files/ddclient.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/files/ddclient.initd,v 1.1 2006/09/08 00:22:30 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/files/ddclient.initd,v 1.2 2007/08/08 03:17:32 uberlord Exp $
# Default location if not specified in /etc/conf.d/ddclient
PIDFILE=${PIDFILE:-/var/run/ddclient/ddclient.pid}
@@ -15,8 +15,8 @@ depend() {
checkconfig() {
local conf="/etc/ddclient/ddclient.conf"
- if [[ -e "${conf}" ]] ; then
- if [[ -n "$(find /etc/ddclient -maxdepth 1 -name ddclient.conf -perm +0004)" ]] ; then
+ if [ -e "${conf}" ] ; then
+ if [ -n "$(find /etc/ddclient -maxdepth 1 -name ddclient.conf -perm +0004)" ] ; then
eerror "${conf} must not be world-readable. Run e.g.:"
eerror " chmod 640 ${conf}"
eerror " chown root:ddclient ${conf}"
@@ -31,16 +31,19 @@ checkconfig() {
start() {
checkconfig || return 1
- ebegin "Starting DDClient"
+ ebegin "Starting ${SVCNAME}"
start-stop-daemon \
--start \
--chuid ddclient \
- --exec /usr/sbin/ddclient -- -pid="${PIDFILE}"
+ --exec /usr/sbin/ddclient \
+ --name ddclient \
+ --pidfile "${PIDFILE}" \
+ -- -pid="${PIDFILE}"
eend $?
}
stop() {
- ebegin "Stopping DDClient"
+ ebegin "Stopping ${SVCNAME}"
start-stop-daemon \
--stop \
--signal USR1 \
diff --git a/net-dns/ddclient/files/digest-ddclient-3.7.2-r1 b/net-dns/ddclient/files/digest-ddclient-3.7.2-r1
new file mode 100644
index 000000000000..bd4c9926be21
--- /dev/null
+++ b/net-dns/ddclient/files/digest-ddclient-3.7.2-r1
@@ -0,0 +1,3 @@
+MD5 53fa5f06788f8732bff3ee7098fadc4d ddclient-3.7.2.tar.gz 87040
+RMD160 fed9642560d74f462179edae92b8346e08cd514e ddclient-3.7.2.tar.gz 87040
+SHA256 7aedbeb5f737cd46794393bdf166fe6b856dc6c97d402a5dcfbfe6247bb37fe2 ddclient-3.7.2.tar.gz 87040